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About this guide

This describes the various methods of monitoring process handling and of localizing errors
in One Identity Manager. It also explains advanced log configuration in
One Identity Manager.

It is assumed that you understand the concept and the architecture of
One Identity Manager. It is also assumed that you are thoroughly familiar with the
One Identity Manager tools.

You can find additional notes about error localization and troubleshooting in the other
One Identity Manager guides.

Available documentation

You can access One Identity Manager documentation in the Manager and in the Designer by
selecting the Help > Search menu item. Videos with additional information can be found
at www.YouTube.com/Oneldentity.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Monitoring process handling

The Job Queue Info program helps you check the current status of the services running in
the One Identity Manager network. It enables a detailed and comprehensive overview of
the requests in the Job queue and various One Identity Manager Service requests on the
servers. This program makes it easier to work with processes, supplies status information
during run-time and allows errors to be quickly recognized and debugged.

In the Job Queue Info program, you can:
e Monitor handling of Job queue processes.
e Monitor processing of the DBQueue.
» Monitor the status of the Job server and web server.
e Display the One Identity Manager Service log file.

e Display the system journal.

Working with the Job Queue Info
program

The Job Queue Info program has several views for the layout of processes and process
steps in the Job queue.

Some of the functions in Job Queue Info, for example certain menu items or shortcuts, can
only be used if the current user has the corresponding program functionality.

Menu items in Job Queue Info

Table 1: Meaning of items in the menu bar

Menu Menu Item Meaning Shortcut

Database New connection Establishes a database connection. Ctrl + Shift

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Menu Menu Item Meaning Shortcut

+ N

Close connection Closes the current database connection.

Change The logged in user can change the
password password.
Settings For configuring general program settings.
Exit Exits the program.

Filter Define filter The WHERE clause wizard is opened to

assist in defining a filter.

Delete filter Deletes the filter.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Menu Menu Item Meaning Shortcut
View Job queue Hides or shows the Job queue view.
Job server Hides or shows the Job server view.
Process History  Hides or shows the process history view.
Process archive  Hides or shows the process archive view.
NOTE: This view is only shown if a
One Identity Manager History Database
is configured in the TimeTrace.
For more information, see Declaring a
One Identity Manager History Database
in the TimeTrace.
Base objects Hides or shows the base object view.
Process Hides or shows the process view.
Process step Hides or shows the process step view.
Parameters Hides or shows the parameter view.
Affected objects Shows or hides the view for affected
objects.
Progress Hides or shows the progress view.
Server state Hides or shows the server state view.
DBQueue Hides or shows the DBQueue view.
System journal  Opens the system journal view.
Refresh view Updates the view. F5
Layout Restores the default layout of the program’s
graphical interface.
Help Community Opens the One Identity Manager community

Support portal
Training
Online

documentation

Search

(ONE IDENTITY

website.

Opens the One Identity Manager product
support website.

Opens the One Identity Manager training
portal website.

Opens the One Identity Manager
documentation website.

Opens the search dialog.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Menu

Menu Item Meaning Shortcut

Emergency stop Displays a dialog from which the system can

be stopped.
Job Queue Info  Opens program help.
help
Info Shows the version information for program.

Table 2: Meaning of the icons in the toolbar

Icon Meaning

= Creates new database connection.

& Closes current database connection.

] Hides or shows the Job queue view.

B Hides or shows the Job server view.

) Hides or shows the process history view.
= Hides or shows the process view.

E Hides or shows the process step view.
# Hides or shows the parameter view.

o] Emergency stop.

h i Opens WHERE clause wizard to set up a filter.
Y Deletes filter.

e Reload the data.

Views in the Job Queue Info

The Job Queue Info has several views for displaying and editing processes and process
steps in the Job queue.

Table 3: Job Queue Info views

View Description

Job queue This view shows the contents of the Job queue grouped by processes. In
the first level of the hierarchy, all the processes are shown with a process
count. If a process node is opened, all the processes are shown with start
times. The complete process with its hierarchy is displayed under a
process node. Each process step contains its success and failure branches
as sub elements.

= One Identity Manager 10.0 Process Monitoring and Troubleshooting
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View

Description

Job server

Process
History

Process
archive

Base objects

Process

Process step

Parameters

Affected
objects

(ONE IDENTITY

This view shows the Job queue contents sorted by executing servers. At
the first hierarchy level, all Job servers are displayed, with their counts of
the different processes, that exist in the Job queue for the Job server. If a
Job server node is opened, the process tasks are listed and the number of
process step per process task is shown. The process steps are listed by
start time under the process task node.

The view show processes that are already finished. The flow of process
handling is displayed in the order of the processes. You can limit the list of
processes in the process history to only processes with errors in the
program settings. If you select a failed process step, the entire error
message is shown in a tooltip.

The view displays processes that were handled including processes that
have already been archived in a History Database. By default, the
archived processes of the last 365 days are taken into account. Define
your own time interval for filters.

NOTE: This view is only shown if a One Identity Manager
History Database is configured in the TimeTrace.

For more information, see Declaring a One Identity Manager
History Database in the TimeTrace.

The process history entries and the current Job queue entries are
summarized here in this view for the object being processed. If an error
occurs during processing and the process handling is stopped (Frozen or
Overlimit status), you can analyze the previous processing sequence in
this view. Once all processes have been successfully handled for this
object the error messages are removed from the view.

This view gives an overview of how process steps are linked within a
process. In this way, the handling sequence of individual process steps for
large processes can be monitored better. After selecting a process, all its
process steps are displayed.

In this view detailed information is displayed for each process step. The
view shows the data structure for a process step at compilation time. After
selecting a process step, specific information from the Job queue is
mapped as well as each parameter of the selected process step with its
values.

After selecting a process step, the passing parameters of the process step
are displayed with their names and their values. If the selected node does
not represent a process step, the parameter view is cleared.

This view shows all objects that are affected by a process step.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
Guide 11
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View Description

Progress This view displays the number of entries in the Job queue is queried. The
current value is represented by a number and inserted, at the same time,
into a bar graph. The process step progress state is shown in different
colors.

Server state This view gives you a faster overview of all the Job servers and Web
servers available in the network.

DBQueue Calculation tasks in the DBQueue used for DBQueue Processor processing
are displayed in this view. The number, sort order and name of the queued
requests are displayed.

System Displays entries in the system journal.
journal

Updating views in the Job Queue Info

To update the views in the Job Queue Info, choose F5. If the view focus is on a base object
then the whole display is updated and the hierarchy tree is closed. This update refreshes
the contents of all views.This update also refreshes the contents of other views.

The views can only ever display a snap-shot of the queue because the contents of the Job
queue is continually changing. Therefore, when a node is opened or the view is updated,
the necessary information may have already been deleted from the Job queue. If this is the
case, the corresponding entry in the hierarchical display is deleted or the corresponding
element is not shown.

Changing the column configuration in the
Job Queue Info program

In some of the program views, you can specify which columns are to be displayed.

To specify which columns to display

e Select a node in the hierarchical display and select Configure columns from the
context menu.

Select the columns you want to display by moving through the list and accepting with
the arrow buttons, then change the order in which they are displayed.

To change the width of the columns on display

e Double-click a column boundary to optimize the column width.

e Use Shift + double-click for a column boundary to optimize the width of all
columns.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Changing program settings in the
Job Queue Info

You can adjust the program settings to suit your requirements. You can find the program
settings for the user configuration in the One Identity Manager database.

To change the program settings

e Inthe Job Queue Info, select the Database > Settings menu.

Language settings
« Common language: Language for formatting data, such as data formats, time
formats or number formats.

» Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Database queries

* Result limit: Number of entries to load and display for processes or process steps.

» Polling interval: Number of seconds between queries. The views are updated at
the end of every interval. If the value is @, the views are not updated. In this case,
use F5 to update.

Server state

e Job servers HTTP port: HTTP port at which the One Identity Manager Service
operates for polling the server state of the Job server. The default value is port 188e.

o Status query timeout (s): Maximum duration of a status query. Job servers that
do not respond within this time limit are considered unavailable.

Process history

e Only show processes with errors: Limits the process history display to processes
with errors. The setting does not effect how the process history is recorded, only how
it is displayed.

= One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Helpful keyboard shortcuts for working with
Job Queue Info

The following keyboard shortcuts are helpful for the daily work with Job Queue Info. Some
of the keyboard shortcuts are available only if the logged-in user has the corresponding
program functionality.

Table 4: Shortcuts in Job Queue Info

Shortcut Usage

F5 Reload the data.

Shift + Select or Ctrl + Select Multi-select process steps.

Ctrl + F2 Mark individual process steps with a bookmark.
F2 or Shift + F2 Switch between the marked process steps.
Ctrl+ C Copy selected data to the clipboard.

Ctrl + T Set new start time for a process step.

Ctrl + R Change the number of retries for a process step.
Ctrl + S Reset start time of a process step.

Ctrl+ P Increase the priority of a process step.

Filters for Job queue, process history,
and process archive

If you want to run specific search queries against the Job queue, process history, or the
process archive more often, use filters. You can create your own (private) filters or
public filters.

Filtering Job queue entries

In the Job queue, Base objects and Job server views, you can filter the current Job
queue entries.

To create filters for the Job queue in the Job Queue Info program

1. Inthe Job Queue Info, select the view with the entries you want to filter.

2. Select the Filter > Define filter menu item.

= One Identity Manager 10.0 Process Monitoring and Troubleshooting
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3. Inthe Define a filter dialog, in the Filter method pane, select your preferred filter
method. Custom filters allow you to run the following searches:

e Wildcard: Search for a string using wildcards.
e SQL: Search for entries with an SQL condition.

e Full text: Search for a search term across all columns of an object definition
that are indexed for the full-text search.

NOTE: To use the full-text search, you must run the program over an
application server with an installed search service. For more information,
see Installing or uninstalling a search service for full-text search.

4. In the Filter parameter section, define the search pattern.

e Enter the search pattern for the Wildcard filter method. You can use * as a
wildcard in the search pattern.

Example: Using wildcards in the search pattern
Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

NOTE: To create filter queries using wildcards, users require the
Common_AllowRiskyWhereClauses program function.

e For the SQL filter method, enter the condition in the search pattern. Enter
the condition as a valid database query WHERE clause. You can enter the
database queries as an SQL query directly or compile the database queries with
a wizard. Use the Expert view or Simple view button to switch to the
appropriate view.

e For the Full text filter method, enter the search term in the search string.
The use of wild cards is permitted. For more information, see Rules and
examples for the full-text search.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.

Related topics

e Using filters in the Job Queue Info on page 18

Filtering process history entries

In the Process history view, you can filter the processes being processed.

To create filters for the process history in the Job Queue Info program

In the Job Queue Info, select the Process history view.
Select the Filter > Define filter menu item.

In the Define a filter dialog, in the Filter method pane, select your preferred filter
method. Custom filters allow you to run the following searches:

e Wildcard: Search for a string using wildcards.
e SQL: Search for entries with an SQL condition.

e Full text: Search for a search term across all columns of an object definition
that are indexed for the full-text search.

NOTE: To use the full-text search, you must run the program over an
application server with an installed search service. For more information,
see Installing or uninstalling a search service for full-text search.

4. Inthe Filter parameter section, define the search pattern.

e Enter the search pattern for the Wildcard filter method. You can use * as a
wildcard in the search pattern.

Example:
Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Pattern - searches for all entries whose display value matches the
Pattern string

NOTE: To create filter queries using wildcards, users require the
Common_AllowRiskyWhereClauses program function.

e For the SQL filter method, enter the condition in the search pattern. Enter
the condition as a valid database query WHERE clause. You can enter the
database queries as an SQL query directly or compile the database queries with
a wizard. Use the Expert view or Simple view button to switch to the
appropriate view.

e For the Full text filter method, enter the search term in the search string.
The use of wild cards is permitted. For more information, see Rules and
examples for the full-text search.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filter available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.

Related topics

» Using filters in the Job Queue Info on page 18

Filtering process archive entries

NOTE: This view is only shown if a One Identity Manager History Database is
configured in the TimeTrace.

For more information, see Declaring a One Identity Manager History Database in
the TimeTrace.

In the Process archive view, you can filter the processes being handled, including those
that have already been archived in a History Database. By default, the archived processes
of the last 365 days are taken into account. Define your own time interval for filters.

To create filters for the process archive in the Job Queue Info program

1. Select the Process archive view in the Job Queue Info.

2. Select the Filter > Define filter menu item.

= One Identity Manager 10.0 Process Monitoring and Troubleshooting
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3. Inthe Define filter dialog, in the Filter method section, select the Process
archive filter method.

4. Inthe Filter parameter section, define the search pattern.

e To filter processes, enter a search pattern for the process name in the
Name field.

e To filter for parameters, enter a search pattern for the parameter name in the
Name field. In the Value input field, enter the search pattern for the value of
the parameter.

e To filter by a time period, select the time period using the From and
Until fields.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.

Related topics

» Using filters in the Job Queue Info on page 18

Using filters in the Job Queue Info

You can use a filter as soon as you create it. Click the Filter button while creating a filter.

You can reuse saved filters at any time.

To use a saved filter in the Job Queue Info
In the Job Queue Info, select the view with the entries you want to filter.

Select the Filter > Define filter menu item.
Double-click the search filter in the Saved filters section.
Click Filter.

W N = =

Related topics

 Filtering Job queue entries on page 14
» Filtering process history entries on page 16
 Filtering process archive entries on page 17

e Removing filters in the Job Queue Info on page 19

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Removing filters in the Job Queue Info

A filter is applied to a view until you remove the filter again.

To remove a filter

1. Inthe Job Queue Info, select the view using the filter you want to remove.
2. Select the Filter > Delete filter menu item.

Related topics

e Using filters in the Job Queue Info on page 18

Publishing filters in the Job Queue Info

NOTE: To create, edit, and delete public filters, users require the Common_
PublicFilterDefine program function.

You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.

To publish a saved filter in the Job Queue Info

In the Job Queue Info, select the view that has a filter you want to publish.
Select the Filter > Define filter menu item.

Double-click the search filter in the Saved filters section.

Click Publish.

A W N -

Related topics

 Filtering Job queue entries on page 14
 Filtering process history entries on page 16

 Filtering process archive entries on page 17

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Deleting saved filters in the
Job Queue Info program

Filters can be deleted when no longer needed.

To delete saved filters in the Job Queue Info

In the Job Queue Info, select the view in which you want to delete a filter.
Select the Filter > Define filter.

In the Saved filters section, click the search filter.

Click .

N

Monitoring process handling

You can allow monitoring of individual processes. The process information is updated
regularly. The progress of a process step is displayed in the font color.

Table 5: Job queue display - meaning of the colors

Color Meaning Progress
state

Orange  This process step is being processed. Processing

Yellow This process step is loaded for processing. Loaded

Green This process step is ready for processing. True

Blue This process step has already been processed. Finished

Black This process step is not ready for processing. False

Red The process step being dealt with cannot be processed. You can Frozen

re-enable process steps with Frozen status and therefore set
them again for processing.

Purple The process step being dealt with cannot be processed. You can Overlimit
re-enable process steps with Overlimit status and therefore set
them again for processing.

Light The process step cannot be found. Missing
purple

To monitor information about a process

e Inthe Job Queue Info, in the Job queue view or the Base objects view, select a
process and select the Monitor process context menu entry.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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The process information is updated regularly.

TIP: To display the objects affected by a process step, use the Affected objects view.

To monitor the entire Job queue

e Inthe Job queue view, in the context menu, select Monitor job queue.

NOTE: The context menu entry is only available if the current user owns the
JobQueue_Monitor program function.

Related topics

» Re-enabling process steps and processes on page 25
» Initializing One Identity Manager Service queues on page 30
» Helpful keyboard shortcuts for working with Job Queue Info on page 14

Details about process handling

This view gives an overview of how process steps are linked within a process. In this
way, the handling sequence of individual process steps for large processes can be
monitored better.

To display details of the process handling

e InJob Queue Info, select a process and select the View > Process menu item.

All the process steps of the selected process are displayed.

One Identity Manager 10.0 Process Monitoring and Troubleshooting
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Figure 1: The process view
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The process step and its properties are displayed through a special control element.

e The process step name is displayed in the control's header.
« The progress state of the process step is clarified by the use of a color icon (@).
o All other entries represent the parameters for this process step.

e You can hide or show the parameter list by clicking on the % # icons in the header of
the control element.

e Each control element entry has a tooltip.

Table 6: Displaying process's process steps - meaning of the colors

Color Meaning Progress state

Orange  This process step is being processed. Processing

Yellow This process step is loaded for processing. Loaded

Green This process step is ready for processing. True

Blue This process step has already been processed. Finished

Black This process step is not ready for processing. False

Red The process step being dealt with cannot be Frozen/Overlimit/unknown

processed. You can re-enable process steps
that have Frozen or Overlimit status and
therefore queue them again for processing.
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Displaying process step handling details

In this view detailed information is displayed for each process step. The view shows the
data structure for a process step at compilation time. After selecting a process step, specific
information from the Job queue is mapped as well as each parameter of the selected
process step with its values.

To display details of the process step handling

e InJob Queue Info, select a process step and select the View > Process step menu.

Table 7: Process step view - meaning of icons

Icon Meaning

E Selection of a process step and its parameters.

iIE Displays a column from the Jobqueue table and the value.
wé Displays a process step parameter and the value.

TIP: You can copy the data currently selected in the view into the clipboard by pressing
Ctrl + C. The data format is column name value.

Process step parameter details

After selecting a process step, the passing parameters of the process step are displayed
with their names and their values. If the selected node does not represent a process step,
the parameter view is cleared.

To display process step parameters

e In the Job Queue Info, select a process step and select the View >
Parameter menu.

This shows all the parameters of the selected process step.

TIP: In the parameter view, you can copy the data selected parameter and its
value into the clipboard using Ctrl + C. The data format is column name value.
Parameters that contain an object key are displayed as a link in the parameter view.

e You can display the objects by clicking on the link or using the Show object
properties context menu.
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e Use the Open in Object Browser context menu item to start the Object Browser
and display the object.

e For object keys that refer to a synchronization project, use the Open in
Synchronization Editor context menu item to start the Synchronization Editor and
load the synchronization project.

To support provisioning analysis, the CausingEntityPatch parameter is shown as a link.
This parameter contains the patch that contains the changes to be provisioned.

e Double-click on the link to open a separate dialog with the change information.
You can also reach the dialog over the Show patch item of the parameter's
context menu.

The change information lists the properties of the object before the change (old
value) and after the change (new value). Changed properties are highlighted in color.

Error messages (ErrorMessages parameter) are displayed as links. Clicking on the link
displays a detailed message.

OUT parameters

Parameters of the OUT or INOUT type are parameters that a process component can use to
output a value. This value is then available in all subsequent process steps in the process
and can be used as a value for parameters of the IN type.

The Job Queue Info program is not technically capable of determining the point at which or
for which process step these parameters are valid. For this reason, OUT parameters are
added to the list of parameters of a process step and are highlighted in blue.

They cannot be seen in the view of the process step under <ParamIN> of a process step
because this view presents the data structure of every process step at compilation time.
However, the OUT parameters are created in the context of the process.

The time at which the process is loaded into the Job Queue Info is important. If a parameter
is overwritten several times, only the state at the time of data query is displayed.

Example: Passing parameters

Step 1 OUT parameter: X=1

Step 2 IN parameter: X=1
Value changes: X=2
OUT parameter: X=2

Step 3 IN parameter: X=2
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If the process is loaded into the Job Queue Info before step 2 is processed, the
Job Queue Info displays the X=1 value for the OUT parameter. If the process is loaded
after step 2 is processed, the X=2 value is displayed for the OUT parameter.

For more information about each process step and how the parameters are filled, see the
One Identity Manager Service log file.

Related topics

» Displaying the One Identity Manager Service log file on page 40

e Output of extended return values from individual process components on page 63

Show hidden parameters

Parameters in the One Identity Manager Service log file and in the Job Queue Info program
that are not to be displayed are labeled with the Hidden option. Values for hidden
parameters are shown as <HIDDEN>.

The following users can view hidden parameters in Job Queue Info:

* Administrative users

e Users with the JobQueue_ShowHiddenParameters program function

Related topics

» Which system user is the current user using? on page 43
» Which program functions are available to the current user? on page 44

Re-enabling process steps and
processes

The maximum number of times a process can appear in the Job queue can be limited in
order to prevent mass modifications. If the limit is exceeded, the process steps are set to
Overlimit status and are therefore no longer collected for processing. You can enable
these process steps be run again.

Critical process steps that have failed to be processed are given Frozen status. You can
also re-enable these processes after correcting the error.
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NOTE: The error message is displayed as a tooltip on the affected process step. You
use the Show error message context menu item to show a detailed error message.

To re-enable a process step

e Select the process step in the Job Queue Info and select the Re-enable process
step context menu item.

NOTE: Use Shift + select or Ctrl + select to select and re-enable multiple
process steps.

To re-enable a process step

e Select the process in the Job Queue Info and select the Restart process
context menu item.

IMPORTANT: When you restart a process, all process steps are processed
again. All previously handled processes up to the point at which the error
occurred are run again. This can lead to data inconsistencies in certain
circumstances.

Sometimes a rerun of the failed process step is not desired. This might occur when the
action to be carried out by the process has been carried out manually, for example, an
expected directory has been manually added in the meantime. Even so, it may just happen
that the process should be rerun even though the error has not been fixed, for example, for
a rollback of already processed steps. In this case, to continue with the process, the next
process step in the success or failure branch can be handled.

To run the subsequent process step

o Select the failed process step and select the End with success or the End with
error context menu item.

NOTE:

e The context menu items are only available if the current user owns the
JobQueue_Frozen program function.

e The entries are only displayed in the context menu if there is an
€rror successor or a success successor and the process step has the
status Frozen.

o Use Shift+ select or Ctrl + select to select multiple process steps and
start further processing.
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Enabling and disabling extended
logging of process steps

Success and error messages from process handling are written to the

One Identity Manager Service log file. In order to test you processes, you can enable
logging mode for process steps in the Job Queue Info. In this case, the processing
messages of the processing step are written along with the Debug level of information into
a separate log. You can display the log in the Job Queue Info as well as in the log file of the
One Identity Manager Service itself.

NOTE: The log mode is only available is the current user owns the JobQueue_
LogMode program function.

To enable process step logging mode

e To log the messages on success and on failure, select the process step in the Job
queue view in Job Queue Info and select the Processing log > Create always
context menu.

» To log the messages on failure only, in the Job Queue Info, select the process step in
the Job queue view and select the Processing log > On Error context menu item.

NOTE: You can set the log mode by default for separate process steps. To do this, edit
the process step in the Designer in the Process Editor. For more information, see
Defining processes.

To display the log in Job Queue Info

» Inthe Job queues view in Job Queue Info, select the process step and select the
Processing log > Display context menu.

This displays the log in a separate window. If a process step was run more than once,
for example, if it is re-enabled more than once, several log are displayed.

To display the log in the One Identity Manager Service log file

e Inthe Job Queue Info, select the Server status view on the Job server tab and
select the Show in browser context menu item.

e The log is marked with a link entry Log written to Job_<UID_Job>_<yyyymmdd>_
<Timestamp>.log. Click the link to display the log.

The files are stored in the One Identity Manager Service log directory.
Repository structure:

<Log directory>\JobLogs\<First 4 digits of the UID_Job>\Job_<UID_Job>_
<yyyymmdd>_<Timestamp>.log
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To end log mode

e InJob Queue Info, in the Job queue view, select the process step and select the
Processing log > Disable context menu item.

Related topics

» Displaying the One Identity Manager Service log file on page 40
« Which program functions are available to the current user? on page 44

Determining the status of the Job
server and web server

To get a quick overview of the availability of the Job server and the web server, you can
request the Job Queue Info's status.

NOTE: Set the HTTP port to be queried and the maximum response time for status
queries in the program settings.

TIP: Use Refresh server list or F6 to reload the list of servers.

One Identity Manager Service configurations of each Job server stored in the database are
used to get more detailed results of Job server status queries. This is especially required if
the HTTP server port has been set individually or a Job server processes several queues. In
the Designer, configure and enable the Get configuration file from the Job server and
write in the Job server configuration schedule to import the

One Identity Manager Service configuration of the Job server into the database.

To query the status of all Job servers

1. Inthe Job Queue Info program, select the View > Server state menu item.

2. Select the Job server tab and press F5.

To query the status of a single Job server

1. Inthe Job Queue Info program, select the View > Server state menu item.

2. On the Job server tab, select the Job server and then the Get status
context menu item.

NOTE: Use the Enter credentials context menu item to enter a user and password to
request the server status. You can select more than one Job server. The user inform-
ation is kept until the next time the Job Queue Info starts.
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If the server responds, the system time, the One Identity Manager Service version and the
One Identity Manager Service account name are determined and displayed. The software
update status as well as the current version of the software are also displayed.

If an error occurs during the status request, the @ symbol is displayed for the Job server.
You use the Show request error context menu item to show a detailed error message.

Job servers that pause processing because they are in offline mode, are flagged
with a Il symbol.

For more information, see Pausing handling of target system specific processes.

To display a Job server's services

1. Inthe Job Queue Info program, select the View > Server state menu item.

2. Onthe Job server tab, select the Job server and select the Show in browser
context menu item.

The One Identity Manager Service HTTP server for the Job server is queried and the
varying One Identity Manager Service services are displayed.

To show the status of a web server

1. Inthe Job Queue Info program, select the View > Server state menu item.

2. On the Web server tab, select the web server and select the Show in browser
context menu item.

Related topics

e Changing program settings in the Job Queue Info on page 13
» Prerequisites for displaying the One Identity Manager Service log file on page 54

» Configure process collection check for Job servers on page 29

Configure process collection check for
Job servers

On the Job server, the Last fetch time property logs when a process step was retrieved
by the One Identity Manager Service. If no completion message for this process step has
been returned within the time specified in the Common | Jobservice |
LoadedJobsTimeOut configuration parameter, the One Identity Manager Service runs a
check. The time of the last check for loaded process steps (Last timeout check property)
is set to the current time.

To configure the process collection check, adjust the following settings in the Designer.
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e Common | Jobservice | LoadedJobsTimeOut configuration parameter

The configuration parameter contains the time in minutes within which a process
should be reported back before a check is run. Default value is 15 minutes.

NOTE: If there are Job server that have exceeded the time limit, the Last
timeout check column is displayed in red.

« Common | MailNotification | NotifyAboutRequestStall configuration parameter

Use the configuration parameter to specify whether an email notification should be
sent when the One Identity Manager Service stops running requests. The
configuration parameter is not set by default.

» Send notification when Job server is not requesting processes schedule

The schedule checks whether the One Identity Manager Service regularly asks for
processes from a queue. If a One Identity Manager Service stops making process
requests, notification is sent by email.

Enable the schedule. The interval should be set as in the Common | Jobservice |
LoadedJobsTimeOut configuration parameter.

Initializing
One Identity Manager Service queues

A queue is initialized when the One Identity Manager Service starts. The

One Identity Manager Service queries the Job queue to see which processes are waiting for
its own queue. During the initialization phase, no processes are handled and it may take a
long time, particularly if the Job queue is very full.

In Job Queue Info, in the Progress view, a warning shows you the queue being initialized.
Click the message to get more detail.
Related topics

» Displaying Job queue progress on page 31

Displaying DBQueue processing

Within One Identity Manager, changes to inheritance-relevant data, such as changes to
assignments or changes to specific system data, such as changes to the user interface for a
system user, necessitate recalculation of the resulting data. These calculations are queued
in the DBQueue and processed by the DBQueue Processor.
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To display DBQueue entries
e InJob Queue Info, select the View > DBQueue menu.

Calculation tasks in the DialogDBQueue table used for DBQueue Processor processing are
displayed in this view. The number, sort order and name of the queued requests are
displayed. The display is updated at fixed time intervals of 2 seconds.

NOTE: If the Database Agent Service is not working, a message is displayed in the
status bar in all the administration tools. To see this message, users must have at least
the configuration user access level.

Displaying Job queue progress

This view queries the number of all entries in the Job queue. The current value is
represented by a number and inserted, at the same time, into a bar graph. The
process step progress state is shown in different colors. The display is updated every 5
seconds. The tooltip shows the timestamp and the number of process steps in the Job
queue at this point.

To display the Job queue sequence

e InJob Queue Info, select the View > History menu.

Table 8: Progress view - meaning of the colors

Color Meaning Progress state
Black Number of process steps that are not read for False
processing.
Green Number of process steps ready for processing. True
Yellow Number of process steps loaded for processing. Loaded
Blue Number of process step that have completed Finished
processing
Red Number of process steps with an unknown Frozen/Overlimit/Missing

progress state

Emergency stop

In certain circumstances, situations can occur in the system that require processing by
One Identity Manager Service and processing of tasks by the DBQueue Processor to be
stopped. For example, changes in One Identity Manager can sometimes cause the system
to become overloaded by making mass entries in the Job queue or the DBQueue.
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To analyze this situation and to take the necessary steps to solve the problem where

necessary, in the Job Queue Info program, you can stop the system and restart it once the
problem has been fixed.

To temporarily halt process handling of a single Job server

1. InJob Queue Info, select the View > Server state menu item.

2. Onthe Job server tab, select the Job server and select the Stop processing
context menu item.

NOTE: After solving the problem, you can use the Start processing context
menu item to restart processing.

To stop processing entirely

1. Inthe Job Queue Info, select the Help > Emergency stop menu item.
2. To stop DBQueue processing, click the DBQueue Processor active button.

From this point on no new calculations are carried out in the database.

NOTE: After the problem is eliminated, you can click the button to restart the
DBQueue Processor.

3. To stop collection of process steps for every One Identity Manager Service, click the
One Identity Manager Service active button.

Process steps that have already been collected are still processed by the services but
no new process steps are sent to the services.

NOTE: After the problem is eliminated, you can click the button to restart the
running of services.

The following icons are displayed in the status bar of all administration tools to inform the
user that DBQueue Processor processing and services have been stopped.

Table 9: Special icon in the status bar for system stop

Icon Meaning

-

The DBQueue Processor has been stopped.

a

The server services have been stopped.

NOTE: If the Database Agent Service is not working, a message is displayed in the
status bar in all the administration tools. To see this message, users must have at least
the configuration user access level.
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Support for error localization in
One Identity Manager

This section explains various possibilities for error localization within One Identity Manager.

Displaying the system configuration
overview and the transport history

IMPORTANT: You will need to provide this information if you contact the
Support Team.

To obtain an overview of the One Identity Manager database system
configuration

o Start the Designer or the Manager and select the Help > Info menu item.
The System information tab provides an overview of your current system
administration and the installed modules with their versions.

NOTE: If you have enabled vendor notification, this report is sent once a month
to One Identity.

To obtain an overview of the History Database system configuration

e Run the following SQL query with a suitable program for performing SQL queries on
the History Database.

select * from QBMVSystemOverview

During a schema installation or schema update using the Configuration Wizard, the
migration date and migration version are recorded in the database transport history.
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When you import a transport package with the Database Transporter, the import date and
description, the database version, and the transport package name are recorded in the
transport history of the target database.

To display transport history

o Start the Designer and select the Help > Transport history menu item.

The error message window in
One Identity Manager tools

Error messages for the One Identity Manager tools are shown in a separate window. In
addition, a more detailed description of the error is displayed.

Figure 2: Error message window

- 0 = Errors occurred

[810284] Failed to authenticate user.

[810015] Login for user viadmin failed.
[810017] Wrong user name or password.

DShow only user relevant DShow error pasitions Show
Show previous errors Show asynchronaous calls

Show One |dentity error numbers Wrap long lines

» Configure the amount of information to be displayed using the options in the error
message window.

One Identity Manager 10.0 Process Monitoring and Troubleshooting

(ONE IDENTITY cuide | 34

Support for error localization in One Identity Manager



e Open the configuration view for the error messages window with the & button
and enable or disable the options you want.

Table 10: Options for displaying error messages

Option

Meaning

Show previous
errors

Show One
Identity error
numbers

Show error
positions

Wrap long lines

Show only user
relevant

Specifies whether all previous errors that lead to the current
error, should also be shown.

Specifies whether internal error numbers are shown.

Specifies whether error position is also shown in the program
code.

Specifies whether long error messages are wrapped.

Specifies whether all error messages are to be displayed or only
those error messages that are classified as user relevant.

Show asynchron-
ous calls

Specifies whether error messages in asynchronous method calls
are shown.

e To send the messages, click on the Send as mail button.

This creates a new email message in the default mail program and copies over the
error text.

e To copy the messages to the clipboard, open the Send as mail menu and click Copy
to clipboard.

e Use screen capture to record the steps leading up to the error.

To start the screen capture tool
Open the Send as mail context menu and click Start screen capture.
2. Confirm the security prompt with OK.
Start capturing the screen with the Snipping Tool.

For more information on screen capturing with the Snipping Tool, see the
Microsoft documentation.

Displaying error log messages

A program's error log, as in the Manager for example, displays all the messages, such as
error messages and warnings, that have occurred since the program started. The error log
is reinitialized when the program is restarted.
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NOTE: In the Manager, the @ icon in the program’s status bar indicates new messages
in the error log. Double-click the icon to open the error log.

To display items from the Manager error log

1. In the Manager, select the View > Error log menu item.

2. Enable the 23 view in the error log toolbar.

You can configure how the messages are displayed in the error log. To do this, switch the
error log to advanced mode by clicking & on the right of the column headers. Here you
have the possibility to debug individual actions.

TIP: You can apply different filters to limit the information being displayed. Click the
arrow in the column header and select a filter. The Y icon in the log toolbar shows
whether a filter is active.

Figure 3: Simple error log (above) and advanced error log (below)

Error log 2 x

=]

Time stamp ¥ Logger name ¥ Message -

022002017 092147 Objectlog User viadmin (Dialog user: viadmin, X fields: viadmin) authenticated.

Error log 2 x
Elm
Time stamp ~ logger name ~ Message -

12082017 16:44:03 Objectlog User viadmin (Dialog user: viadmin, X fields: viadmin) authenticated.
€12.00.2017 16:44:51 VI FormBase.ExceptionMgr Object ({0}) could not be saved!

Table 11: Meaning of icons in the log

Icon Meaning

! Logs all critical error messages. (Info level Fatal)

0 Logs all information. (Info level Info)

! Logs all warnings. (Info level Warning)

o Logs all error messages. (Info level Error)

[ | Logs debugger output. This setting should only be used for testing. (Info level

Debug)

"

Logs highly detailed information. This setting should only be used for analysis
purposes. The log file quickly becomes large and cumbersome. (Info level
Trace)

Y Adds a custom filter condition.
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-
0
o
=3

Meaning

Y Deletes filter condition.

Q Searches for term.

& Searches next term.

& Marks all messages with a specific term.

Buffer  Sets the message buffer size. The buffer's level is displayed next to the field.
size

1] Deletes the buffer contents.

[ | Stops logging.

> Starts logging.

B Saves log to file.

M Specifies which column are displayed in the error log.
Copies selected messages to the clipboard.

& Opens the error log with a text editor.

The following information is displayed about a message. The range of information depends
on the severity level of a message.

Table 12: Information about a message

Detail Description

Severity code Level of information supplied for the message.

Timestamp Time and date of the log entry.

Logger name One Identity Manager component from which the message was sent.
Message Logged message.

Error Message Detailed error message.

Data Additional data about the message.

Sequence ID Number of the line in the error log.

Stack trace Complete stack trace for the error message.

Session ID Session identification number.

NOTE: If there is a filter set on the session ID, only the messages
for this session are displayed, for example, loading collections and
single objects. If the filter is not set, actions outside of the

connection, such as loading of table definitions or configuration
parameters, are also displayed.

One Identity Manager 10.0 Process Monitoring and Troubleshooting

(ONE IDENTITY cuide | 37

Support for error localization in One Identity Manager



TIP: Double-click a message to display detailed information.

Figure 4: Detailed information about a message

Log message properties X

General

Q -

Object [ ) could not be saved!

Sequence D 16643

Timestamp 20170922 11:51:52:961
Logger name W|.FormBase ExceptionMar
Exception [1025012] Obiject ( () could not be
=

Related topics

» Configuring One Identity Manager component logging with NLog on page 49

Displaying system journal messages

The system journal is used to store information, warning, and error messages from
different components of One Identity Manager, for example, DBQueue Processor,
Configuration Wizard, or One Identity Manager Service. Actions in the Job Queue Info
program, such as reactivating process steps, are also recorded in the system journal.

To display system journal entries in the Manager
1. In the Manager, select the View > Error log menu item.
2. Enable the i view in the error log toolbar.
To display system journal entries in the Job Queue Info
e Inthe Job Queue Info, select the View > System journal menu item.

TIP: You can apply different filters to limit the information being displayed. Click the
arrow in the column header and select a filter. The Y icon in the log toolbar shows if a
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filter is active.

Table 13: Displaying messages in the system journal

Icon Meaning

o Information is written to the error log/system journal.
- A warning has been written to the system journal.

o An error has been written to the system journal.

TIP: Double-click a message to display detailed information.

Figure 5: Detailed information about a message

System journal entry - O X

Message Tasks not processed because the script assemblies
are not valid,

Program DBQueue Processor

Host 501D2061

Logged in system user QBM_PScheduleCheck

Type Warning

Date T/8/2025 8:34 AM

The following information is displayed about a message. The range of information depends
on the type of message.

Table 14: Information about a message

Detail Description

Message Logged message.

Program One Identity Manager component from which the message was
sent.

Host Computer from which the action was started.

Logged in system System user that triggered the action.

user

Type Type of message. Following values are possible:

= One Identity Manager 10.0 Process Monitoring and Troubleshooting
(ONE IDENTITY cuice | 39

Support for error localization in One Identity Manager



Detail Description

e Warning: This is a warning (Warning info level).

e Information: This is information (info info level).
e Error: Thisis an error (Error info level).

e Debug: This is a debug message (debug info level).

e Trace: This is an output with more detailed information
(Trace info level).

Date Time and date of the log entry.

Related topics

» Logging process handing errors in the system journal on page 47
» Auditing logins and logouts on page 47
e Configuring retention times of messages in the system journal on page 46

Displaying the
One Identity Manager Service log file

You can use a browser front-end to display the One Identity Manager Service log file.
You call up the log file with the appropriate URL:

http://<server name>:<port number>
The default value is port 188e.
Different credentials are expected depending on how the authentication method is
configured for displaying the log file.

To open the One Identity Manager Service log file in the Job Queue Info

Start the Job Queue Info program.

2. Inthe Server state view, select the Job server and select the Open in browser
context menu item.

The One Identity Manager Service HTTP server for the Job server is queried and the
various One Identity Manager Service services are displayed.

3. Todisplay the contents of the log file, select Log File in the navigation view.
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Figure 6: The One Identity Manager Service log file

@N E IDENTITY Oneldentity Manager Job Service - AEDOKU-DC

A Warning: No private key supplied. Running without encryption support. x
# Home
Loaded Assemblies v | Allinformation -
Statistics . .

Logging severity: Info. ~
Components 2017-89-12 90:80:07 +82:00 - Info: Reguesting process steps for queue \AEDOKU-DC.

2817-89-12 00:60:87 +82:00 - Info: Last process step request succeeded.
Cache 2817-89-12 00:60:89 +82:80 - Info: Requesting process steps for queue \WURZELAUSIX.

2817-89-12 00:80:89 +82:00 - Info: Last process step request succeeded.
Log File 2@17-89-12 00:00:24 +82:00 - Info: Reguesting process steps for gqueue \WURZELAUSIX.

2017-89-12 00:80:24 +82:00 - Info: Last process step request succeeded.

2917-09-12 00:80:37 +82:00 - Info: Reguesting process steps for queue \AEDOKU-DC.
2817-89-12 00:80:37 +62:86 - Info: Last process step request succeeded.

2017-89-12 90:80:39 +82:00 - Info: Reguesting process steps for queue \WURZELAUSIX.
2017-09-12 00:88:39 +82:00 - Info: Last process step request succeeded.

2817-89-12 00:80:54 +82:80 - Info: Requesting process steps for gueue \WURZELAUSIX.
2817-89-12 00:80:54 +82:00 - Info: Last process step request succeeded.

2@17-89-12 00:91:07 +82:00 - Info: Reguesting process steps for gqueue \AEDOKU-DC
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The messages to be displayed on the web page can be filtered interactively. There is a
drop-down on the website for this. Only text contained in the log file can be displayed in
this case. For example, if the message type is Warning, messages with the Info message
type cannot also be displayed if the relevant filter is selected.

The log output is color-coded to make it easier to identify.

Table 15: Log file color code

Color Meaning

Green Processing successful

Yellow Warnings occurred during processing
Red Fatal errors occurred during processing

NOTE: If you want to retain the color information to send by email, you need to save
the complete web page.

Related topics

e Configuring One Identity Manager Service logging on page 53
» Prerequisites for displaying the One Identity Manager Service log file on page 54

* Querying One Identity Manager Service availability on page 41

Querying One Identity Manager Service
availability

The availability of a One Identity Manager Service can be tested over /alive.

Example call: http://<server name>:<port number>/alive
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Only success (HTTP 200 with True as content) or fail (HTTP 500) is returned.

Displaying an application server's
status

You can access the application server from a browser.
Use the appropriate URL for this:
http://<server name>/<application name>

https://<server>/<application name>

TIP: You can open the web server's status display in the Job Queue Info. In the
Job Queue Info, select View > Server state in the menu and, on the Web servers
tab, open the web server status display from the Open in browser context menu.

You will see different status information. Status information for the application server is
displayed as performance indicators. Users with the AppServer_Logs program function
see the log.

In addition, API documentation is available here. To access the REST API in the application
server, users require the AppServer_API program function. For more information, see
One Identity Manager REST API.

Related topics

» Determining the status of the Job server and web server on page 28

Which authentication module is the
current user using?

One Identity Manager uses different authentication modules for logging in to administration
tools. Authentication modules identify the system users to be used and load the user
interface and database resource editing permissions depending on their permission group
memberships.

For more information, see One Identity ManagerAuthentication modules.

To identify the current authentication module for the current user

« Todisplay user information, double-click the & icon in the program status bar.

The System user tab displays the following information about the authentication
module used:
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e Authenticated by: Name of the authentication module used for logging in.

o Identity UID (UserUID): Unique ID of the current user’s identity if an
identity-based authentication module is used to log in.

Which system user is the current user
using?

Users log in to the running administration tool using a system ID. Permitted system
user IDs are determined by the authentication module you select. When the system
user logs in to the One Identity Manager administration tools, the user interface is
displayed and editing permissions are assigned depending on the permissions groups to
which the user belongs.

For more information, see One Identity Manager authentication modules and Editing
system users.

To identify the current system user for the current user:

+ Todisplay user information, double-click the & icon in the program status bar.
The System user tab displays the following information about the system user.
o System user: Name of the current system user.

 Dynamic user: Specifies whether the logged in user is using a dynamic
system user. Dynamic system users are applied when a role-based
authentication module is used.

 Administrative user: Specifies whether the current user is using a
system user.

« Remarks: Detailed description about the system user.

Which permissions apply to the
current user?

Depending on the membership of the system user in permissions groups, the user interface
and the authorizations for objects are made available to the current user.

For more information, see Granting One Identity Manager schema permissions through
permissions groups.

To identify the current permissions groups for the current user

« To display user information, double-click the & icon in the program status bar.

The Permissions groups tab lists the user's permissions groups.
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NOTE: On the System users tab, the Read-only option specifies whether the
system user being used has read-only permissions. If so, the user is not
permitted to change data.

To identify which permissions are assigned to the current user for an object:

e Select the object for which you want to see the permissions.
e Select the Properties context menu.

On the Permissions tab, based on the permissions groups, you see what
permissions apply to an object.

Which program functions are available
to the current user?

Some functions in One Identity Manager tools are available only if the program functions
are assigned to the current user. For example, this includes data export from the
Manager, calling the SQL Editor in the Designer or showing DBQueue Processor
information in all programs.

For more information, see Managing permissions via program functions.

To identify the program functions available to the current user:

« To display user information, double-click the & icon in the program status bar.

The Program functions tab shows the program functions that are available.

Which access level does the user use?

To deploy a One Identity Manager database on an SQL Server or a managed instance in
Azure SQL Database, you are provided with SQL logins and database users for
administrative users, configuration users, and end users. Permissions at server and
database level are matched to suit the user's tasks.

For more information, see Minimum access levels of One Identity Manager tools.

NOTE:

» If you select an existing database connection in the connections dialog, the
access level of the login to be used is shown in a tooltip.
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e Some user interfaces expect configuration user permissions at least. Logging in
as an end user is not possible in this case.

To find the access level of the logged in user

 To display user information, double-click the icon in the program status bar &

On the System user tab, in the SQL access level field, you will see the access level
for the current login. The access levels displayed are End user, Configuration user,
Administrative user, System administrator, and Unknown.
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Configuring logs in
One Identity Manager

One Identity Manager provides various options for extending its log. The log can be
configured for each One Identity Manager component.

Configuring retention times of
messages in the system journal

Table 16: Configuration parameters for logging in the system journal

Configuration
parameter

Meaning

Common | Journal

Common | Journal |
LifeTime

Common | Journal |
LifeTime | D

Common | Journal |
LifeTime | E

Common | Journal |
LifeTime | I

Common | Journal |
LifeTime | T

Common | Journal |
LifeTime | W

Common | Journal |
Delete

(ONE IDENTITY

General parameter for configuring the system journal.

Maximum retention time in days for a system journal entry in the
database. Older entries are deleted from the database.

Retention time in days for messages with the Debug information
level.

Retention time in days for messages with the information Error
level.

Retention time in days for messages with the Info information
level.

Retention time in days for messages with the Trace information
level.

Retention time in days for messages with the Warning information
level.

Configuration of deletion behavior for system messages.
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Configuration Meaning
parameter

Common | Journal | Number of entries to be deleted in any operation.
Delete | BulkCount

Common | Journal |  Total number of entries to be deleted in any processing run.
Delete | TotalCount

Messages in the system journal are regularly deleted by the DBQueue Processor.

To delete log entries in the system journal

e Inthe Designer, enable the Common | Journal | LifeTime configuration
parameter and enter the maximum retention period for the entries in the system
journal. Use the configuration subparameters to specify the retention time for each
information level.

» If thereis a large amount of data, you can specify the number of objects to delete per
DBQueue Processor operation and run in order to improve performance. To do this,
use the Common | Journal | Delete | BulkCount and Common | Journal |
Delete | TotalCount configuration parameters.

Logging process handing errors in the
system journal

Error messages from process handling can be recorded in the system journal.

To log error in process handing in the system journal

» At the process steps in the Designer, enable the Log errors to journal option.

Related topics

» Displaying system journal messages on page 38

Auditing logins and logouts

Successful logins, failed login attempts, and logouts can all be logged. The messages are
sent to a syslog server.

NOTE: Logins and logouts are evaluated in the QBM_VDialogJournallLoginAudit view.
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To audit logins in One Identity Manager

e Inthe Designer, set the Common | Journal | LoginAudit configuration parameter.

e Use the Common | Journal | LoginAudit | LifeTimeFailure configuration
parameter to specify the retention period for failed logins. The default value is

30 days.

e Use the Common | Journal | LoginAudit | LifeTimeSuccess configuration
parameter to specify the retention time for successful logins. The default value

is 10 days.

To audit One Identity Manager logouts

e In the Designer, set the Common | Journal | LogoutAudit configuration

parameter.

e Use the Common | Journal | LoginAudit | LifeTimeLogout configuration
parameter to specify the retention time for logouts. The default value is 10 days.

Logins and logouts are stored in the QBMLoginAudit table. The following information

is audited:

Table 17: Login and logout audit data

Detail

Description

Application

Authentication
module

Host

Identity display
name

Logged in system
user

Message

Session ID

Type

Related topics

One Identity Manager component where the login or logout
occurred.

Authentication module that was used.

Computer used to log in or log out.

Identity used to log in or log out.

System user that was used to log in or log out.

Message logged for the log in or log out.
Session ID of the user process in SQL Server.
Type of message. The following values are possible:

e Failed login: The login attempt failed.
» Successful login: The login was successful.

e Logout: This is a logout.

» Generating log messages for SIEM systems on page 65
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Logging information about OAuth
2.0/0penID Connect authentication

To support troubleshooting in OAuth 2.0/0OpenID Connect authentication you can log
personal login data, such as information about tokens or issuers. The log is written to the
object log file (<appName>_object.log) of the respective One Identity Manager component.

To log authentication data

e Inthe Designer, set the QBM | DebugMode | OAuth2 |
LogPersonalInfoOnException configuration parameter.

Configuring One Identity Manager
component logging with NLog

In the One Identity Manager default installation, the log files are written to the
%LocalAppData%\One Identity\One Identity Manager\<appName> under the name
<appName>.log directory, where appName is the name of the One Identity Manager
component.

Example: %LocalAppData%\One Identity\One Identity Manager\Manager\Manager.log

All messages with a minimum information level of Info are recorded in the <appName>.log
file. The files are kept for 7 days and backed up daily.

In addition, all messages with a severity level of Fatal are recorded in the Application
event log for the One Identity One Identity Manager <appName> source.

NOTE: The default settings for the configuration require write permissions for the
%localappdata¥% directory. If a One Identity Manager component (*.exe) does not have
the required permissions, change the logBaseDir variable in the nlog.config config-
uration file to write the log to a directory for which the permissions exist.

Structure of the nlog.config configuration file

The configuration settings for logging messages using NLog are made in the nlog.config
configuration file. For an exact description and functionality of NLog, see the online help
(http://nlog-project.org/). The nlog.config settings are globally valid for all

One Identity Manager components.

Use variables to define the general names, output path, and the severity levels to be
recorded in the log files and the event log in the configuration file.
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Table 18: General variables for configuring logging

Variable Description
appName Application name of the One Identity Manager component. If it is not
possible to determine the application name, IdentityManager is used.
logBaseDir Output path for the component's log files.
Default:

%LocalAppData’%\One Identity\One Identity Manager\<appName>

logFileLevel Severity level of messages to write to the log file.
Default: Info

eventLoglLevel Severity level of the messages that are written to the event log.
Default: Fatal

The output targets for messages and the settings for storing and archiving log files are
defined in the targets section. NLog already has predefined targets that you can use in the
configuration file.

Table 19: Output targets for logging

Target Name Description

logfile Name and settings of the general log file of a One Identity Manager
component.

Default settings:
Name: <appName>.log
Storage: 7 days
Archived: daily

debug Name and settings of the log file for recording debug messages.
Default settings:
Name: /debug/<appName>.log
Storage: 7 days
Archived: daily

sqllogfile Name and settings of the log file for recording database queries.
Default settings:
Name: <appName>_sql.log
Storage: 7 days
Archived: daily

objectlogdfile Name and settings of the log file for recording object actions over the
object layer.
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Target Name Description

Default settings:

Name: <appName>_object.log
Storage: 7 days

Archived: daily

jobgenlogfile  Name and settings of the log file for recording during process generation.
Default settings:
Name: <appName>_jobgen.log
Storage: 7 days
Archived: daily

The rules section is used to define rules for logging the messages. The logger name is
used to define which components are logged. Messages are logged for all components with
the default setting logger name="*". To limit logs to certain components, use the name
contained in the log.

Table 20: Logger names of components

Logger name Description

FrontendLog Logs actions in front-ends.

JobGenlLog Logs during process generation.

Jobservice Logs One Identity Manager Service messages.
ObjectLog Logs object actions through the object level.
ProjectorEngine Logs messages from the synchronization engine.
SqlLog Logs database queries

StopWatch Logs timings.

SystemConnection Detailed logging of data communication with the system connec-
tion during synchronization, including system configuration and
system connectors' data communication.

SystemConnector Logs system connector data communication during synchron-
ization.

Update Logs update handling.

WeblLog Logs Web service actions.

DebuglLogObserver  Logs performance data from the synchronization engine.
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You can enter the severity level through:

 minlevel: Messages above this severity level are logged. The LogFileLevel variable
can overwrite the severity level in a custom configuration file.

» level: Messages with exactly this severity level are logged. The eventLoglLevel
variable can overwrite the severity level in a custom configuration file.

Table 21: Permitted severity levels

Severity Description

Level

Trace Logs highly detailed information. This setting should only be used for
analysis purposes. The log file quickly becomes large and cumbersome.

Debug Logs debug steps. This setting should only be used for testing.

Info Logs all information.

Warning Logs all warnings.

Error Logs all error messages.

Fatal Logs all critical error messages.

Files for custom extensions

The following files are defined for custom extensions. You can upload and distribute the
files using the Software Loader

<include file="${basedir}/custom-log-variables.config" ignoreErrors="true"/>
<include file="${basedir}/custom-log-targets.config" ignoreErrors="true"/>

NLog extension for logging information about the Windows identity

Use the custom extension files to make the adjustments.

* Modify the extensions section in the configuration file. The nlog.config
configuration file has the <add assembly="NLog.WindowsIdentity" /> entry in the
extensions section.

e To use the NLog extension, add this section and uncomment the extensions section.

e N

<!-- Add this if you need the windows-identity in your format
<extensions>
<add assembly="NLog.WindowsIdentity" />
</extensions>

-->
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e Uncomment the following entry in the targets section as well.

Ve

<!-- Adapt this entry if you need the more verbose remotelLayout with machine
name, process name, and windows identity:
<target name="logfile" xsi:type="File" fileName="${logBaseDir}/${ap-
pName}.log" layout="${remoteLayout}" encoding="utf-8"
archiveFileName="${logBaseDir}/${appName}.{#}.log"
maxArchiveFiles="7" archiveEvery="Day" archiveNumbering="Rolling"/>
-->

NLog extension for logging in the event log

Use the custom extension files to make the adjustments.

e To log messages in the event log, modify the extensions section in the
configuration file.

e Add an <add assembly="NLog.WindowsEventLog"/> entry for logging to the event log.
Uncomment the extensions section in order to use the NLog extension.

Ve

<!-- Add this if you need the windows-identity in your format
<extensions>
<add assembly="NLog.WindowsIdentity" />
<add assembly="NLog.WindowsEventLog"/>
</extensions>
-->

Configuring
One Identity Manager Service logging

Success and error messages from process handling are written to the
One Identity Manager Service log file. Messages can also be written to a server’s event log.
A severity level can be configured for output to this log file.

You can create most of the settings in the One Identity Manager Service configuration file.
Use the Job Service Configuration program to do this.

For more information, see Configuring the One Identity Manager Service.

Related topics

» Configuring One Identity Manager component logging with NLog on page 49
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Prerequisites for displaying the
One Identity Manager Service log file

The One Identity Manager Service log files can be displayed using a HTTP server
(http://<server name>:<port number>).

e Users require permission to open an HTTP server. The administrator must grant URL
approval to the user to do this. This can be run with the following command line call:

netsh http add urlacl url=http://*:<port number>/ user=<domain>\<user name>

If the One Identity Manager Service has to run under the Network Service's user
account (NT Authority\NetworkService), explicit permissions for the internal web
service must be granted. This can be run with the following command line call:

netsh http add urlacl url=http://<IP address>:<port number>/ user="NT
AUTHORITY\NETWORKSERVICE"

You can check the result with the following command line call:

netsh http show urlacl

To display the One Identity Manager Service log file, configure the following modules in the
One Identity Manager Service configuration file:

* FileLogWriter module

Create the log file settings in this module.
o Configuration module

Configure the port for displaying the services. The default value is port 1880.
e HTTP authentication module

Set up an authentication method to display the log file.

For more information, see Configuring the One Identity Manager Service.

Configuring the
One Identity Manager Service log file

To generate the log file, customize the FileLogWriter module in the
One Identity Manager Service configuration file for each One Identity Manager Service.

Table 22: FileLogWriter parameters

Parameters Description

Number of Maximum number of log files. If several log files exist, the oldest
history logs backup file is deleted when a new log file is created so that the limit is
(HistorySize) not exceeded.
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Parameters Description

Max. length of Maximum number of characters allowed in a process step parameter
parameters so that they are written to the log file.

(ParamMaxLength)

Max. log file size  Maximum size in MB of the log file. Once the log file has reached the
(MB) limit, it is renamed as a backup file and a new log file is created.
(MaxLogSize)

Log file Name of the log file, including the directory name. Log information for
(OutputFile) the One Identity Manager Service is written to this file.

IMPORTANT: The directory specified for the file must exist. If the
file cannot be created, no error output is possible. Error messages
then appear under Windows operating systems in the event log or
under Linux operating systems in /var/log/messages.

Process step log Retention time for process step logs. After this expires, the logs are
lifetime deleted.

(JobLogLifeTime) a6yt format:
day.hour:minutes:seconds

For test purposes, you can enable logging of individual process steps
in the Job Queue Info. The processing messages of the process step is
written to a separate log with the Debug NLog severity. The files are
stored in the log directory.

Repository structure:

<Log directory>\JobLogs\<First 4 digits of the UID_Job>\Job_
<UID_Job>_<yyyymmdd>_<Timestamp>.log

LogSeverity Severity levels of the logged messages.
Permitted values are:

» Info: All messages are written to the event log. The event log
quickly becomes large and confusing.

e Warning: Only warnings and exception errors are written to the
event log (default).

e Serious: Only exception messages are written to the event log.

Add server name Specifies whether the server name is to be added to the log entries.
(AddServerName)

Log rename In order to avoid unnecessarily large log files, the module supports the
interval functionality of exchanging the log file with a history list. The
(LogLifeTime) LogLifeTime specifies the maximum life of a log file before it is

renamed as backup. If the log file has reached its maximum age, the

One Identity Manager 10.0 Process Monitoring and Troubleshooting

(ONE IDENTITY Guide | 55

Configuring logs in One Identity Manager



Parameters Description

file is renamed (for example, as JobService.log 20040819-083554)
and a new log file is started.

Timeout format:

day.hour:minutes:seconds

For more information, see Configuring the One Identity Manager Service.

Authentication method for displaying the
One Identity Manager Service log file

Use the HTTP authentication module to specify how authentication on the HTTP server
works to access the services, for example, to display the log file or status display.

The following module types may be selected:
e BasicHttpAuthentication
Use this authentication type to specify a user account for accessing the HTTP server.
Module parameters are:
e User account (User): User account for logging in.
e Password (Password): User account's password.

e SessionHttpAuthentication

Users can log in with the authentication modules that are assigned to the Job Server
application and enabled.

The users require the JobServer_Status program function.

Table 23: Module parameters

Parameter Description

Job provider ID (ProviderID) ID of the Job provider with the connection
configuration to use for logging in. This must be
either a MSSQLJobProvider or an
AppServerJobProvider. If this is empty the
first Job provider is used.

Application URL (AppURL) (Optional) This option is only required if the
users can log in with OAuth2 or OpenID Connect.
The URL must match the value in the
QBMWebApplication.BaseURL column. A
OAuth2/0penID Connect configuration is
assigned to the web application.
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Parameter Description

The following URL must be given in the
configuration and the connected external system
as the redirect URL.

https://<jobserver>:<port>/login

Cleanup after inactivity Specifies the time period after which the session

(RemoveSessionAfterInactivity) isremoved from memory. The next time the
session is accessed, it is reestablished
transparently for the user. The default value is
00:10:00.

Timeout format:

hours:minutes:seconds
Session timeout Specifies how long a session stays connected.
(SessionTimeout) After timeout expired or when the Job server is

restarted, the session is ended. The default
value is 1.00:00: 30.

Timeout format:

day.hour:minutes:seconds

e WindowsHttpAuthentication

Use this authentication type to specify an Active Directory group, whose users can be
authenticated on the HTTP server.

Module parameters are:

e Group (Role): Active Directory group. A security ID (SID) or the
Active Directory group name in the domain of the Job server can be specified. If
the Active Directory group is not located in the domain of the Job server, the
SID must be used.

e Debug login errors (DebuglLoginErrors): (Optional) User account
properties and groups are written to the log file to debug login problems.
Do not set this value in production environments as group assignments can
be written to the log.

NOTE: If a module is not specified, authentication is not required. In this case, all
users can access the services.

For more information, see Configuring the One Identity Manager Service.
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Advanced logging in the
One Identity Manager Service

To use advanced logging for the One Identity Manager Service, configure the storage of log
files in the One Identity Manager Service configuration file in the Connection module.

NOTE: The given directories must exist and the One Identity Manager Service user
account must have write permissions to the directory.

The following parameters are available:

e Process generation log directory (JobGenLogDir)

Log files are created in the specified directory to log the process generation
instructions generated by One Identity Manager Service.

For more information, see Configuring the One Identity Manager Service.

Extended debugging in
One Identity Manager Service

The Configuration module of the One Identity Manager Service configuration file provides
two parameters for advanced debugging:

e DebugMode
e ComponentDebugMode

If the Debug mode (DebugMode) parameter is enabled, the One Identity Manager Service
writes more extensive information into the log file, such as all parameters transferred to a
component and the results of the process handling and their Out parameters.

Individual One Identity Manager Service process components can output additional process
data to the One Identity Manager Service log file. For this purpose, you can enable the
Component debug mode (ComponentDebugMode) parameter in the configuration module.
Use this debug mode only for localizing errors because the effect on performance means
that it is not recommended for normal use.

For more information, see Configuring the One Identity Manager Service.
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Outputting custom messages in the
One Identity Manager Service log file

IMPORTANT: You should never use the VB.NET functions Msgbox and Inputbox on
servers. Use the functions VID Write2lLog, RaiseMessage or
AppData.Instance.RaiseMessage.

You can use the RaiseMessage and AppData.Instance.RaiseMessage script engine tasks from
within process steps to write custom messages to the One Identity Manager Service log file.
Use the ScriptComponent process component to run the scripts.

The messages in the log file are marked in color depending on the specified severity
(MsgSeverity parameter).

Figure 7: Example output of custom messages to the
One Identity Manager Service log file

2007-08-10 12:4B:58 - Warning: Example warning messade
2007-08-10 12:4B:58 - Info: Example Info message

2007-08-10 12:48:5 Example error messade

RaiseMessage

The output is consolidated with other messages and logged at the end of processing the
process step.

Syntax:

RaiseMessage (MsgSeverity, "string")

Example: Using RaiseMessage output

RaiseMessage (MsgSeverity.Warning, "Example warning message")
RaiseMessage (MsgSeverity.Info, "Example Info message™)

RaiseMessage (MsgSeverity.Serious, "Example error marked message")

AppData.Instance.RaiseMessage

The output is issued immediately during processing regardless of whether processing of the
process step has ended.

Syntax:

AppData.Instance.RaiseMessage (MsgSeverity, "string")

One Identity Manager 10.0 Process Monitoring and Troubleshooting

(ONE IDENTITY cuide | 59

Configuring logs in One Identity Manager



Example: Using AppData.Instance.RaiseMessage output
AppData.Instance.RaiseMessage (MsgSeverity.Warning, "Example warning
message")

AppData.Instance.RaiseMessage (MsgSeverity.Info, "Example Info message")

AppData.Instance.RaiseMessage (MsgSeverity.Serious, "Example error marked
message")

\

For more examples of One Identity Manager Service log file output, see the script example
on the installation medium in the directory QBM\dvd\AddOn\SDK\ScriptSamples.

Logging One Identity Manager Service
messages in the event view

To log One Identity Manager Service messages in the server's event log, modify the
EventLoglLogWriter module in the One Identity Manager Service's configuration file. To
view the event log, you can use the results display in the Microsoft Management Console,
for example.

Table 24: EventLogLogWriter parameters

Parameters Description

EventID The ID of the messages written to the event log.

EventLog Name of the event log to which the messages are written. The messages
are written to the application log with Application as the default value.

NOTE: If more than one One Identity Manager Service write event
logs on a server, make sure that the first eight letters in the log
name are unique on the server.

Category The category of the messages written to the event log.
Source The name of the source of the messages written to the event log.

LogSeverity Severity levels of the logged messages.

Permitted values are:

« Info: All messages are written to the event log. The event log
quickly becomes large and confusing.

* Warning: Only warnings and exception errors are written to the
event log (default).

e Serious: Only exception messages are written to the event log.
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Process handling errors can also be written to a server’s result log. To do this, use the
LogComponent process component.

For more information, see Configuring the One Identity Manager Service.

Related topics

e Changing the event log for the One Identity Manager Service on page 61

Changing the event log for the
One Identity Manager Service

By default, the One Identity Manager Service only logs messages in the event log
Application.

To use an event log with a different name

1. On the Job server, manually add the file for theOne Identity Manager Service to write
to. You can use PowerShell, for example, to do this.

a. Run PowerShell as administrator on the Job server.
b. Run the following CmdLet:
New-EventLog -Source "Foobar" -LogName "<file name>"

2. Enter this file name in the One Identity Manager Service configuration file, in the
module EventLogWriter as the name for the event log.

3. Restart the computer.
4. Restart the One Identity Manager Service.

HTTPLogPlugins log file

If the HTTPLogPlugin plug-in is configured in the One Identity Manager Service
configuration file, a log file is generated with the HTTP queries of the

One Identity Manager Service. The file is written in Apache HTTP Server Combined Log
Format.

Example: HTTPLogPlugins log entries

XXX.XX.X.XX - - [03/Feb/2005:14:55:48 +0100] "GET /resources/JobService.css
HTTP/1.x" OK -
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"http://<Servername>:<Portnummer>/status/LogWriter/Config""Mozilla/5.0
(Windows; U; 5.1; de-DE; rv:1.7.5) Gecko/20041108Firefox/1.0"

Table 25: Meaning of each entry

Entry Meaning
XXX XX X XX IP address that sent the
request.

- Client user name using IDENT
protocol (RFC 1413)-

- User name of the client
according to HTTP authen-

tication.

[03/Feb/2005:14:55:48 +0100] Time that the request is
processed on the server

GET /resources/JobService.css HTTP/1.x Request

OK Status code-

- Size of data sent back to the
browser

"http://<server URL from which the page can

name>:<port>/status/LogWriter/Config" be accessed

"Mozilla/5.0 (Windows; U; Windows NT 5.1; de- Browser name
DE; rv:1.7.5) Gecko/20041108Firefox/1.0"

For more information, see Configuring the One Identity Manager Service.

Logging messages from target system
connectors

By default, the messages from the target system connectors are logged in the
One Identity Manager Service's log file. External processes are logged in the StdioProcessor
log file (StdioProcessor.log).

The connectors for Active Directory, Oracle E-Business Suite, HCL Domino, SAP R/3, and
SCIM additionally log the following information for a message:

e TargetSystem: Target system ID of the connector.

 Method: Method that caused the logging to start.
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e« Number: Unique error number.

e Message: Error message.

Example: Target system connector messages

{ "Message": "Target:\"SCIM\" Method:\"OnConnect\" Number:\"2550101\"
Message:\"Method OnConnect called.\"", "TargetSystem": "SCIM", "Method":
"OnConnect"”, "Number": "2550101", "Message": "Method OnConnect called.",
"SessionId": "SCIM-©B4926", "Parent": "Log Event: Logger='SystemConnector'
Level=Debug Message='Connecting target system...' SequenceID=1213",
"Indention": "\t" }

Related topics

» Displaying the One Identity Manager Service log file on page 40
e Configuring One Identity Manager Service logging on page 53

Output of extended return values from
individual process components

Individual process components have process tasks with parameters that supply extended
return values (OUT).

The entire output of the parameter is written to the One Identity Manager Service log file
when a error occurs. For example, the output text of the listed commands or programs
can be returned when you run a command or a program using the CommandComponent
process component.

To log return values

e Inthe Designer, enable the Common | Jobservice | DoReturnOutput
configuration parameter.

Related topics

e OUT parameters on page 24

Enabling the CrashRecorder

The CrashRecorder saves the previous 128 messages starting at Debug level and issues
these in the error message window. You can configure the CrashRecorder in the
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One Identity Manager tools configuration files (appsettings.<appName>.json).

Table 26: CrashRecorder configuration settings

Setting Description

Enabled Enable (true) and disable (false)

Buffer Specifies how many entries are saved and output.

Default: 128 entries.

Level Severity level of entries to record. Permitted values are Debug, Error, Fatal,
Info, Off, Trace, and Warn.

Default: Debug

For an example configuration, see the appsettings.json configuration file in the
One Identity Manager installation directory. For more information, see Configuration of
settings for the One Identity Manager tools.

Example: CrashRecorder configuration in the appsettings.json
configuration file

C 3

"CrashRecorder": {
"Enabled": "false",
"Buffer": "128", // count of entries to buffer
"Level": "Debug" // NLog.LoglLevel e.g. Debug, Trace, Warn, Error

Related topics

» The error message window in One Identity Manager tools on page 34

e Configuring One Identity Manager component logging with NLog on page 49
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Generating log messages for SIEM
systems

Once objects have been changed in One Identity Manager, log messages for defined
changes can be automatically generated in Common Event Format (CEF) and sent to a
specified syslog server, for example One Identity syslog-ng Store Box. Security
Information and Event Management (SIEM) systems are then able to analyze the messages
to identify and respond to potential security incidents, for example.

To send messages to a SIEM system via a syslog server

e Inthe Designer, set the QBM | CEF configuration parameter and configure the
connection to the syslog server using the following configuration parameters.

« QBM | CEF | HosthameOrIP: Host name or IP address of the syslog server.
e QBM | CEF | Port: Port for communicating with the syslog server.

e QBM | CEF | Protocol: IP protocol type for communicating with the syslog
server. Permitted values are:

e TCP: Communicate with the syslog server via TCP.
e UDP: Communicate with the syslog server via UDP.

For more information about setting configuration parameters, see Editing
configuration parameters.

e In the Designer, enable and configure the Send object changes to syslog
server schedule.

For more information on enabling schedules, see Enabling and disabling schedules.
e Enable the SIEM message definitions that you want to use for logging.

For more information, see Enabling or disabling SIEM message definitions on
page 71.

e Optionally, change the severity level of a message. You can create other SIEM
message definitions as required.

For more information, see Adjusting the severity level of SIEM message definitions
on page 71 and Creating custom SIEM message definitions on page 72.
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Default SIEM message definitions

One Identity Manager provides different SIEM message definitions. The SIEM message
definitions contain templates that are used to generate the messages. These are sent to a
SIEM system. The event ID and activity are used to categorize and group the messages for
further evaluation, for example for reports or statistics, or to create correlation rules.

System messages

SIEM message definitions for system messages are always available.

Table 27: SIEM message definitions for system messages

Event ID Activity Description

50 Successful/informal login  Successful login messages.

51 Failed login Incorrect login attempt messages.

60 Job queue message Information and debugger output of the Job

queue and the One Identity Manager Service.

61 Job queue miscellaneous Messages coming from other components.
messages

70 DBQueue information or The DBQueue Processor provides information,
warning warnings, and debugger output.

71 DBQueue error Error messages for the DBQueue Processor.

Messages for identities

NOTE: These SIEM message definitions are available if the Identity Management
Base Module is installed.

Table 28: SIEM message definitions for identities

Event ID Activity Description

40 Identity security risk A security risk for an identity was identi-
triggered fied.

41 Identity security risk cleared The identity's security risk was revoked.

80 Identity reactivated An identity was reactivated.

One Identity Manager 10.0 Process Monitoring and Troubleshooting

(ONE IDENTITY cuide | 66

Generating log messages for SIEM systems



Messages for requests

NOTE: These SIEM message definitions are available if the Identity Management
Base Module is installed.

Table 29: SIEM message definitions for requests

Event ID Activity Description

10 Request submitted A request was submitted.

11 Request approved A request was granted approval.

12 Request approved A request was granted approval and assigned.

13 Request denied A request was denied.

14 Request approved A request was approved, even though the recom-
despite recom- mendation was to deny it.

mendation to deny

Messages for attestation

NOTE: These SIEM message definitions are available if the Attestation Module is
installed.

Table 30: SIEM message definitions for attestation

Event ID Activity Description
20 Attestation An attestation was approved.
approved
21 Attestation denied An attestation was denied.
22 Attestation An attestation was approved despite the

approved despite recommendation to deny it.
recommendation
to deny

Messages for compliance

NOTE: These SIEM message definitions are available if the Compliance Rules Module
is installed.
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Table 31: SIEM message definitions for compliance

Event ID Activity Description

30 Rule violation detected A rule violation has been detected.

31 Exception approval granted for rule An exception was granted for a rule
violation violation.

32 Exception approval denied for rule  An exception was denied for a rule
violation violation.

Messages for user accounts

NOTE: These SIEM message definitions are available if the corresponding target
system module are installed.

Table 32: SIEM message definitions for user accounts and permissions

Event ID Activity Description
81 Mailbox enabled in Microsoft Exchange A mailbox was enabled in
Microsoft Exchange.
81 User account enabled in A user account was enabled in
Active Directory an Active Directory domain.
81 User account enabled in AIX system A user account was enabled in
an AIX system.
81 User account enabled in cloud applic- A user account was enabled in a
ation cloud application.
81 User account enabled in cloud target A user account was enabled in a
system cloud target system.
81 User account enabled in Domino A user account was enabled in a

Domino domain.

81 User account enabled in A user account was enabled in
Google Workspace Google Workspace.
81 User account enabled in LDAP A user account was enabled in

an LDAP domain.

81 User account enabled in Microsoft A user account was enabled in a
Entra ID Microsoft Entra ID client.
81 User account enabled in OnelLogin A user account was enabled in
OneLogin.
81 User account enabled in Oracle E- A user account was created in
Business Suite Oracle E-Business Suite.
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Event ID

Activity

Description

81

81

82

82

82

82

82

82

82

82

82

82

82

82

82

(ONE IDENTITY

User account enabled in
Privileged Account Management
system

User account enabled in SAP R/3

Permission granted in Active Directory

Permission granted in Domino

Permission granted in
Google Workspace

Permission granted in LDAP

Permission granted in Microsoft Entra
ID

Permission granted in OnelLogin

Permission granted in Oracle E-
Business Suite

Permission granted in SharePoint

Permission granted in
SharePoint Online

Permission granted in Unix

Permissions granted in cloud
application

Permissions granted in cloud target
system

Permissions granted in
Privileged Account Management
system

A user account was enabled in a
PAM appliance.

A user account was enabled in
an SAP R/3 client.

A group was assigned to a user
account in an Active Directory
domain.

A group was assigned to a user
account in a Domino domain.

A group was assigned to a user
account in Google Workspace.

A group was assigned to a user
account in an LDAP domain.

A group was assigned to a user
account in a Microsoft Entra ID
tenant.

A group was assigned to a user
account in OnelLogin.

A group was assigned to a user
account in Oracle E-
Business Suite.

A group was assigned to a user
account in SharePoint.

A group was assigned to a user
account in a SharePoint Online
tenant.

A group was assigned to a user
account in a Unix host.

A group was assigned to a user
account in a cloud application.

A group was assigned to a user
accountin a cloud target
system.

A group was assigned to a user
account in a PAM appliance.
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Event ID

Activity

Description

82

82

82

83

83

83

83

83

83

83

83

83

83

83

83

83

83

83
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User account added to group in
SAPR/3

User account added to profile in
SAPR/3

User account added to role in SAP R/3

Mailbox created in Microsoft Exchange

User account created in
Active Directory

User account created in cloud
application

User account created in cloud target
system

User account created in Domino

User account created in
Google Workspace

User account created in LDAP

User account created in Microsoft Entra
ID

User account created in OnelLogin

User account created in Oracle E-
Business Suite

User account created in
Privileged Account Management
system

User account created in SAP R/3
User account created in SharePoint
User account created in

SharePoint Online

User account created in Unix

A group was assigned to a user
account in an SAP R/3 client.

A profile was assigned to a user
accountin an SAP R/3 client.

A role was assigned to a user
account in an SAP R/3 client.

A mailbox was created in
Microsoft Exchange.

A user account was created in
an Active Directory domain.

A user account was created in a
cloud application.

A user account was created in a
cloud target system.

A user account was created in a
Domino domain.

A user account was created in
Google Workspace.

A user account was created in
an LDAP domain.

A user account was created in a
Microsoft Entra ID tenant.

A user account was created in
OneLogin.

A user account was created in
Oracle E-Business Suite.

A user account was created in a
PAM appliance.

A user account was created in
an SAP R/3 client.

A user account was created in
SharePoint.

A user account was created in a
SharePoint Online tenant.

A user account was created in a
Unix host.
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Enabling or disabling SIEM message
definitions

Enable the SIEM message definitions that you want to use for logging.

To enable SIEM message definitions

1. In the Designer, select the Base Data > Advanced >SIEM message
definitions category.

2. Inthe List Editor, select the SIEM message definition.
3. Inthe Properties section, for the Disabled property, select the value False.

4. Select the Database > Commit to database menu item and click Save.

If you no longer need a SIEM message definition, you can disable it again.

To disable SIEM message definitions

1. In the Designer, select the Base Data > Advanced >SIEM message
definitions category.

2. Inthe List Editor, select the SIEM message definition.
In the Properties section, for the Disabled property, select the value True.

Select the Database > Commit to database menu item and click Save.

Adjusting the severity level of SIEM
message definitions

You can adjust the severity level for standard SIEM message definitions. The severity level
describes the importance of a message.

To change the severity level of a SIEM message definition

1. In the Designer, select the Base Data > Advanced >SIEM message
definitions category.

In the List Editor, select the SIEM message definition.

In the Properties section, from the value drop-down, select a value for the Severity
property. Permitted values are:

e 0-3: Low
e 4-6: Medium
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e 7,8: High
e 9,10: Very high
4. Select the Database > Commit to database menu item and click Save.

Creating custom SIEM message
definitions

To create custom SIEM message definitions, you can:

e Copy and customize a default SIEM message definition

e Create a new SIEM message definition

To copy a default SIEM message definition

1. In the Designer, select the Base Data > Advanced >SIEM message
definitions category.

2. In the List Editor, select the SIEM message definition and then the Copy
context menu item.

3. Select New.

This creates a new SIEM message definition. It copies the main data from the default
SIEM message definition.

4. Customize the new SIEM message definition to suit your requirements.

(Optional) Disable the copied standard SIEM message definition if you no
longer need it.

6. Select the Database > Commit to database menu item and click Save.

To create a new SIEM message definition

1. In the Designer, select the Base Data > Advanced >SIEM message
definitions category.

2. In List Editor, select the New context menu item.
This creates a new SIEM message definition.
3. Enter the SIEM message definition main data.

4. Select the Database > Commit to database menu item and click Save.

Related topics

e Enabling or disabling SIEM message definitions on page 71
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SIEM message definition properties

The following properties are mapped for SIEM message definitions.

Table 33: SIEM message definition properties

Property Description
Activity Name of the activity.
Column (Optional) Specification of a column whose change in value is expected to
trigger a message.
Disabled Specifies whether the SIEM message definition is enabled. Permitted
values are:
* True: The SIEM message definition is disabled.
* False: The SIEM message definition is enabled.
Event ID ID for categorizing and grouping events.
Message Text template for the message to send. Use placeholders to include values
template of each object in the message text. The values are defined in parameters

Parameters 1
to
parameters 5

1to5.
Example:
The identity {@} has been reenabled.

Property of the individual object for which the message is generated. The
properties can be referenced in the text template for the message and
output in the message text.

Use dollar ($) notation to specify simple properties, primary key columns,
and foreign key columns of the selected table.

Example:
>$CentralAccount$
$UID Person[D]$

Scripts can be passed with the notation $Script(<script name>)$. The
script called must use a function that is defined as <ScriptName>(IEntity)
as String.

Example:
$Script(QER_GetDisplayForPersonWantsOrg)$

For more information, see Using dollar ($) notation.

Selection Condition for restricting which elements can be selected. The condition is
condition formulated as a where clause and refers to the selected Table.
To determine changes to column values, use the syntax new.<column
name> and old.<column name> when formulating the selection condition.
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Property

Description

Severity
code

Table

Type of
action

Formulation of the various operations:

e Insert a value: new.<column name> = <value>
e Delete a value: old.<column name> = <value>

e Change a value: old.<column name> = <old value> and
new.<column name> = <new value>

Example:

An identity was classified as a security risk. The
Person.IsSecurityIncident column is queried.

The Person table is defined as the table. The selection condition is
formulated as follows:

old.IsSecurityIncident = @ and new.IsSecurityIncident =1

Severity of the message to display in the SIEM system. Permitted values
are:

e 0-3: Low

e 4-6: Medium

¢ 7,8: High

¢ 9,10: Very high

Table with the data changes that result in messages being generated.
Only tables type Table or View with an object key (XObjectKey) and a
primary key are permitted.

The event for which a message is to be generated. Permitted values are
Insert, Update and Delete.

Related topics

» Enabling or disabling SIEM message definitions on page 71

e Adjusting the severity level of SIEM message definitions on page 71
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About us

One Identity solutions eliminate the complexities and time-consuming processes often
required to govern identities, manage privileged accounts and control access. Our solutions
enhance business agility while addressing your IAM challenges with on-premises, cloud and
hybrid environments.

Contacting us

For sales and other inquiries, such as licensing, support, and renewals, visit
https://www.oneidentity.com/company/contact-us.aspx.

Technical support resources

Technical support is available to One Identity customers with a valid maintenance contract
and customers who have trial versions. You can access the Support Portal at
https://support.oneidentity.com/.

The Support Portal provides self-help tools you can use to solve problems quickly and
independently, 24 hours a day, 365 days a year. The Support Portal enables you to:

e Submit and manage a Service Request

e View Knowledge Base articles

e Sign up for product notifications

» Download software and technical documentation

e View how-to videos at www.YouTube.com/Oneldentity
e Engage in community discussions

e Chat with support engineers online

e View services to assist you with your product
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