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About this guide

This guide is intended for end users, system administrators, consultants, analysts, and
other IT professionals who want to learn about secure handling of One Identity Manager
tools, in particular the Manager and the Designer.

The interfaces of the Manager and Designer have a similar layout. The basic elements and
functions of the user interface are the same for all of the One Identity Manager tools. The
user interface layout is explained based on the example of the Manager. Default functions
used in connection with the Manager Designer are described.

NOTE: This guide describes One Identity Manager functionality available to the default
user. It is possible that not all the functions described here are available to you. This
depends on your system configuration and permissions.

Available documentation

You can access One Identity Manager documentation in the Manager and in the Designer by
selecting the Help > Searchmenu item. Videos with additional information can be found
at www.YouTube.com/OneIdentity.
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2

One Identity Manager tools user
interface

The user interface layout and operation of One Identity Manager tools is explained using
the Manager as an example. Manager functionality can be provided as a Manager web
application via the API Server. The Manager web application user interface differs slightly
from the Manager user interface. The basic elements and functions of the user interface are
the same for all of the One Identity Manager tools.

Certain components of the One Identity Manager’s graphical user interface are stored in the
One Identity Manager schema and can be tailored to suit customer requirements. Menu
items in the navigation structure, interface forms, and tasks (task definitions) can be
configured in this way.

Menu items, interface forms, and task definitions are assigned to permissions groups.
The user's effective components of the user interface depend on the authentication
module used for logging in to the One Identity Manager tools. If a user logs in to a
One Identity Manager tool, a system user is found and the available menu items,
interface forms, task definitions, and individual program functions are identified
depending on the permission groups to which this system user belongs and the adapted
user interface is loaded.

Data is displayed as objects in the user interface. User interface objects are meta-objects.
You provide a selection of configurable elements that describes how the data stored in the
database is perceived. These objects enable data to be distinguished by specific properties.
They provide an additional control function for configuring the user interface. Hence,
interface forms and tasks are linked to object definitions, which means that different forms
and tasks are displayed in the user interface depending on which object is selected.

For more information about how to customize the user interface to your specific
requirements, see Editing the user interface.

One Identity Manager 10.0 User Guide for One Identity Manager
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Working with the Manager

The Manager is the main administration tool for setting up all identity data. It displays and
maintains all the data required for the administration of identities, their user accounts,
permissions, and company-specific roles in a One Identity Manager network. Company
resources required to carry out tasks can be configured and assigned to identities.

You can also use the Manager to:

l Define custom IT policies.
l Set up an IT Shop from which company resources and assignments can be
requested.

l Set up special approval processes for authorizing requests and checking compliance
to IT policy.

l Set up attestation procedures for regularly testing the correctness of data about
identities or roles and their assignments.

By implementing One Identity Manager application roles, every One Identity Manager user
obtains only those permissions they require to fulfill necessary administrative duties.

The user interface layout

You can control the One Identity Manager tools' graphical user interface with using mouse
and shortcuts. A minimum screen resolution of 1280 x 1024 pixels is recommended with at
least 16 bit color for the best display.
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Figure 1: Manager user interface

The user interface consists of the following components:

A. Title bar

In the title bar, you can see the program icon, program name, and connected
database shown using the notation <user>@<database server>\<database
(description)>.

B. Menu bar

The menu bar gives you different menus and menu items. The menus Database and
Help are always there. If a database is open, you can see more menus.

C. Toolbar

Each program component comes with its own toolbar.

D. Editing section

The editing section has different views for displaying and editing data.

E. Status bar

The status bar displays different status data. Some status data is shown by way
of icons. Which icons are displayed is partially dependent on the program
settings selected.
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Menu items in the Manager

Menu Menu item Meaning Shortcut

Database New connection Establishes a database connection. Ctrl + Shift +
N

Close connection Closes the current database connection.

Change manage-
ment

Opens a dialog for editing change labels.

This item is only displayed in expert
mode.

Start/stop
simulation

The program switches between
simulation mode or normal operating
mode.

For more information, see Simulating
data changes in the Manager.

Change manage-
ment

Opens a dialog for editing change labels.

This item is only displayed in expert
mode.

For more information, see Working with
change labels.

Export data Opens a form for specifying which data to
export.

For more information, see Exporting data
with the Manager.

Show deferred
operations

Displays deferred operations.

For more information, see Scheduling
operation activation times.

Pending changes Shows changes pending for objects and
their processing status.

Check data
consistency

This opens the consistency check form.

For more information, see Checking data
consistency.

Change
password

The logged in user can change the
password.

Settings For configuring general program settings.

Exit Exits the program. Alt + F4

Table 1: Meaning of items in the menu bar
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Menu Menu item Meaning Shortcut

Object New Adds a new object with the displayed
object type.

Ctrl + N

Save Saves all changes to an object. Ctrl + S

Set the change
time

Opens a calendar to set the time to make
the change.

For more information, see Scheduling
operation activation times.

Delete Deletes selected object. Ctrl + D

Set deletion
time

Opens a calendar to set the time to delete
the object.

For more information, see Scheduling
operation activation times.

Undo delete Prompts to revert the deletion process.

This item is only available if the object is
marked for deletion.

Discard changes Discards any unsaved form entries. Ctrl + Shift +
D

Reload Reloads the object. Ctrl + F5

Properties Show other properties of the active
object.

This item is only displayed in expert
mode.

Reapply
templates

Reapplies all the object templates.

This menu item is only shown for the main
data form of the object.

Add to favorites
or remove from
favorites

Add the current object to your favorites or
remove it from your favorites. These
options are shown alternately.

Ctrl + B

Back Shows the previous form in the order in
which the forms were viewed.

Alt + left
arrow

Forward Shows the next form in the order in which
the forms were viewed.

Alt + right
arrow key
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Menu Menu item Meaning Shortcut

View Navigation Activates the navigation view. Ctrl + Q
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Menu Menu item Meaning Shortcut

Result list Opens the result list. Ctrl + R
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Menu Menu item Meaning Shortcut

Documents Enables the current document. Ctrl + O

Favorites Shows or hides the favorites list.

Tasks Shows or hides the task view.

Error log Shows or hides the error log.

For more information, see Displaying
error log messages.

Process
Information

Shows or hides the process view.

For more information, see Analyzing
process monitoring in the
One Identity Manager.

TimeTrace Shows or hides the TimeTrace.

For more information about TimeTrace,
see Analyzing data and data changes.

Database search Shows or hides the database search.

Start page The start page is displayed.

Enable quick
edit mode

The quick editing of objects is enabled or
disabled.

Close current
document

Closes the current document. F4

Close all
documents

Closes all open documents.

Enable
document

Shows all open documents. You can
toggle from one open document to the
next.

Layout Changes the layout of the program’s
interface.

Ctrl + Shift +
L (loads in
expert mode)

Display field
definitions

The technical table and column names are
shown in the editing forms.

This item is only displayed in expert
mode.

Display
navigation
objects

Displays the loaded navigation objects.

This item is only available if Show
additional navigation information is
enabled in the program settings.
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Menu Menu item Meaning Shortcut

Plug-ins Name of the
plug-in.

Shows the available plug-ins so that you
can apply them.

Help Community Opens the One Identity Manager
community website.

Support portal Opens the One Identity Manager product
support website.

Training Opens the One Identity Manager training
portal website.

Online
documentation

Opens the One Identity Manager
documentation website.

Search Opens the search dialog.

Form help Opens the help for this form. F1

Info Shows the version information for
program.

Icon Meaning

Show homepage.

Show the previous form in the order in which the forms were viewed. You can
display the form history from the menu. You can select any form you wish from
here.

Show the next form in the order in which the forms were viewed. You can display
the form history from the menu. You can select any form you wish from here.

Show or hide the database search dialog.

Add a new object of that object type.

Saves changes.

Set time at which to save an object's changes.

For more information, see Scheduling operation activation times.

Deletes object.

Set time at which to delete the selected object.

For more information, see Scheduling operation activation times.

Redo delete. This option is only available if the object was marked for deletion.

Discard unsaved changes from the form.

Table 2: Toolbar functions
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Icon Meaning

Update object.

Add object to favorites.

Remove object from favorites.

Print form. Printer settings are configured in the configuration menu.

Status bar in the Manager

The status bar displays different status data. Some status data is shown by way of icons.
Which icons are displayed is partially dependent on the program settings selected. The
status bar comes in different colors.

Color Meaning

none Database for development is connected.

Red Simulation mode is enabled.

Green Database for testing is connected.

Yellow Database for production is connected.

Table 3: Meaning of the colors

Icon Meaning

Current user.

The DBQueue Processor was stopped.

The services were stopped.

The database is connected. The connected database is displayed in the following
format: <Server>\<database (description)>.

TIP: Double-click the database connection identifier in the status bar to
copy it into the clipboard.

Database status (database activity such as loading or saving objects).

The database must be compiled.

The database is in recovery mode. It is not possible to process data at this time.

Table 4: General icons in the status bar
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Icon Meaning

There are invalid script assemblies. The database must be compiled.

No connection.

Display for step-by-step preparation of a database update. All database users
will be informed about the upcoming update. The system does accept anymore
processes.

Display for step-by-step preparation of a database update. Users cannot log in to
the database anymore. All running processes will still be completed.

Display for step-by-step preparation of a database update. The database is
updating.

Information available.

A warning was reported.

An error was reported.

Icon Meaning

Quick edit mode is enabled.

The field definitions (technical table names and column names) are displayed.

Additional information on the navigation objects is displayed.

The program is in simulation mode.

The system data was modified.

Definition of the current object.

TIP: Double-click the objects definition in the status bar to copy it into the
clipboard.

Table 5: Additional icon in the status bar in the Manager

Related topics

l The user interface layout on page 9
l Document view in the Manager on page 37
l Displaying columns names on page 43
l Detailed information about the user interface on page 64
l Information about the logged in user in the Manager on page 24
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Help in the Manager

By default, the Online documentation is used in the help system. The help system can also
be installed locally.

Access the One Identity Manager documentation in the Manager via the Help > Online
documentationmenu. If local help is installed, the Help > Search in local helpmenu is
also available.

To open the help for individual forms use the Help > Form helpmenu item or F1.

With some forms, a separate dialog appears. Use the help icon (?) in the title bar of the
dialog window to open the help for a dialog window.

Every form also has a help display for the columns shown. Clicking on the help icon
changes the cursor into the help icon. You can then click a column description to display
tips about using the column in the form of tooltips.

Layout mode in the Manager

The Manager can display the editing area in standard mode or expert mode. The layout of
the default view varies between modes. The current user's layout is saved in the user
configuration so that when you restart the program the last layout you used is shown.

Simple layout mode in the Manager

The simple layout mode provides two other layouts in addition to the default layout.

To select the simple layout mode in the Manager

1. In the Manager, select the Database > Settingsmenu item.

2. On the User tab, disable the Enable expert mode option.

To change the layout in the Manager

l To specify a layout in the Manager, select the View > Layout > Classic or the View
> Layout > View 2menu item.

l To reset the layout to the default setting in the Manager, select the View > Layout
> Restore defaultmenu item.

One Identity Manager 10.0 User Guide for One Identity Manager
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Expert mode in the Manager

In expert mode you can use the mouse to change the position and size of the editing
windows in the user interface. You can use the pin in the title bar of a window to enable or
disable the auto-hide mode. If this mode is enabled, the selected window slides out of or
into the area. To select a window in auto-hide mode, use the symbol in the navigation
toolbar on the side. There are other menu items and functions available in expert mode.

To select expert mode in the Manager

1. In the Manager, select the Database > Settingsmenu item.

2. On the User tab, enable the Enable expert mode option.

To change the layout in the Manager

l To save the layout in the Manager, select the View > Layout > Savemenu item
and enter a Name.

l To load a layout in the Manager, select the View > Layout > Load or Ctrl + Shift
+ Lmenu item.

l To reset the layout to the default setting in the Manager, select the View > Layout
> Restore defaultmenu item.

l To load the classic layout, in the Manager, select the View > Layout >
Classic menu item.

Menu Menu item Meaning Shortcut

Database Change
management

Opens a dialog for editing change labels.

View Display field
definitions

The technical table and column names are
shown in the editing forms.

Layout > Save Save the current layout.

Layout > Load Load a layout. Ctrl + Shift
+ L

Object Properties Show other properties of the active object.

Table 6: Other menu items in expert mode

Context
menu

Meaning

Definition This shows advanced technical information about configuring a menu item.
This menu item is only available in navigation view. You must also enable
the Show additional navigation information program setting.

Properties Shows other properties of the object.

Table 7: Additional entries in the context menu in expert mode
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Tools User Interface

Working with the Manager

20



Related topics

l Displaying columns names on page 43
l Detailed information about the user interface on page 64
l Displaying extended properties for objects in the Manager on page 81

Manager program settings

You can adjust the program settings to suit your requirements.

To change the program settings in the Manager

l In the Manager, select the Database > Settingsmenu item.

User settings in the Manager

On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.

General

l Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.

l Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

l Enable quick edit mode: Specifies whether quick editing is enabled.

By default, an object‘s overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

l Enable expert mode: Specifies whether expert mode is used. Setting this option
switches the program from standard view mode to advanced mode.

l Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.

l Use technical display values: Specifies whether display names or technical names
are used when collating data exports.

One Identity Manager 10.0 User Guide for One Identity Manager
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Data query limits

l Enable query limit: Specifies whether the number of elements shown in the result
list and list items in controls is limited.

NOTE: The Enable query limits option can only be set if the user owns the
Common_AllowRiskyWhereClauses program function.

If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.

l Limit result list object count: Specify whether the number of items to display in a
result list is limited.

If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.

l Use system settings: Specifies whether the system settings are used for the
query limit.

If this option is set, then the global system settings from the Common |
DBConnection | ListLimit parameter is used. If the number of results is greater
than the defined number, a filter dialog opens.

l Objects: Personal setting for the object query limit. If the number of results is
greater than the defined number, a filter dialog opens.

Usage

l Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.

l Show recently used objects: Specify whether or not the most recently used
objects are displayed. If this option is set, the objects used last are shown in a
separate node in the result list.

l Object type count: This number specifies how many objects per object type are
shown per menu entry when the option Show recently used objects is enabled.

Debugging

l Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.

NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

l Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.
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Related topics

l Manager program settings on page 21
l Layout mode in the Manager on page 19
l Limiting items in a list using query limits on page 65

General program settings in the Manager

On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings

l Common language: Language for formatting data, such as data formats, time
formats or number formats.

l Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Related topics

l Manager program settings on page 21
l Detailed information about the user interface on page 64

Plug-ins available in the Manager

The Plugins tab shows the available program plug-ins with a short description of
their features.

To enable or disable a plug-in in the Manager

l Double-click the plug-in name.

NOTE: You can choose more plug-ins in the Manager menu by clicking Plugins.

Related topics

l Manager program settings on page 21
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Information about the logged in user in
the Manager

The program's status bar shows the name of the current user. Depending on the
authentication module used, this can be the full name of the identity or the designation of
the current system user. Use the tooltip to show the full name of the current user and the
current system user.

To get more information about the current user

l To display user information, double-click the icon in the program status bar.

Property Meaning

System users Name of system user

Authenticated
by

Name of the authentication module used for logging in.

Identity UID
(UserUID)

Unique ID for the current user’s identity if an identity-based authen-
tication module is used to log in.

SQL access level Access level of the database server used to log in.

Read-only The system user has only has read permissions. Modification to data
are not possible.

Dynamic user The current user uses a dynamic system user. Dynamic system users
are applied when a role-based authentication module is used.

Administrative
user

The current user uses an administrative system user.

Remarks More details about the system user in use.

Permissions
group

Permissions groups that are assigned to the system user. The permis-
sions groups determine the user's user interface and object permis-
sions.

Program
functions

Program functions assigned to the system user The menu items and
functions available depend on the program functions.

Table 8: Extra information about the current user
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Changing the password of the logged
in user

To change the password:

1. Select the Database > Change passwordmenu item and enter the following
information:

l Old password: Enter the previous password.
l New password: Enter the new password.
l Confirm new password: Enter the new password again.

NOTE: The password must comply with the password policy. To display
the requirements, click the Password requirements link.

2. Save with OK.

Views in the Manager

The editing area in the Manager has different views for displaying and editing data.

View Description

Navigation The navigation shows suggested navigation starting points for the current
user.

For more information, see Navigating in the Manager on page 26.

Result list When you select a menu item in the navigation view, one result list shows
all the objects that correspond to the object definition and the conditions
of the menu item. You can insert, edit or delete objects in the result list.

For more information, see Result lists in the Manager on page 29.

Document
view

The document view shows the forms to edit a selected object.

For more information, see Document view in the Manager on page 37.

Tasks The task list shows the tasks and reports available for an object.

For more information, see Tasks in the Manager on page 35.

Favorites This view is used to compile individual items into a user-specific favorites
list. Save entries that you use frequently in your favorites.

For more information, see Favorites in the Manager on page 36.

Table 9: Views in the editing area
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View Description

Error log The error log shows errors and warnings that occurred when working with
the Manager.

For more information, see Displaying error log messages.

Process
Information

This view is used to analyze the process data resulting from data changes.

For more information, see Analyzing process monitoring in the
One Identity Manager.

TimeTrace In this view you can track changes to an object that were made up to any
point in the past.

For more information about TimeTrace, see Analyzing data and data
changes.

Navigating in the Manager

The structure of the user interface navigation is hierarchical. The top level of the hierarchy
is used to classify the data managed by One Identity Manager into specified categories.
Categories include a range of different menu items.

In the Manager, select a category by locating the category tab in the bottom section of the
navigation. You can configure additional settings in the configuration menu.

Figure 2: Navigating in the Manager using the "Identities" category as an
example.
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Specific mouse commands are available:

l You can open or close a menu item by double-clicking on the entry name.
l Click the name of the menu item to show the found objects in the result list, as long
as a corresponding object for that object type is found. If there are no objects for a
defined menu item, an empty result list is shown.

Shortcuts for the navigation

In the Manager, you have the the following shortcuts in the navigation available.

Shortcut Action

Ctrl + Q Activate navigation structure.

Down arrow, up arrow, page down key, page up key,
home, end

Move up/down the navigation
structure.

<+> or right arrow key Open menu item.

<-> or left arrow key Close menu item.

Data Select an entry.

F5 Refresh the navigation

Table 10: General shortcuts for the navigation

Context menu for the navigation

The navigation has its own context menu. Menu commands are shown or hidden depending
on the selected menu item.

Context menu item Meaning

Open on new tab Opens the object in a new form in the document view.

Refresh view Updates the navigation.

Search The system searches for objects in the navigation.

Add to my
One Identity Manager

Copies the selected menu item to theMy
One Identity Manager category. This helps you navigate
quickly to frequently used menu items. The data is saved in the
user configuration.

Add to favorites Adds the selected object to your favorites.

Remove from favorites Removes the selected object from your favorites.

Show process inform-
ation

The process view shows the process data for the selected
object.

Table 11: Context menu items in the Manager navigation
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Context menu item Meaning

For more information, see Analyzing process monitoring in the
One Identity Manager.

Tasks The available tasks for the object are displayed and you can run
the desired task.

Definition Shows detailed information about configuring the menu item.
This item is only displayed in expert mode.

Show deferred opera-
tions

Shows the deferred operations for the objects in this category.

For more information, see Scheduling operation activation
times.

Navigation configuration

The navigation has a configuration bar with its own configuration menu. Use the
configuration menu to show or hide categories.

To open the navigation configuration menu

l Use the <...> button.

Configuration
menu item

Meaning

Show more categor-
ies

Shows more categories in the list. The category icon is removed
from the configuration bar.

Show fewer categor-
ies

Hides more categories in the list. These are represented by icons in
the configuration bar.

Add or remove
categories

Add categories to or remove categories from the list.

Table 12: Navigation configuration menu items

Related topics

l Detailed information about the user interface on page 64

My One Identity Manager

NOTE: This function is not available in the Manager web application.

The categoryMy One Identity Manager shows the user-specific entries in the Manager.
All the available infosystems and specific reports for the current user are shown here. In
this category you can create and apply user-specific filters.
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To copy a menu item to the My Manager category in One Identity Manager

l Click Add to My .One Identity Manager

This helps you navigate quickly to frequently used menu items. The data is saved in
the user configuration.

To delete a menu item from the My Manager category in One Identity Manager

l Click Remove from My .One Identity Manager

Context Menu Item Meaning

Remove from My
One Identity Manager

Removes the selected menu item from this category.

New filter Search criteria for database queries are saved as filters.

Edit filter The selected filter can be edited.

Remove filter Deletes the selected filter.

Attaching The selected filter is attached to a category. When you select a
category, all objects that correspond to the filter are shown on a
separate form page.

Export filter Exports the selected filter as an XML file.

Import filter Imports filters that exist as XML files.

Table 13: Additional entries in the context menu for the my
One Identity Manager category

Related topics

l Advanced database search on page 76
l Attaching filters in the Manager on page 73
l Exporting and importing filters in the Manager on page 73

Result lists in the Manager

A result list shows all the objects that correspond to the object definition and the conditions
of the menu item selected in the navigation view. You can insert, edit or delete objects in
the result list.

A result list tab shows the title of the list and the number of elements in it. The entries in a
result list can be sorted by columns. You can search for entries.
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Figure 3: Example of a result list in the Manager

Select an entry from the list. The object is loaded and the first available form appears in the
document view. If there are no objects for the selected menu entry, the document view
continues to show the most recently selected form.

The Manager makes the following functions available in a result list.

Configuring result list columns

Specify which columns are displayed in a result list and the order in which the
columns appear.

To select which columns to display

1. In the Manager, in the result list toolbar, select (Configure columns).

This opens the dialog to change the result list settings.

TIP: To display the technical names of the columns, select the Use technical
display values check box in the Manager program settings.

2. The columns are shown in the General section.
l Enable or disable the columns by clicking the button in front of the
columns name.

l Use the button to show or hide the column descriptions.
l Use the button to reset your selection.

3. Click OK.

To change the order in which columns are displayed:

1. In the Manager, in the result list toolbar, select (Configure columns).

This opens the dialog to change the result list settings.
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2. In the Change order section, select the columns you want to move. You can select
multiple columns using Shift + select or Ctrl + select.

3. Move the selected columns with the arrow keys.
l Use the button to move the selected column up.
l Use the button to move the selected column down.
l Use the button to reset the order.

4. Click OK.

Pin a result list

In the Manager, pin a result list using the pin. This keeps the result list open even if you
select another menu item or another category in the navigation. It allows you to switch
between different result lists.

Optimize loading of objects

In the Manager, by default, double-click loads an object. You can modify this behavior.

To load objects with a single click in the Manager

1. In the Manager, select the Database > Settingsmenu item.

2. On the User tab, enable the Use single clicks option.

How objects are displayed in the result list

In the Manager, an object is marked with the symbol that was set when the interface was
configured. If an object is deleted by the One Identity Manager Service, the object is
initially marked for deletion. It is permanently deleted only after a set time period. Objects
that are selected for deletion are marked with the icon.

New objects are displayed below the Added entry in the result list. The objects used are
displayed below the Recently used entry in the result list.

To display recently used objects in the Manager

1. In the Manager, select the Database > Settingsmenu item.

2. On the User tab, activate the Show recently used objects option and enter the
Object type count.

Displaying multiple forms in the document view

Select single objects one after the other to update the opened form in the document view.
Only one form is open at a time.

To display multiple forms in the document view of the Manager

l Use Alt + Click or click Open on new tab from the context menu to open
the objects.
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This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

Shortcuts for the result list

In the Manager you can use the following shortcuts in the results list.

Shortcut Action

Ctrl + R Enable result list.

Down arrow, up arrow, page down key,
page up key, home, end

Move up/down the list.

Enter, Alt + Enter Open an item.

Shift + selection + Enter , Ctrl +
selection + Enter

Select multiple entries and open the main data
form to edit multiple entries.

F5 Update the result list.

Table 14: Common shortcuts for the result list in the Manager

Result list toolbar

The result list in Manager has its own toolbar.

Icon Function

Quick edit. This opens the main data form. Selected objects can be edited
directly.

New. Creates a new object.

Delete. Deletes the object.

Undo delete. Reverts the delete action.

Refresh view. Reloads the objects.

Search through result list.

Filter result list.

NOTE: The function is visible only if the users have the Common_
AllowRiskyWhereClauses program function.

Configure the columns in a result list.

Export result list.

Table 15: Toolbar features in the Manager

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Manager

32



Result list context menu

The result list in the Manager has its own context menu.

Context
Menu Item

Meaning

New Inserts a new object. Already entered insert values are applied.

Delete The selected object is deleted once the security prompt is confirmed.

Undo delete After confirming the security prompt, the object is undeleted. This option
is only available if the object was marked for deletion.

Open on new
tab

The object is opened in a new form in the document view.

Search Searches for objects in the result list.

Add to
favorites

Adds the selected object to your favorites.

Remove from
favorites

Removes the selected object from your favorites.

Show process
information

The process view shows the process data for the selected object.

For more information, see Analyzing process monitoring in the
One Identity Manager.

Tasks The available tasks for the object are displayed and you can run the
desired task.

Properties Show other properties of the active object. This item is only displayed in
expert mode.

Table 16: Entries in the result list context menu in the Manager

Related topics

l Expert mode in the Manager on page 20
l User settings in the Manager on page 21
l Custom filters in the Manager on page 68
l Displaying extended properties for objects in the Manager on page 81
l Multiple object edit in the Manager on page 82
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Adding, editing, or deleting objects in theManager

Add, edit, or delete objects via the result list.

To add an object in the Manager

1. In the Manager, select the category in which you want to add an object.

2. Click (New) in the result list.

This opens the main data form.

3. On the main data form, edit the main data of the object.

4. Save the changes.

To edit an object in the Manager

1. In the Manager, select the category.

2. In the result list, select the object.

3. Select the Change main data task.

This opens the main data form.

4. Edit the main data of the object.

5. Save the changes.

To delete an object in the Manager

1. In the Manager, select the category.

2. In the result list, select the object.

3. Click (Delete) in the result list.

4. Confirm the security prompt with Yes.

Editing multiple objects at the same time

You can edit several objects at the same time. For example, to set the same value
of certain properties for several objects. Properties with different values are marked
with the icon.

To edit multiple objects at the same time in the Manager

1. In the Manager, in the result list, use Shift + selection or Ctrl + selection to select
the objects.

2. In the result list, click the icon (Edit selected objects).

This opens the main data form.

3. Change the values as required.

4. Save the changes.

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Manager

34



Tasks in the Manager

When you select an object, the task list shows the tasks and title of available reports. To
run a task or open a report, select an item in the task list. Use the tooltip to show a more
detailed description of a task or a report.

Figure 4: Task lists in the Manager

TIP: If tasks are linked to preprocessor-relevant configuration parameters, the
preprocessor conditions are shown behind the tasks. To do this, enable the program
setting Show additional navigation information.

Related topics

l Detailed information about the user interface on page 64
l User settings in the Manager on page 21
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Favorites in the Manager

In the Manager, save objects from the result list that you use frequently in your favorites.

Figure 5: Example of a favorites list in the Manager

To add an object to the favorites from a result list

1. In the Manager, select the object from a result list

2. Select the Add to favorites context menu item.

To remove an entry from the favorites

1. In the Manager, in the Favorites view, select the object.

2. Select the Remove selected favorite(s) context menu item.

Favorites list toolbar

The favorites list in Manager has its own toolbar.

Icon Meaning

Sorts your favorites alphabetically.

Sorts your favorites by object type.

Deletes all favorites.

Deletes selected favorites.

Table 17: Meaning of entries in the special toolbar in the Manager
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Favorites list context menu

The favorites list in Manager has its own context menu.

Context
Menu Item

Meaning

Open on new
tab

Opens the object in a new form in the document view.

Search Searches for objects in the favorites list.

Remove
selected
favorites

Removes selected favorites from the favorites list.

Tasks A submenu shows all the tasks that are available for the selected object.
Select one of the tasks to open the relevant form.

Properties Shows other properties of the currently selected object. This item is only
displayed in expert mode.

Table 18: Context menu items in the Manager favorites list

Related topics

l Displaying extended properties for objects in the Manager on page 81
l Expert mode in the Manager on page 20

Document view in the Manager

When you select an object in the result list, the first available form is displayed in document
view. As a minimum, the following forms are displayed for each editable object:

l Overview form

This form is used only to display selected data for an object.
l Main data form

Use this form to change the object data.

Every form has a form tab bar that displays the selected object according to a set
display template.

NOTE: For outstanding objects, the display pattern on the form tab is marked
[Pending].
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Figure 6: Form in the Manager

Every form has a context menu with form-specific entries. In expert mode, you can use the
Properties entry in the form context menu to view additional object properties and the
permissions.

To open the forms belonging to an object

l When you select an object on the result list, the first form always opens (usually the
overview form).

l From the result list, select single objects one after the other to update the opened
form in the document view. Only one form is open at a time.

l To open other forms, select the task from the task view or from the form's
context menu.

To display multiple forms in the document view:

l Use Alt + Click or the Open on new tab context menu to open the objects.

This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

To close the forms:

l From the menu, select the View > Close active document or the View > Close
all documentsmenu item.

Quick editing

By default, an object‘s overview form is displayed first. You can, however, configure the
program to show the edit form for the object first, which allows faster editing.

To enable quick edit mode:

l In the Manager, use the icon in the result list.

It is only possible to quick edit the selected object.
l Select the View > Enable quick edit modemenu item.
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Restart the program to enable quick edit mode.
l From the Database > Settingsmenu item, select the Enable quick edit mode
program setting.

Quick edit mode remains enabled even if you restart the program.

Related topics

l Detailed information about the user interface on page 64
l Displaying extended properties for objects in the Manager on page 81

Overview forms

Overview forms display selected information about objects. Form elements are used to
present the information on the overview forms.

Figure 7: Example of elements in an overview form

The display text of the menu item, the display text for the objects to be shown and the
menu item icon are displayed in the header of a form element. Other data represents the
object properties and values. There is a tooltip for each property showing a description for
use. Some form element entries are highlighted in color when you click on them with the
mouse. Then you can click on the entry to switch to the referenced object.
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If the form element is used for mapping lists, the items are displayed with their names. The
number of items is shown in the form element header. There is also an icon in the form
element header for showing and hiding the items. The list items have a tooltip.

Icon Meaning

Show list items.

Hide list items.

Table 19: Form element icon

NOTE: Objects marked for deletion are struck through on the overview form.

Mandatory input fields

Input fields are used to edit strings, numbers, and dates. A default context menu is
available for input fields. Mandatory input fields are marked with a triangle . Whether an
input field is required or not depends on the minimum column length defined in the model
tables. Other required fields are defined in the customizers.

Figure 8: Input field with required field

TIP: You can use the Ctrl + Alt + Enter shortcut to enlarge the input fields for
entering multiline texts.

Labeling changed data

Changes to data are labeled with extra icons in front of the modified value. As long as the
changes have not been saved, you can undo the changes by clicking on the icon.

Figure 9: Labeling changed data
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Icon Meaning

Changed value. The value is not yet saved. Click the icon to discard the
change.

The value has a translation. Changing the value might loose the translation. A
mouse click on the icon opens a dialog where you can specify how to proceed
with the translation.

The value will be changed at a specified time. You can change the value only at
the specified time.

The value will be changed at a specified time.

Table 20: Labeling the input fields when data changes

For more information, see Scheduling operation activation times.

Related topics

l Translating input on page 41

Translating input

For more information about localization and editing translations in the Designer, see
Localization in One Identity Manager.

If a column is marked as multilingual, an extra button is displayed next to the input field.

NOTE:

l The value is always entered in the input field in the specified default language.
The value is then translated into the required languages.

l The translations are only used to display a value, for example, in the overview
form or in lists. The input fields to be edited still show the value entered in the
default language.

l You can edit translations in different places. When you change a translation, all
those places are shown. Before changing a translation, check in the Designer
about how it is used.

l Users can only edit object and column translations for which they have
permissions.

l To edit all translation, users require the Common_Translate program function.
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To translate an entry:

1. Click beside the input field to open the dialog window for entering the translations.

2. Use next to the translation field to delete a translation.

NOTE: You can use the button beside the translation input to delete a trans-
lation. In web applications, use the Delete button.

3. Click Save.

Figure 10: Translating entries

Handling issues caused by changing translation values

You can edit translations in different places. If you change a value that already has a
translation, the change to the value may cause the translation to be lost. New translations
must be created.

If you change a value that already has a translation, an additional button appears. This
allows you to create a copy of the existing translation.

Labeling of modified data with translations

To create a copy of the translations for the new value

1. In front of the input field, click .

This opens a dialog.

2. To create a copy of the translations for the new value, click Yes.

3. Click Save.

To make other changes to the translations or to delete unused translations, use the
Language Editor in the Designer.
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Displaying columns names

The column name is shown for every input field. If the full column name is too long to
display, it is shortened with [...]. Use a tooltip to display the full name.

In the Manager, you can display the technical names of the columns in expert mode. in the
format column@table.

To display the technical names in expert mode in the Manager

l In the Manager, select the View > Show field definitionmenu item.

Related topics

l Expert mode in the Manager on page 20

List of permitted values

If you have the option to set a list of permitted values for a column, the input field
looks like this:

l If there is no defined list, enter the value in the simple input field that appears.
l If there is a defined list, select the value from the selection list that appears.

Figure 11: Selecting from a list of permitted values

The control on the default forms in the Manager is only available for the predefined columns
and for the user-defined columns (generally Spare field no. 01–Spare field no. 10).

Entering multiple values

If a column is suitable for entering multiple values, the icons is shown next to the input
field. Use the context menu to run other actions. The number of items is displayed next
to the list.

Figure 12: Entering multiple values

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Manager

43



Context menu item Meaning

Add item Adds an item to the list.

Remove item Removes the selected item from the list.

Remove all items Removes all the items in the list.

Next item Selects the next item.

Previous item Selects the previous item.

Sort alphabetically Sorts the items in the list in alphabetical order.

Table 21: Context menu items for entering multiple properties

Setting values with the slider

Use the slider to set a value within a defined range. The value appears next to the slider
and can be displayed in full with the tooltip. The color indicates how critical the value is
assessed to be.

Figure 13: Slider

Entering scripts

This input field is used in the editors when the input data needs to have a specified
syntax (for example SQL, XML, or VB.Net). It has an advanced edit mode that provides
additional actions.

To switch to advanced mode

l Press Ctrl + Alt + Enter or click the button at the bottom right.
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Figure 14: Directly entering a database query

Icon Meaning

Quits advanced edit mode.

Undoes last change.

Redoes last change.

Cuts selected code.

Copies selected code into clipboard.

Inserts code from clipboard.

Deletes selected code.

Decreases insert.

Increases insert.

Automatic text formatting.

Formats text selection automatically.

Shows/hides line numbers.

Inserts comments.

Removes comments.

Inserts or removes line numbers.

Inserts or removes automatic line breaks.

Enable or disable automatic completion of words when they are entered.

Hides or shows tab and space characters.

Table 22: Meaning of icon in advanced edit mode
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Icon Meaning

Searches within code.

Inserts code snippet.

Shows list of objects properties.

Shows auto completion list.

Shows list with parameter information.

Shows additional information.

Shortcut Description

Ctrl + C Copy to clipboard.

Ctl + Ins Copy to clipboard.

Ctrl + X Cut and copy to clipboard.

Shift + Del Cut and copy to clipboard.

Ctrl + L Cut row and copy to clipboard.

Ctrl + V Paste from clipboard.

Shift + Ins Paste from clipboard.

Ctrl + Y Redo action.

Ctrl + Shift + Z Redo action.

Ctrl + Z Undo action.

Backspace Remove character behind cursor.

Shift + Backspace Remove character behind cursor.

Ctrl + Backspace Remove word behind cursor.

Del Delete character in front of cursor.

Ctrl + Shift + L Delete row.

Ctrl + Del Delete to end of next word.

Data Insert line break.

Shift + Return. Insert soft line break.

Ctrl + Return Insert row above.

Ctrl + Shift + Return Insert row below.

Ctrl + Space Auto-complete.

Table 23: Shortcut for editing scripts
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Shortcut Description

Ctrl + Space + Space Show list with parameter information.

Tab Insert indent/tab.

Shift + Tab Remove indent/tab.

Ctrl + U Change marked characters to lowercase.

Ctrl + Shift + U Change marked characters to uppercase.

Ins Toggle insert mode.

Ctrl + T Swap characters in front and behind cursor.

Ctrl + Shift + T Swap words in front and behind cursor.

Shift + Alt + T Swap row with previous row.

Alt + PgUp Move row up.

Alt + PgDn Move row down.

PgUp Move up

PgDn Move down.

Left arrow Move left.

Right arrow Move right.

Ctrl + Left arrow Move to previous word.

Ctrl + Right arrow Move to next word.

Home Move to start of line.

End Move to end of line.

Ctrl + Home Move to start of script.

Ctrl + End Move to end of script.

PgDn Move up a page.

PgUp Move down a page.

Ctrl + PgUp Move to visible start.

Ctrl + PgDn Move to visible end.

Ctrl + ] Move to next bracket. (not possible on German keyboard)

Ctrl + Down arrow Scroll down.

Ctrl + Up arrow Scroll up

Ctrl + F Open search dialog.
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Shortcut Description

F3 Search next.

Ctrl + F3 Search forward.

Shift + F3 Search backward.

Ctrl + Shift + F3 Find previous.

Ctrl + H Replace.

Ctrl + I Search forward incrementally.

Ctrl + Shift + I Search backward incrementally.

Ctrl + Shift + Num- Reduce code block selection.

Ctrl + Shift + Num+ Extend code block selection.

Esc Remove selection.

Shift + Down arrow Extend selection down.

Shift + Up arrow Extend selection up.

Shift + Left arrow Extend selection left.

Shift + Right arrow Extend selection right.

Ctrl + Shift + Left arrow Extend selection to previous word.

Ctrl + Shift + Right arrow Extend selection to next word.

Shift + Home Extend selection to start of line.

Shift + End Extend selection to end of line.

Shift + Alt + Home Extend selection to start of script.

Ctrl + Shift + End Extend selection to end of script.

Shift + PgUp Extend selection by one page up.

Shift + PgDn Extend selection by one page down.

Ctrl + Shift + PgUp Extend selection to visible start.

Ctrl + Shift + PgDn Extend selection to visible end.

Ctrl + A Select all.

Ctrl + Shift + W Select word.

Ctrl + Shift + ] Select up to the next bracket. (not possible on German
keyboard)

Shift + Alt + Down arrow Extend selected block down.
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Shortcut Description

Shift + Alt + Up arrow Extend selected block up.

Shift + Alt + Left arrow Extend selected block left.

Shift + Alt + Right arrow Extend selected block right.

Ctrl + Shift + Alt + Left
arrow

Extend selected block by one word to the left.

Ctrl + Shift + Alt + Right
arrow

Extend selected block by one word to the right.

Ctrl + mouse wheel Adjust text size.

There is additional help provided for creating script code.

Syntax highlighting

The input fields support syntax highlighting depending on the syntax type.

Auto-completion

You can use auto-completion when you write script code. You can enable automatic
completion in the input fields with the button in advanced edit mode. This suggests a
word to automatically complete the keyword as it is entered. If a keyword is expected at a
certain position in the source code, auto-completion comes up automatically after a few
letters. Although, after specific characters, such as period (.) or parenthesis ((), automatic
completion is always offered. Alternatively, you can use the Ctrl + space shortcut in the
relevant positions within the input fields to call up autocomplete.

The amount of scripted code to enter is reduced by displaying the names of properties
or functions that can be used. The contents of the list is determined by the key words
in the code.

Entering code snippets

One Identity Manager provides code snippets for you to use as templates. You can insert
code snippets using the following options:

1. Using the icon

a. Select the icon.

b. Select the code snippet.

2. Using a shortcut

a. Press F2.

b. Select the code snippet.

3. Using an aliases
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a. Enter an alias.

b. Use Tab to insert the code snippet.

NOTE: Be aware of case sensitivity when you enter the alias.

NOTE: If you select a code snippet directly using a shortcut or the icon, a short
description and the shortcut name are displayed in a tooltip.

Inputting values using dollar ($) notation

In input fields where a VB.NET term is expected, a help list opens when you enter $. All
properties of the current object are displayed. You can also see a tooltip with a detailed
description of the property. When you select a foreign key (FK) column, you can navigate to
the columns in the relevant table using the arrow keys. To end the selection in the target
column, press Enter or double-click. The complete $ notation for your selection should now
be shown in the input column. To close the help list without copying any data, press Esc or
leave the input field.

Figure 15: Help list for dollar notation

Icon Meaning

Property of current object.

Primary key (PK).

Foreign key (FK).

Dynamic foreign key

Table

Special properties

Script

Table 24: Meaning of icons used in the help list for dollar notation.
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Shortcut Action

Arrow down key Opens the help list.

Arrow up key, arrow down
key

Navigate to previous or next entry.

Arrow left key, arrow right
key

Navigate to the object above or below over the foreign
key.

Data Accepts the value in dollar notation.

Table 25: Help list functions for dollar notation

Entering database queries

It is sometimes necessary to enter database queries. You can enter the database queries as
a SQL query directly or compile the database queries with a wizard. Use the , or
buttons to switch to the appropriate view.

Icon Meaning

Enter a database query as a SQL query.

WHERE clause wizard.

Filter designer.

Table 26: Meaning of the icons

Wizard for entering database queries

The wizard helps you to formulate a condition (where clause) for database queries. The
complete database query is composed internally. It always refers to the database table,
which is preset when the Where clause wizard starts.
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Figure 16: WHERE clause wizard.

There are predefined operators to make it easier to create conditions. The operators are
underlined. Operators with a help entry for the permitted value (such as column selection,
data input or free text) are shown in parentheses (<<Operator>>).

To create a database query using the WHERE clause wizard

1. Start the WHERE clause wizard with the button.

2. Create the database query.
l When you hover over an operator, the cursor changes to a hand symbol.
l If an operator has only two permitted values you can click to switch between
the values.

l Click an operator with more than two permissible values to open a drop-down
listing the permissible operator values.

Click to select the required entry and then use the button to confirm the
selection.

- OR -

Double-click an entry to select the value.
l A selection window opens in which you can select all database columns of the
base object and its related objects. Use SQL name to switch between the
display name and the technical name of tables and columns.

l For complex database queries, you have the option of linking several conditions
together. After each condition there is a row showing the logical operator for
the connection, followed by another row for the next condition. Use the button
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in front of a condition to delete it from the query.
l Use the Expert view button to switch to direct entry of the query in SQL
syntax. Use theWizard view button to switch back to the simple input mode.

3. Click Continue.

The database query condition is shown in SQL syntax.

4. Click Finished.

Filter designer

The filter designer helps you formulate a condition for database queries. The complete
database query is composed internally. The database query always references the
Person table.

Figure 17: Filter designer

To create a database query using the filter designer

1. Start the wizard by pressing .

2. Using the all operator, specify whether at least one or all of the conditions defined
below must be fulfilled.

l When you hover over the operator, the cursor changes to a hand symbol.
l By clicking the operator, switch between the all and at least one values.

3. Create the conditions.

a. In the first drop-down, specify the condition type.

Depending on the condition type, other menus are displayed.

Condition type Meaning

Property Properties of identities. The permitted properties drop-
down is already limited to the most important identity
properties.

Table 27: Permitted condition types
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Condition type Meaning

For the account
with the target
system type

Identity’s user account. Valid user account properties
depend on which target system is selected.

You can only select columns that are shown in the
Unified Namespace and for which the Display in the
filter designer option is enabled.

For entitlements
with the target
system type

Identity target system group. Valid group properties
depend on which target system is selected.

You can only select columns that are shown in the
Unified Namespace and for which the Display in the
filter designer option is enabled.

SQL Query Free choice of SQL query (WHERE clause). To use the
WHERE clause wizard, click .

b. From the additional menus, select the object attributes for the condition.

All other controls are operators and properties that you require to formulate
the condition. You can only select one entry from the drop-down. You can
select more entries from extended drop-down menus, where the properties are
displayed hierarchically and then added to the condition using an "or" operator.
You may enter text directly into input fields. Pop-up menus and input fields are
shown and hidden dynamically.

c. To insert another condition, click . All partial conditions are linked by
an AND link.

d. To delete a condition, click .

e. To the preview window, click . All objects determined by the condition
are displayed.

Entering custom filter conditions

At certain points you can define custom filter conditions. The filter conditions are
formulated like a condition (WHERE clause) for a database query.

You can enter database queries directly or put them together with a wizard. Use the and
buttons to switch to the relevant view.

l The comparison operators =, <>, <, >, <=, >=, and like are supported for defining
conditions.

l To link condition you can use the logical operators AND, OR, and NOT.
l You can use variables in your condition definitions. Variable must be masked.

Syntax: '$<variable>$'
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NOTE: If the condition contains a dollar sign, which is not labeling a variable, it
must be masked with $.

Example: '300 $$' compared to the value '300 $'

TIP: If you enter a condition directly, you can access predefined variables with
the button.

Each condition is displayed in a special control in the wizard. The controls contain
connection points to logically join single conditions or delete single conditions. The
connection points are set if you mouse over the edge of the respective control.

Figure 18: Wizard for entering filters

To create a filter with a wizard

1. Click Create condition.

This inserts a control for the first condition.

2. Enter the condition.

a. Click the left-hand part of the condition and select the property to filter by.

The properties for filtering are listed in the drop-down. You can also define
other properties and use variables.

b. Specify the comparison operator. Click the comparison operator to change it.

The comparison operators =, <>, <, >, <=, >=, and like are supported for
defining conditions.

c. Specify the comparison value on the right-hand side of the condition.

You can enter a string for a comparison value or select a property from the list.
You can also use variables.

NOTE: To switch back to the input field again, select Input field from
the drop-down.

3. To link condition you can use the logical operators AND, OR, and NOT.

a. Mouse over the edge of the control to which you wish to create a link.

The connection points appear.
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b. Mouse over a connection point and select the connection.

This adds a new control for the next condition.

NOTE: To remove a control, select the Delete connection point.

Selecting values from lists

Use the drop-down to select an element. Use the icon next to the input field to go to the
assigned object. You can add additional values to some menus. The icon is displayed
next to the drop-down.

The extended drop-down links to elements from a different database table. To better
display your hierarchical structures, from this drop-down you can select from hierarchy
trees as well as flat structures.

Figure 19: Extended menus

To select a value form an extended drop-down

1. Open the drop-down by clicking the arrow.

2. Enable or disable an entry using a single click and close the drop-down.

- OR -

Enable or disable an entry by double-clicking.

The drop-down closes automatically.

TIP: As you enter text in the input field, the system filters the selection data for
you. When you open the drop-down you can see the entries that contain the text
you entered. If the entered text is unique, you can also select the relevant entry
using the tab.

To search in the drop-down

1. Click the magnifying glass in the drop-down title bar to open the search dialog.

2. Enter your search term.
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3. Set the option Case sensitive if required.

4. Start the search with the Search or Enter button.

5. Use F3 to continue searching.

6. End the search with Esc.

Selecting dynamic entries

Some foreign key relationships are identified dynamically in One Identity Manager. There
are two steps to selecting a dynamic foreign key.

1. Specify the table in which the object should be identified.

2. Select the actual object.

To specify a dynamic entry:

1. Open the drop-down by clicking the arrow.

2. First select the table in which to find the object.

3. Select the specific object in the next drop-down.

4. Click OK.

Selecting dates

As well as manually entering a date, you can copy a date into the input field from the
control. Open the control using the [...] button beside a date input field.

Figure 20: Control for setting a date
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The title bar of the control repeats the name of the corresponding input field.

To select a date:

1. Today's date is identified by a colored border. Click Today to select today's date.

- OR -

Select the date using the calendar.

a. Select the month and year using the arrow beside theMonth year control or
click theMonth year control.

b. Select the day by clicking in the calendar.

2. Click OK.

Editing login times

This control is used, for example, to configure the daily login hours for a user account.

Figure 21: Login time control

The calendar shows a 7-day week, each box represents one hour. The configured login
times are shown in color, respectively. If a box is filled, login is allowed. If the box is empty,
login is denied.

To specify login times

l Select a time period with the mouse or keyboard.
l Select Assign to enable login in the selected period.
l Select Remove to deny login in the selected period.
l Select Reverse to invert the selected period.
l Use the arrow keys to reset or repeat a selection.
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Layout of object relations

This control element shows the relations between the One Identity Manager database
objects (Parent/ChildRelation).

l Only the assigned elements are displayed in the Remove assignments pane.

You can remove assigned elements here.
l In the Add assignments pane, you can see all the elements.

Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.

To activate or deactivate an assignment

l Use the control's context menu.

- OR -
l Double-click an entry.

Figure 22: Displaying assignments in the control element
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Icon Meaning

Object is assigned to the selected base object.

Object is not assigned to an object.

Object is assigned to another object.

Table 28: Meaning of icons in the control element

NOTE: In the list, assigned elements come before unassigned elements.

Entry Meaning

Assign Assign object to the selected base object.

Remove Remove assignment of object to base object.

Assign child objects In a hierarchical structure, assign the selected object and its
child objects to the base object.

Remove child objects In a hierarchical structure, remove the assignments of the
selected object and its child object to the base object.

Assign all objects Assign all existing objects to the base object.

Remove all assignments Remove all assignments to the base object.

Search Opens the search dialog.

Go to object Go to the selected object.

Go to assigned object Go to this object's assigned base object.

Show objects already
assigned to other objects.

Objects that are assigned to other objects are shown in the
Add assignments pane.

Hide objects already
assigned to other objects.

Objects that are assigned to other objects are hidden in the
Add assignments pane.

Table 29: Control element context menu items

Displaying assignments

The membership tree shows the direct and indirect assignments to a base object. It also
shows the source of the indirectly assigned objects. This means that the object was
assigned to a base object through a dynamic role, for example, or through inheritance.

l Only the assigned elements are displayed in the Remove assignments pane. You
can remove the assignments here.

l Under Add assignments you can see all the elements.
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Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.

NOTE: Objects marked for deletion and outstanding objects are struck through on the
overview form.

To activate or deactivate an assignment

l Use the control's context menu.

- OR -
l Double-click an entry.

Figure 23: Displaying assignments

Icon Meaning

Object is assigned directly to the selected base object.

Object is assigned indirectly to the selected base object.

Table 30: Meaning of icons in the membership tree
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Icon Meaning

Object is assigned directly and indirectly to the selected base object.

Object is not assigned to a base object.

Inheritance interruption. Only when objects are assigned in hierarchical struc-
tures.

Indirect assignment.

Assignment through dynamic roles.

Assignment not yet effective. The DBQueue Processor has not yet calculated the
assignment.

The change in value is planned for a specific date and time.

NOTE: The list displays assigned elements before unassigned elements.

Entry Meaning

Assign Directly assign the selected object to the base object.

Remove Remove the assignment of the selected object to the base object.

Assign child
objects

In a hierarchical structure, assign the selected object and its child objects
to the base object.

Remove child
objects

In a hierarchical structure, remove the assignments of the selected
object and its child object to the base object.

Assign all
objects

Directly assign all existing objects to the base object.

Remove all
assignments

Remove all direct assignments to the base object.

Search Opens the search dialog.

Go to object Go to the selected object.

Extended
properties

Switches to the detailed form for the selected object, where you can
make additional assignments. A prerequisite for this is that the selected
object is assigned and this assignment has been saved.

Table 31: Entries in the membership tree context menu

NOTE: Use the Search function to search the entire assignment tree for the
occurrence of specific texts. The search sequence does not follow the displayed
hierarchical structure of the tree, but instead the internal structures of the control
element. As such, the search seems to jump through the tree at random. All records
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are searched to find the requested object.

General shortcuts for controls

Shortcut Action

Tab, shift + tab, left arrow key, right arrow key, down
arrow, up arrow

Move within the controls.

Down arrow, up arrow, page down key, page up key,
home, end

Move in lists and in hierarchical
structures.

<+> or right arrow key Open hierarchy level.

<-> or left arrow key Close hierarchy level.

Space or Enter Select an entry.

Shift + Return. Select multiple entries.

F4 or Alt + down arrow Open selection list.

Del Remove entry from the list.

Table 32: General shortcuts for controls

Reloading changes to the user interface

In the status bar, the icon indicates that the user interface was modified.

To reload modifications to the system data

1. In the status bar, double-click the icon .

2. Enable the Restore user interface option. After loading the modifications, the
system then navigates back to the point in the interface that you were
previously using.

3. Click Yes.
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Detailed information about the user
interface

You will usually need to display more information about individual interface elements, such
as menu entries or forms, only if the program's user interface is edited.

To display detailed information

1. Select the Database > Settingsmenu item.

2. On the User tab, enable the Show additional navigation information option.

NOTE: The option is not saved permanently. It has to be reset when the program
is started.

The following information appears:

l The Manager shows the form name in the status bar. It displays in the
following format:

<logical form> [(<physical form>)]

TIP: Double-click the form identifier in the status bar to copy it into the
clipboard.

l In the Manager, the Show system data entry is displayed in the menu bar in the
Viewmenu. This opens a form that lists detailed information about the loaded menu
items, forms, and form definitions.

l In the Manager, in expert mode, the Definition context menu entry is also displayed
in the navigation view. This shows advanced technical information about configuring
a menu item.

l If menu entries or tasks are linked to preprocessor-relevant configuration
parameters, the preprocessor conditions are shown behind the menu items and
tasks.

Related topics

l Expert mode in the Manager on page 20
l Manager program settings on page 21
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Limiting items in a list using query
limits

Use a query limit to limit the number of elements displayed in a result list and in the control
elements with list values (for example, menus). If the number of results exceeds the limit,
a filter dialog opens.

In the Designer, you can globally define the maximum number of entries displayed before
the filter dialog is opened in the Common | DBConnection | ListLimit configuration
parameter. In addition, the current user can use the system setting or enter their own limit.
The personal limit overwrites the global value in the configuration parameter.

To use the system settings

1. Select the Database > Settingsmenu item.

2. On the User tab, in the Data query limits section, set the Enable data query
limits and Use system settings options.

- OR -

On the User tab, in the Data query limits section, set the Limit result list object
count and Use system settings options.

This setting applies the global value defined in the Common | DBConnection |
ListLimit configuration parameter.

To use a personal limit

1. Select the Database > Settingsmenu item.

2. On the User tab, in the Data query limits section, set the Enable query
limits options.

- OR -

On the User tab, in the Data query limits section, set the Limit result list object
count and Use system settings options.

3. On the User tab, in the Data query limits section, clear the Use system settings
option and under Objects, specify the number of objects.

NOTE: The Enable query limits option can only be set if the user owns the
Common_AllowRiskyWhereClauses program function.

Related topics

l Limiting list sizes using simple filters on page 66
l Custom filters in the Manager on page 68
l Searching for list entries on page 67
l Database search in the Manager on page 75
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Limiting list sizes using simple filters

You can use the filter dialog to limit the entries in a list though defined filter criteria. A filter
remains in use until you reset it. Settings in the filter dialog are saved in the user
configuration.

If you want to start certain search queries more frequently, create search queries for the
advanced database search or create user-defined filters.

To limit a result set

1. In Filter condition, enter the text to use as a basis for filtering. Use of * as wild
cards is permitted. Case sensitivity is not taken into account.

2. In Apply to, enable the properties to which the filter condition is to be applied.

3. If you only want lists to show objects that meet the filter condition and are already
assigned to the base object, enable the Only show current assignment option.

NOTE: This option is only available for lists with object assignments.

4. Click Apply.

NOTE: To display all objects, click Show all. The filter condition is not applied
in this case.

Example: Filter conditions

This filter condition is used to search for all parts of an identity’s full name. This is put
together in the following manner:

Full name

Last name, first name

Example:

Miller, Alex

Miller-Meyer, Dani

Meyer-Miller, Chris

Filter
condition

Description Find, according to
example

Miller or Finds all identities whose full name contains Miller, Alex
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Filter
condition

Description Find, according to
example

*Miller* the string Miller. Miller-Meyer, Dani

Meyer-Miller, Chris

Miller* Finds all identities whose full name begins
with the string Miller.

Miller, Alex

Miller-Meyer, Dani

*Miller Finds all identities whose full name ends with
the string Miller.

No entry

Related topics

l Limiting items in a list using query limits on page 65
l Searching for list entries on page 67
l Custom filters in the Manager on page 68
l Database search in the Manager on page 75

Searching for list entries

Use the search dialog to search for entries within a list.

To search in a list

1. Open the search dialog from the Search context menu, by clicking the icon or with
the shortcut Ctrl + F.

2. Enter the Search term or select a previous one from the list using the arrow button.

3. Set the Case sensitive option if required.

4. Start the search with the Search or Enter button.

5. Use F3 to continue searching.

6. End the search with Esc.

Shortcut Action

Ctrl + F Open search dialog.

Data Start search.

Table 33: Shortcuts for the search dialog
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Shortcut Action

Esc End search.

F3 Search next.

For a wider ranging search, use the database search function.

Related topics

l Database search in the Manager on page 75

Custom filters in the Manager

You make use of custom filters if you wish to run specific search queries frequently. You can
create your own (private) filters or public filters.

Custom filters allow you to run the following searches:

l Searching for a search term with placeholders within the display values of the
selected object definition

l Searching entries with a SQL condition
l Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Creating filter queries using wildcards in
the Manager

NOTE: To create filter queries using wildcards, users require the Common_
AllowRiskyWhereClauses program function.

A search query using placeholders searches for the search pattern in the display values of
the selected object definition.

To create a filter query using placeholders in the Manager

1. In the Manager, select theMy One Identity Manager > Filters category.

2. Select the New filter context menu item.

3. In the Define a filter dialog, select theWildcard filter method.

4. In the Filter parameter pane, enter the following information.
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l Filter objects of: Select the object definition in which to perform the search.
l Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.

Example: Using wildcards in the search pattern

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

5. (Optional) If required, specify the following settings in the Optional
parameter pane.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.

7. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

8. To save the filter, click Save.

Related topics

l Applying filters in the Manager on page 72
l Publishing filters in the Manager on page 72
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Creating filter queries in the Manager using
SQL conditions

A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.

To create a filter query using a SQL condition in the Manager

1. In the Manager, select theMy One Identity Manager > Filters category.

2. Select the New filter context menu item.

3. In the Define a filter dialog, select the SQL filter method.

4. In the Filter parameter pane, enter the following information.
l Filter objects of: Select the object definition in which to perform the search.
l Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
directly or compile the database queries with a wizard. Use the Expert view or
Simple view button to switch to the appropriate view.

5. (Optional) If required, specify the following settings in the Optional
parameter section.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.

7. To save the filter, click Save.

8. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

Related topics

l Applying filters in the Manager on page 72
l Publishing filters in the Manager on page 72
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Creating filter queries using full-text search
in the Manager

NOTE: To use the full-text search, you must run the program over an application
server with an installed search service. For more information, see Installing or
uninstalling a search service for full-text search.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For more information,
see The full-text search in One Identity Manager.

To create a filter query in the Manager using the full-text search

1. In the Manager, select theMy One Identity Manager > Filters category.

2. Select the New filter context menu item.

3. In the Define a filter dialog, select the Full text filter method.

4. In the Filter parameter pane, enter the following information.
l Filter objects of: Select the object definition in which to perform the search.
l Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 79.

5. (Optional) If required, specify the following settings in the Optional
parameter section.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.

7. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

8. To save the filter, click Save.

Related topics

l Applying filters in the Manager on page 72
l Publishing filters in the Manager on page 72
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Applying filters in the Manager

To use a filter in the Manager

l In the Manager, select the filter in the My One Identity Manager > Filters
category.

Related topics

l Creating filter queries using wildcards in the Manager on page 68
l Creating filter queries in the Manager using SQL conditions on page 70
l Creating filter queries using full-text search in the Manager on page 71

Publishing filters in the Manager

NOTE: To create, edit, and delete public filters, users require the Common_
PublicFilterDefine program function.

You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.

To publish a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager > Filters
category.

2. Select the Edit filter context menu item.

3. Click Publish.

4. Confirm the security prompt with Yes.

5. Click Save.

Related topics

l Creating filter queries using wildcards in the Manager on page 68
l Creating filter queries in the Manager using SQL conditions on page 70
l Creating filter queries using full-text search in the Manager on page 71
l Exporting and importing filters in the Manager on page 73
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Exporting and importing filters in the
Manager

To make custom filters available to other users, you can export and import them.

To export a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager > Filters
category.

2. Start the export using the Export filter context menu.

3. Using the file browser, select the directory path for the report and enter a file name
for the filter.

4. Click Save.

The filter file (*.xml) is generated.

To import a filter in the Manager

1. In the Manager, select theMy One Identity Manager > Filters category.

2. Start the export using the Import filter context menu.

3. Select the filter file from the file browser.

4. Click Open.

Related topics

l Attaching filters in the Manager on page 73
l Publishing filters in the Manager on page 72

Attaching filters in the Manager

You can attach filters to various categories so you can quickly access the filtered objects.

To attach a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager > Filters
category.

2. Select the Attach context menu.

3. Select one or multiple menu categories to attach the filter to.

When you select a category with an attached filter in the navigation view, all objects that
correspond to the filter are displayed on a separate form page. The following functions
are available:
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l Double-click an entry on this form page to switch to the corresponding object. The
first available form is opened.

l Open the export form using the Export data task or click Export data on the
context menu. The filter condition of the attached filter is already applied as an
export condition.

For more information, see Exporting data with the Manager.

Editing filters in the Manager

NOTE: To create, edit, and delete public filters, users require the Common_
PublicFilterDefine program function.

To edit a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager > Filters
category.

2. Select the Edit filter context menu item.

3. Edit the filter settings in the Define a filter dialog.

4. Click Save.

Related topics

l Creating filter queries using wildcards in the Manager on page 68
l Creating filter queries in the Manager using SQL conditions on page 70
l Creating filter queries using full-text search in the Manager on page 71

Deleting filters in the Manager

NOTE: To create, edit, and delete public filters, users require the Common_
PublicFilterDefine program function.

To delete a filter in the Manager

1. In the Manager, select the filter in the My One Identity Manager > Filters
category.

2. Select the Remove filter context menu item.
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Database search in the Manager

In the Manager, you can run a simple database search or an advanced database search.
Run a simple database search once. You cannot save a simple database search. Use an
advanced database search if you wish to run specific search queries frequently. You can
save the search query.

Simple database search

The simple database search allows you to run the following searches:

l Searching for a search term with placeholders within the display values of the
selected object definition

l Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Running simple database searches using
wildcards

A search query using placeholders searches for the search pattern in the display values of
the selected object definition.

To run a simple database search in the Manager with placeholders

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. Enter the following information in the Search section.

a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.

b. Search text: Enter the search term. You can use * as a wildcard. Case
sensitivity is not taken into account.

Examples:

Pattern or pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

c. Full-text search: Disable the option.
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3. (Optional) Click the Search drop-down arrow to access the Default search
operator drop-down and select a search operator to use by default in the simple
search. Permitted values are starts with, contains or equals.

4. Start the search using the Search button.

TIP: Press to set the current query as the default for future search queries.

Running simple database searches using full-
text search

NOTE: To use the full-text search, you must run the program over an application
server with an installed search service. For more information, see Installing or
uninstalling a search service for full-text search.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For more information,
see The full-text search in One Identity Manager.

To run a simple database search in the Manager as a full-text search

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. Enter the following information in the Search section.

a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.

b. Search text: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 79.

c. Full-text search: enable the option.

3. (Optional) Click the Search drop-down arrow to access the Default search
operator drop-down and select a search operator to use by default in the simple
search. Permitted values are starts with, contains or equals.

4. Start the search using the Search button.

TIP: Press to set the current query as the default for future search queries.

Advanced database search

The advanced database search allows you to run the following searches:
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l Searching for a search term with placeholders within the display values of the
selected object definition

l Searching entries with a SQL condition
l Searching for a search term across all columns of an object definition that are
indexed for the full-text search

TIP: The saved search queries are displayed in the Manager in theMy
One Identity Manager > Filters category. You can run or edit the search queries
there or export them for other users.

Creating search queries using wildcards

NOTE: To create search queries using wildcards, users require the Common_
AllowRiskyWhereClauses program function.

A search query using wildcards searches for the search pattern in the display values of the
selected object definition.

To create a filter query using wildcards in the Manager

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search section.

3. Click New search and select theWildcard search method.

4. In the Search parameter pane, enter the following information.
l Search in: Select the object definition in which to perform the search.
l Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.

Examples:

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string
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5. (Optional) If required, specify the following settings in the Optional
parameter pane.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search pane and click Save.

Creating search queries using SQL conditions

A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.

To create a filter query using an SQL condition in the Manager

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search section.

3. Click New search and select the SQL search method.

4. In the Search parameter pane, enter the following information.
l Search in: Select the object definition in which to perform the search.
l Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
directly or compile the database queries with a wizard. Use the Expert view or
Simple view button to switch to the appropriate view.

5. (Optional) If required, specify the following settings in the Optional
parameter section.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search section and click Save.
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Creating search queries using full-text search

NOTE: To use the full-text search, you must run the program over an application
server with an installed search service. For more information, see Installing or
uninstalling a search service for full-text search.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For more information,
see The full-text search in One Identity Manager.

To create a search query in the Manager using the full-text search

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search area.

3. Click New search and select the Full text search method.

4. In the Search parameter pane, enter the following information.
l Search in: Select the object definition in which to perform the search.
l Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 79.

5. (Optional) If required, specify the following settings in the Optional
parameter area.

l Sort criteria: Specify the properties (columns) by which to sort the search
result. Click to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.

l Display template: Specify the format in which the results are displayed. Click
to show all available properties according to the object definition. Click on a

name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search area and click Save.

Rules and examples for the full-text search

The following table lists rules and examples for full-text search.

Example Description

Alex Miller Finds Alex Miller, but not Alex Meyer.

Search results must contain all of the separate terms in the query. A logical
AND is used.

Table 34: Rules with examples for searching
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Example Description

Alex OR
Miller

Find Alex Miller and Alex Meyer.

Placing OR between the search terms, acts as a logical OR operator. The
result of this search contain at least one of the two search terms.

Alex NOT
Miller

Find Alex Meyer, but not Alex Miller.

The results of this search do not contain the term that comes after NOT.

Ale* Finds Alex and Alexis.

The * functions as a wildcard for any number of characters to complete the
term.

Ale? Finds Alex, but not Alexis.

The ? functions as a wildcard for a single character to complete the term.

"Alex
Miller"

Finds results in which the search terms Alex and Miller follow one another.

Results of this search contain the string in quotes as phrase.

Alex
Miller~

Finds Alex Miller among others, but also similar results are shown. A tilde ~
after the search term indicates that the search should also find similar
results. This means that incorrectly spelled terms can be found, as well.

You can specify the level of similarity by adding a number between 0 and 1
(with decimal point) after the tilde ~. The higher the number, the more
similar the results.

Running advanced database searches

To run an advanced database search in the Manager

1. In the Manager, select the View > Database searchmenu item.

The database search is displayed in the navigation view.

2. To open the advanced database search, click the Advanced button in the
Search section.

3. Double-click the search filter in the Saved filters area.

4. Start the search using the Search button.

TIP: The saved search queries are shown in theMy One Identity Manager > Filters
category. You can run or edit the search queries there or export them for other users.

Related topics

l Custom filters in the Manager on page 68
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Displaying extended properties for
objects in the Manager

NOTE: The Manager must be running in expert mode to show object properties.

To show extended object properties

l Select the object and open the Properties item in the context menu.
l On General, you can see the object‘s general properties, for example, ID,
status, or primary key.

TIP: The primary key can be copied in different formats. To do this, click
the Primary key or the Table relations caption.

l All the object columns are displayed in a grid on Properties with their values.
You can choose between a simple column view and the advanced view with
additional data for column definitions.

Individual properties can be highlighted with an icon.

To customize the display properties
l On the Properties tab, select the Property pages icon and set the
required display properties.

l On the Permissions tab, based on the permissions groups, you see what
permissions apply to an object. The first entry shows the basic permissions for
the table. The permissions for this particular object are displayed beneath that.
The other entries show the column permissions.

TIP: Double-click the table entry, the object entry, or a column
entry to display the permissions group from which the permissions
were determined.

Icon Meaning

Permissions exist.

Permissions have been removed by the object layer

Permissions limited by conditions.

Table 35: Icon used for permissions

l You can display which change labels the object belongs to on the Change
labels tag. Here you can assign a new or an existing change label to the object

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Manager

81



and its dependent objects. For more information, see Assigning objects and
dependencies to change labels.

l On the Export tab you can export the object in One Identity Manager's own
transfer format or generate SQL statements.

To use the export method, users require the Transport_Export program
function. To generate the SQL statements, users require the Common_
SqlExport program function.

Related topics

l Expert mode in the Manager on page 20

Multiple object edit in the Manager

It is possible to edit more than one object of the same object type at the same time in the
Manager. The form tab of the main data form shows the number of selected objects and the
object type. Input fields with different values are labeled with the icon. When you edit an
input field and save your changes, the change applies to all open objects.

To edit multiple objects at the same time:

1. Use Shift + selection or Ctrl + selection to select the objects in the result list.

2. Open the main data form either with Enter, clicking the icon in the result list, or
selecting Tasks > Edit main data in the context menu.

Committing data on change conflicts

If two users change the same object at the same time, this can cause conflicts when the
object is saved, especially if the same property is changed. In this case, a dialog appears
when you save the object. You can use this dialog to view and apply the changes.

All changes to the object that caused a conflict are shown.

Figure 24: Display of change conflicts
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To apply your changes:

l Active the check box in the Apply column for your values that you wish to save.

Column Description

Property Property of the object that triggered a change conflict.

Your change Value of the property you entered and wish to save.

Change made by
other user

Value of the property that had already been saved by the other user.

Apply? Specify if your value should be applied.

To apply your value, select the check box. Otherwise the system
keeps the value saved by the other user.

Result Current property value.

If you activate the check box in the Apply column, the value you
entered is displayed.

Table 36: About change conflicts
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4

Working with the Manager web
application

Manager functionality can be provided as a Manager web application via the API Server.

The Manager web application user interface differs slightly from the Manager user
interface. You can find detailed information about the basic features under Working with
the Manager on page 9.

For optimal displaying of the graphical user interface, use a device with a minimum screen
resolution of 1280 x 1024 pixels and at least 16-bit color depth. For mobile viewing, for
example when using a tablet, use a device with a display size of at least 9.7 inches.

Header in the Manager web application

There are several buttons available to you in the Manager web application header that
make it easier and simpler to access functions and settings. The following table explains,
which icons to select to reach the relevant functions and settings.

Icon Meaning

(system
status)

Displays the system status information.

(profile) Currently logged in user. Use the Log outmenu item to log out of the
web application.

(connection) Displays the connection information.

(switch applic-
ation)

Click the button to view other applications available to you and switch
to one of them.

Table 37: Functions in the header

Related topics

l Switching applications in the Manager web application on page 86
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Help in the Manager web application

By default, the Online documentation is used in the help system. The help system can also
be installed locally.

Use the icon to go to the help for each individual form.

Information about the logged in user in
the Manager web application

The web application header shows the name of the current user. Depending on the
authentication module used, this can be the full name of the identity or the designation of
the current system user.

To get more information about the current user

l In the header, click on the (connection) icon.
l Use the Copy connection information button to copy the information to the
clipboard.

Property Meaning

User UID Unique ID for the current user’s identity if an identity-based authen-
tication module is used to log in.

Read-only Specifies whether the system user used only has read-only permis-
sions. Possible values:

l Yes: The user only has read permissions. Modification to data are
not possible.

l No: The user has write permissions. Changes to data are
possible.

language Language for the user interface.

Language for
value format-
ting

Language for formatting data, such as data formats, time formats or
number formats.

Staging level Specifies whether this is a development system, a test environment, or
a production system.

System user
UID

Unique identifier of the system user used.

Table 38: Information about the logged in user
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Property Meaning

Authentication
used

Name of the authentication module used for logging in.

Time zone Time zone of the logged in user.

Permissions
groups

Permissions groups that are assigned to the system user. The permis-
sions groups determine the user's user interface and object permis-
sions.

Program
functions

Program functions assigned to the system user The menu items and
functions available depend on the program functions.

Switching applications in the Manager
web application

Display all the applications available to you on every login page and in each web
application. Switch to any one of them as required.

To switch to another application

1. Perform one of the following actions:
l On the login page, click (Switch application).
l If you are already logged in, click (Switch application) in the header.

This opens Switch Application side panel and displays the available applications.

2. Click an application to switch to it.

Views in the Manager web application

The editing area in the Manager web application has different views for displaying and
editing data.

View Description

Navigation The navigation shows suggested navigation starting points for the current
user.

Result list When you select a menu item in the navigation view, one result list shows
all the objects that correspond to the object definition and the conditions of
the menu item. You can insert, edit or delete objects in the result list.

Table 39: Views in the editing area
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View Description

Document
view

The document view shows the forms to edit a selected object.

Tasks The task list shows the tasks and reports available for an object.

Reports The report list shows the tasks and reports available for an object.

Favorites This view is used to compile individual items into a user-specific favorites
list. Save entries that you use frequently in your favorites.

TimeTrace In this view you can track changes to an object that were made up to any
point in the past.

For more information about TimeTrace, see Analyzing data and data
changes.

Navigation in the Manager web application

The structure of the user interface navigation is hierarchical. The top level of the hierarchy
is used to classify the data managed by One Identity Manager into specified categories.
Categories include a range of different menu items.

The navigation view in the Manager web application has its own menu bar.

Icon or menu item Meaning

Closes all expanded menu items.

Searches for menu items within the navigation.

Hides the navigation view.

Shows the navigation view.

... > Add to favorites Adds the selected item to your favorites.

... > Show deferred
operations

Shows the deferred operations for the objects in this
category.

For more information, see Scheduling operation activation
times.

Table 40: Icons and menu items in the navigation view in the Manager web
application

Related topics

l Favorites in the Manager web application on page 90
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Result list in the Manager web application

The result list shows all the objects that correspond to the object definition and the
conditions of the menu item selected in the navigation view. You can insert, edit or delete
objects in the result list.

A result list tab shows the title of the list and the number of elements in it. The entries in a
result list can be sorted by columns. You can search for entries.

The Manager web application has the following functions available in the result list.

Configuring result list columns

Specify which columns are displayed in a result list and alter the order of the columns.

l In the Manager web application, select theMore > Select columns to display
menu in the result list.

Object display in the result list

The objects used are displayed below the Recently used item in the result list.

Use the Show selected only toggle to switch between displaying all entries or only
selected entries in the result list.

Result list menu bar in the Manager web application

The following menu items are available in the Manager web result list application.

Menu item Meaning

New Inserts a new object.

Edit Opens the main data form for the selected object.

Delete The selected object is deleted once the security prompt is
confirmed.

More > Enable quick edit
mode

This opens the main data form. Selected objects can be
edited directly.

More > Reload Reloads the result list.

More > Select columns to
show

Column configuration options for a result list.

Last used Displays the most recently used objects.

Search Searches for objects in the result list.

Table 41: Menu items in the Manager web application result list
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Adding, editing, or deleting objects in the
Manager web application

Add, edit, or delete objects via the result list.

To add an object to the Manager web application

1. In the Manager web application, select the category in which you want to add
an object.

2. Click (Create) in the result list.

This opens the main data form.

3. On the main data form, edit the main data of the object.

4. Save the changes.

To edit an object in the Manager web application

1. In the Manager web application, select a category.

2. In the result list, select the object.

3. Click (Edit) in the result list.

4. Select the Change main data task.

This opens the main data form.

5. Edit the main data of the object.

6. Save the changes.

To delete an object in the Manager web application

1. In the Manager web application, select a category.

2. In the result list, select the object.

3. Click (Delete) in the result list.

4. Confirm the security prompt with Yes.

Editing multiple objects at the same time

You can edit several objects at the same time. For example, to set the same value
of certain properties for several objects. Properties with different values are marked
with the icon.

To edit multiple objects in the Manager web application at the same time

1. In the Manager web application, in the result list, select multiple objects.

2. Click (Edit) in the result list.

This opens the main data form.
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3. Change the values as required.

4. Save the changes.

Favorites in the Manager web application

In the Manager web application favorites list, you can save objects from the results list,
individual menu items or categories that you use frequently.

The Manager web application also displays info system statistics in the Favorites section.
These items cannot be removed from the favorites. For more information about the info
system, see The Info system in the Manager.

To add an object from a results list to the favorites

1. In the Manager web application, select the object in a result list.

2. Click (Edit) in the result list.

This opens the main data form.

3. Select theMore > Add to favoritesmenu item.

To add a category or menu item to your favorites

1. In the Manager web application, select an entry in the navigation.

2. Select the ... > Add to favoritesmenu item.

To remove an entry from the favorites

1. In the Manager web application, select the entry in the Favorites section.

2. Click (Remove from favorites).

Displaying extended properties for
objects in the Manager web application

Use this task to display additional information about an object.

To show extended object properties

1. In the Manager web application, select a category.

2. In the result list, select the object.

3. Click (Edit) in the result list.

4. SelectMore > Properties.

This displays an overview of the object properties.
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l On the General tab, you see the general properties of the object, such as the
name, change information or the object key.

l On the Permissions tab, based on the permissions groups, you see what
permissions apply to an object. The first entry shows the basic permissions for
the table. The permissions for this particular object are displayed beneath that.
The other entries show the column permissions.

5. Close the dialog by clicking OK.
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5

Working with the Designer

The Designer is the main configuration component in One Identity Manager. The program
offers an overview of the entire One Identity Manager data model. It enables the
configuration of global system settings, for example, languages, or configuration
parameters such as customizing user interfaces for the various administration tools. It also
allows the permissions structure to consolidate the various administrative tasks of each
user and user groups. Another important task is the definition of workflows for technically
illustrating the administration procedures in the company.

The interfaces of the Manager and Designer have a similar layout. You can find detailed
information about the basic features under Working with the Manager on page 9.

The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the Designer, the available
editors are displayed together with the tasks that can be run in the task view.

General tips for the Designer

During the startup process the Designer fills an internal database. SQLite is used for the
database system. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.

Depending on the program’s configuration, the internal database is either loaded into main
memory or copied to the hard drive of the workstation. To avoid data inconsistencies, only
one instance of the program should be started per database. If the database from the first
instance is copied to hard disk then the databases for all other instances are loaded into
main memory.

All changes to objects in the program are made in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are recorded in a change log. If the internal database is stored on the
hard drive, all additional changes are also logged to this database. This means that you can
restore to the last working state after connecting to the database if the program crashes.

When the data is transferred all recorded changes are made to the One Identity Manager
database. This is done at object level so that, for example, processes are generated and
formatting rules are observed. The principle "last writer wins" applies here as opposed to
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the previous object processing. That means that changes have been made by a user to
object properties in the mean time are overwritten.

Depending on the program settings, the internal database is deleted from the hard drive
when the program has finished. This means that all the data has to be loaded from the
One Identity Manager database when the program is restarted. If the internal database is
not deleted when the program finishes, the next program start up can be accelerated
because only changes from the One Identity Manager that is connected have to be loaded.

Menu items in the Designer

Menu Menu item Meaning Shortcut

Database New connection Establishes a database connection. Ctrl + Shift
+ N

Commit to
database

Displays the change log. Changes to the
data can be saved to the
One Identity Manager database.

Ctrl + Shift
+ S

Reload data Data is reloaded from the
One Identity Manager database.

Compile
database

Starts the Database Compiler.

For more information, see Compiling a
One Identity Manager database.

Ctrl +
Shift+ B

Change
management

Opens a dialog for editing change labels.

For more information, see Working with
change labels.

Check data
consistency

Opens the Consistency Editor.

For more information, see Checking data
consistency.

Start SQL editor Starts the SQL editor.

Change
password

Changes current user’s password.

Settings For configuring program settings.

Exit Exits the program. Alt + F4

Table 42: Meaning of items in the menu bar
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Menu Menu item Meaning Shortcut

View Navigation Activates the navigation view. Ctrl + Q

Tasks Shows or hides the task view. Ctrl + T

Error log Shows or hides the error log. Ctrl + E

Object import Shows or hides the view for importing
objects.

Ctrl + I

Search Shows or hides the search dialog. Ctrl + Shift
+F

Close current
document

Closes the current document.

Close all
documents

Closes all documents that are open in the
document view.

Activate
document

Shows all open documents in a selection list.

Layout Restores the default layout of the program’s
graphical interface. You can save layouts
and load them again.

Enable quick
edit mode

The quick edit mode is enabled or disabled.

Help Community Opens the One Identity Manager community
website.

Support portal Opens the One Identity Manager product
support website.

Training Opens the One Identity Manager training
portal website.

Online
documentation

Opens the One Identity Manager
documentation website.

Search Opens the search dialog.

Help for the
Designer

Opens program help.

NOTE: Specific help information is
available for each editor.

F1

transport history Display a chronological list of migration,
imports, and exports of transport packages.

Info Shows the version information for program.
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Icon Meaning

Saves changes to the One Identity Manager database.

Shows the previous object in the order that the forms were viewed (object
history).

Shows next object in the order they have already been viewed (object history).

Database column help. Clicking on the help icon changes the cursor into the help
icon. Then when you click on a column description, tips for using the column are
displayed in the form of tooltips.

Prints the edit view. Printer settings are configured in the configuration menus.

Table 43: Functions in the standard toolbar

Using the help in the Designer

By default, the Online documentation is used in the help system. The help system can also
be installed locally.

Access the One Identity Manager documentation in the Designer via the Help > Online
documentationmenu. If local help is installed, the Help > Search in local helpmenu is
also available.

Open the general help for Designer from the Helpmenu or by selecting F1. The Helpmenu
offers specific help information for each editor.

In addition, a Designer help is available for individual properties of the currently displayed
object. Clicking on the help icon changes the cursor into the help icon. Then when you
click on a column description, tips for using the column are displayed in the form of tooltips.

Views in the Designer

The following views are displayed in the Designer: There are several editors used for
editing data. Their functionality and methods are tailored to the different
configuration tasks.

View Description

Navigation
view

The navigation structure of the user interface is hierarchical and allows
users to drill down to the selection of an object definition. The top level of
the hierarchy is used to classify One Identity Manager data into specified
categories.

Table 44: Designer views
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View Description

Document
view

Overview forms and selected editors are displayed in the document view.
When an object is selected in the navigation view, the corresponding
overview form is displayed.

TIP: If quick edit is enabled, you skip the overview and go straight to
the first editor available for the object.

Task view When you select an object in the navigation view, the available editors are
displayed together with the tasks that can be run. The relevant editor is
opened in the document view when the object is selected.

Change log Changes made by the user are recorded in the change log.

Error log The program’s error log displays all warnings and error messages that have
occurred since the program started up. When the Designer restarts, the
error log is reinstalled.

For more information, see Displaying error log messages.

Change
label

In this view, change labels are created and edited.

For more information, see Working with change labels.

Related topics

l The editors in the Designer on page 107
l Logging and committing objects in the Designer on page 99

Designer program settings

You can adjust the program settings to suit your requirements.

To change the program settings in the Designer

l In the Designer, select the Database > Settingsmenu item.

User settings in the Designer

On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.
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General

l Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.

l Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

l Enable quick edit mode at program start: Specifies whether quick editing
is enabled.

By default, an object‘s overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

l Show system data: Specifies whether comprehensive system information such as
system tables, script occurrences, preprocessor dependencies are shown.

l Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.

l Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.

NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

l Show "Getting Started": Specifies whether the Getting Started category is
shown or hidden.

Data query limits

l Enable query limit: Specifies whether the number of elements shown in the result
list and list items in controls is limited.

NOTE: The Enable query limits option can only be set if the user owns the
Common_AllowRiskyWhereClauses program function.

If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.

l Use system settings: Specifies whether the system settings should be used for the
list limit.

If this option is activated, then the global system settings from the Common |
DBConnection | ListLimit configuration parameter are used. If the number of
results is greater than the defined number, a filter dialog opens.

l Objects: Personal setting for the object list limit. If the number of results is greater
than the defined number, a filter dialog opens.
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Usage

l Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.

l Entries in the search history: Number of entries available in the search history.

Related topics

l Designer program settings on page 96

General program settings in the Designer

On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings

l Common language: Language for formatting data, such as data formats, time
formats or number formats.

l Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Designer database settings

l Load all system data at program startup: Set the loading behavior for
system data.

If this option is not enable, only the tables that are absolutely necessary are loaded
when the Designer starts. The rest of the table are loaded in background and the user
can already start using the program. The progress of the filling procedure is shown in
the program’s status bar.

If this option is enabled, all tables are loaded when the program starts. The user
cannot start using the program until all the tables have been loaded. The changes
take effect once the Designer has restarted.

l Load BLOB fields from database on program start: If this option is not enabled,
the contents of binary fields are only loaded when they are required.

If the option is enable, this data is already loaded at program startup. The means
that program startup takes longer.

The changes take effect once the Designer has restarted.
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l Save databases locally: If this option is enabled, the internal database is not
deleted when the program ends. This accelerates restarting the program the next
time since only the changes connected with the One Identity Manager database need
to be reloaded.

If the option is not enabled the internal database is deleted from the hard disk when
the program ends. This means that all the data has to be loaded from the
One Identity Manager database when the program is restarted.

l Use RAM to store the system data (no crash recovery): If this option is not
enabled, the internal database is saved on the workstation hard disk.

If the option is enabled, the internal database is loaded into the workstation’s RAM.
In this case the database cannot be restore if the program crashes.

The changes take effect once the Designer has restarted.
l Database directory: If the Save database locally option is enabled, the internal
database is stored in the
%LocalAppData%\One Identity\One Identity Manager\Designer\Cache directory. You
save the database somewhere else by selecting another database directory.

l Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.

Related topics

l General tips for the Designer on page 92
l Designer program settings on page 96

Logging and committing objects in the
Designer

All changed objects in the Designer are created in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are also recorded in a change log.

To display change data in the Designer

l In the Designer, select the Database > Commit to databasemenu item.

The entries in the change log are grouped by editor. Actions (add, change, and delete) that
have been run and changes to the object’s properties with old and new values are displayed
in the log.
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Icon Description

Adds the object.

Deletes the object.

The object has been changed.

Table 45: Icons in the change log

The following functions are available in the change log:

l Enable and disable individual changes

You can disable individual changes in the change log. These changes are not
transferred to the One Identity Manager database when the data is saved. You can
however, re-enable changes at a later date. You can enable or disable each change
using the corresponding icon in the change log toolbar.

l Define change label

It is also possible to create a group of all the changes in the change log,
under one label.

l Before saving the recorded changes in the change log, select the required
change label in the Change label drop-down.

l To assign individual changes to different change labels, use the Special
change label context menu entry in the change log.

When the changes are transferred to the One Identity Manager database, the change
label is applied to the relevant changes.

For more information, see Working with change labels.
l Saves changes

All changes are saved to the One Identity Manager database as specified. This is done
at object level so that, for example, processes are generated and formatting rules are
observed. The principle "last writer wins" applies here as opposed to the previous
object processing. That means that changes made by a user to object properties in
the mean time are overwritten.

Icon Description

Enables change/section.

Ignores change/section.

Edit a change label.

Specifies a default change label. This change label is used for all subsequent
changes.

Table 46: Functions in the change log toolbar
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Related topics

l General tips for the Designer on page 92

Designer-internal full-text search

Use full-text search to look for entries within the internal Designer database. You will find
the full-text search on its own menu bar in the Designer.

To search for a term

l Enter your search term in the Search field.

You can enter more than one partial terms. You can use * as a wildcard. Case
sensitivity is not taken into account. Entries are searched for that contain all the
partial terms given.

The objects found are entered in a list as you enter the search term.

Figure 25: Displaying the source

l The icon to the left of the entry shows the entry’s object type (table), such as a
process, a table or a menu item.

l The source that the object is extracted from is shown to the right of the entry. The
search term is highlighted by an underline.

l Database tables, object relations and the exact source are also displayed in a tooltip.
l Double-click an entry to switch to the corresponding object.

If no entries are found for a search term, the system makes suggestions that you can use
as search terms by double-clicking.
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Figure 26: Suggestions for search terms

If you have selected an entry, the search term is added to the search history and is
therefore available for further searches.

l Open the search history with the arrow in the search field.
l When you select an entry, all available sources are shown.

The number of entries in the search history depends on your program settings.

Figure 27: Search history

TIP: Update the full-text catalog of the Designer database if you need to include
objects in the search that have been edited after the program started, like new
processes or column names. You do this with Update index, in the search history.

User-defined filters in the Designer

It is possible to limit the number of list entries in certain the Designer editors by using a
filter. After creating a filter, the filter conditions are immediately implemented on the set of
result currently displayed. A filter remains in use until you reset it.

The main components of a user filter are:

l A search in the objects' display values
l A customized search condition (where clause)
l A full text search

You have the option to set up ad-hoc filters and permanent filters. Ad hoc filters are used
for a one-off reduction of list entries. These filters are not saved and are applied to the data
immediately.

Create a permanent filter if you want to reuse certain search queries on a frequent
basis. Permanent filters are saved in the user configuration and therefore are always
available for use.
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Using Adhoc filters in the Designer

Ad hoc filters are used for a one-off reduction of list entries. These filters are not saved and
are applied to the data immediately. The WHERE clause wizard helps you formulate a
condition for database queries. The complete database query is composed internally.

To use an ad-hoc filter in the Designer

1. In the Designer, select the Filter > Define filtermenu item.

2. In the Where Clause Wizard, create the filter condition.

IMPORTANT: Enter the condition for limiting the result set in SQLite notation. The
condition is defined as a valid where clause for database queries. The condition relates
to the selected database table found that is determined when the editor starts.

Related topics

l Wizard for entering database queries on page 51

Creating filter queries using wildcards in
the Designer

NOTE: To create filter queries using wildcards, users require the Common_
AllowRiskyWhereClauses program function.

The system searches for the search term in the display values of the selected object
definition, using the wildcards.

To create a filter query using placeholders in the Designer

1. In the Designer, select the Filter > Manage filtersmenu.

2. Click New filter.

3. In the Define a filter dialog, select theWildcard filter method.

4. In the Filter parameter pane, enter the following information.
l Filter objects of: The object definition for the list is already selected.
l Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.
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Example: Using wildcards in the search pattern

Pattern* - searches for all entries whose display value starts with the
Pattern string

*Pattern - searches for all entries whose display value ends with the
Pattern string

*Pattern* - searches for all entries whose display value contains the
Pattern string

Pattern - searches for all entries whose display value matches the
Pattern string

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

7. (Optional) To apply the filter immediately, click Filter.

8. Select the Database > Commit to databasemenu item and click Save.

Related topics

l Applying filters in the Designer on page 106
l Publishing filters in the Designer on page 106

Creating filter queries in the Designer using
SQL conditions

A condition is used to filter all entries that match the specified condition according to the
selected object definition.

To create a filter query using a SQL condition in the Designer

1. In the Designer, select the Filter > Manage filtersmenu.

2. Click New filter.

3. In the Define a filter dialog, select the SQL filter method.

4. In the Filter parameter pane, enter the following information.
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l Filter objects of: The object definition for the list is already selected.
l Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as a SQL query
directly or compile the database queries with a wizard. Use the Expert view
and Simple view button to switch to the appropriate view.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.

6. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

7. (Optional) To apply the filter immediately, click Filter.

8. Select the Database > Commit to databasemenu item and click Save.

Related topics

l Applying filters in the Designer on page 106
l Publishing filters in the Designer on page 106

Creating filter queries using full-text search
in the Designer

NOTE: To use the full-text search, you must run the program over an application
server with an installed search service. For more information, see Installing or
uninstalling a search service for full-text search.

A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For more information,
see The full-text search in One Identity Manager.

To create a filter query in the Designer using the full-text search

1. In the Designer, select the Filter > Manage filtersmenu.

2. Click New filter.

3. In the Define a filter dialog, select the Full text filter method.

4. In the Filter parameter pane, enter the following information.
l Filter objects of: The object definition for the list is already selected.
l Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 79.

5. In the Save filter pane, enter a name and a description for the search filter
and click Save.
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6. (Optional) To make the filer available to all users

a. Click Publish.

b. Confirm the security prompt with Yes.

7. (Optional) To apply the filter immediately, click Filter.

8. Select the Database > Commit to databasemenu item and click Save.

Related topics

l Applying filters in the Designer on page 106
l Publishing filters in the Designer on page 106

Applying filters in the Designer

To use a saved filter in the Designer

1. In the Designer, select the Filter > Manage filtersmenu.

2. Double-click the search filter in the Saved filters pane.

3. Click Filter.

Related topics

l Creating filter queries using wildcards in the Designer on page 103
l Creating filter queries in the Designer using SQL conditions on page 104
l Creating filter queries using full-text search in the Designer on page 105

Publishing filters in the Designer

NOTE: To create, edit, and delete public filters, users require the Common_
PublicFilterDefine program function.

You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.

To publish a filter in the Designer

1. In the Designer, select the Filter > Manage filtersmenu.

2. Double-click the search filter in the Saved filters area.

3. Click Publish.

4. Confirm the security prompt with Yes.

5. Select the Database > Commit to databasemenu item and click Save.
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Related topics

l Creating filter queries using wildcards in the Designer on page 103
l Creating filter queries in the Designer using SQL conditions on page 104
l Applying filters in the Designer on page 106

The editors in the Designer

The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the navigation view, the available
editors are displayed together with the tasks that can be run.

Editor Description

Object Editor The Object Editor is provided for editing single
objects. All properties of an object are represented in
table form and can be edited depending on the
permissions. In addition, properties such as edit
permissions and column definitions are shown. For
more information, see Working with the Object Editor
on page 109.

List Editor The List Editor is used to display result lists and to
quickly edit objects and object relations. Object
properties are displayed in tabular form but there is
no additional information about each property as in
the Object Editor. For more information, see Working
with the List Editor on page 111.

SQL Editor You can use the SQL Editor to run database queries
against the internal Designer’s SQLite database. For
more information, see Working with the SQL Editor
on page 114.

User & Permissions Group Editor Use the User & Permissions Group Editor to create
and edit permissions groups and the system user.

For more information, see Granting
One Identity Manager schema permissions through
permissions groups.

User Interface Editor Use the User Interface Editor to edit the navigation of
the One Identity Manager tools.

For more information, see User interface navigation.

Table 47: Designer editors
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Editor Description

Form Editor Use the Form Editor to create and edit the interface
forms, such as the main data forms or assignment
forms.

For more information, see Editing user interface
forms.

Overview Form Editor Use the Overview Form Editor to create overview
forms.

For more information, see Working with overview
forms.

Permissions Editor Use the Permissions Editor to edit the permissions
structure of the permissions groups and system user.

For more information, see Permissions for tables and
columns.

Process Editor The Process Editor is the tool that you use to define
and change processes in One Identity Manager.

For more information, see Process orchestration in
One Identity Manager.

Job Server Editor You use the Job Server Editor to edit the Job server
attributes and the One Identity Manager Service
configuration file.

For more information, see Setting up Job servers.

Language Editor For the translation of captions, use the
Language Editor.

For more information, see Language-dependent data
representation.

Schema Editor The Schema Editor displays an overview of the entire
One Identity Manager database model.
Schema Editor is used to customize table and column
definitions to suit the customer. For example, you
can define formatting rules or formatting scripts with
the Schema Editor.

For more information, see One Identity Manager
schema basics.

Configuration Parameter Editor The Configuration Parameter Editor provides an
overview of all the configuration parameters in the
One Identity Manager and their current values.

For more information, see Configuration parameters
for system configuration.
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Editor Description

Script Editor Use the Script Editor to create, edit, and test the
custom scripts.

For more information, see Creating and editing
scripts with the Script Editor.

Consistency Editor Use the Consistency Editor to analyze database
object for data consistency. A number of tests are
offered to test the database and if necessary run a
repair.

For more information, see Checking data
consistency.

Mail Template Editor Use the Mail Template Editor to create and edit mail
templates.

For more information, see Mail templates in Manager.

Working with the Object Editor

The Object Editor is provided for editing single objects. All properties of an object are
represented in table form and can be edited depending on the permissions situation. In
addition, properties such as edit permissions and column definitions are shown.

Object Editor menu items

When the editor starts, the following menu items are available in the Designer.

Menu Menu item Meaning

Object New Creates a new object.

Save Saves all changes to an object.

Delete Deletes current object.

Discard Returns object to previous state.

Reload object Updates the object view.

Table 48: Menu items added by the editor

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Designer

109

https://docs.oneidentity.com/csh?topicname=desgnscripteditcreate&product_name=oneim_version_10.0LTS
https://docs.oneidentity.com/csh?topicname=desgnscripteditcreate&product_name=oneim_version_10.0LTS
https://docs.oneidentity.com/csh?topicname=desgnconsistencycheckintro&product_name=oneim_version_10.0LTS
https://docs.oneidentity.com/csh?topicname=desgnconsistencycheckintro&product_name=oneim_version_10.0LTS
https://docs.oneidentity.com/csh?topicname=dbmdialogrichmailintro&product_name=oneim_version_10.0LTS


Menu Menu item Meaning

Options Group view The object properties are displayed as groups.

Column names Column display text is shown. If the option is not enabled,
the technical names according to the One Identity Manager
schema are shown.

Primary key Shows or hides the primary key.

Extended Shows or hides the extended column properties.

Help Object Editor
help

Opens the editor help.

Icon Meaning

The object properties are displayed as groups.

Displays caption/technical name depending on the One Identity Manager
schema.

Shows/Hides primary keys.

Shows/hides the extended column properties.

Creates object.

Saves changes.

Deletes object.

Resets object to previous state (lose changes).

Updates object view.

Table 49: Meaning of toolbar icons

Multiple object edit in the Object Editor

It is possible to edit more than one object of the same object type at the same time in the
Object Editor.

1. Use Shift + select or Ctrl + select to select the entries in the result list.

2. Open the editor from the task view,

The task name contains the number of selected objects. Input fields that have
different values are marked in color. The values entered and saved in the fields are
stored for all objects.

One Identity Manager 10.0 User Guide for One Identity Manager
Tools User Interface

Working with the Designer

110



Working with the List Editor

The List Editor is used to display result lists and to quickly edit objects and object relations.
Object properties are displayed in tabular form but there is no additional information about
each property as in the Object Editor.

List Editor menu items

When the editor starts, the following menu items are available in the Designer.

Menu Menu item Meaning

Object New Creates a new object.

Delete Deletes current object.

Reload object Updates the object view.

Filter Define filter Opens a dialog window for creating an ad hoc filter.

Delete filter Deletes the filter.

Manage filters Opens a dialog window for creating permanent filters.

View Properties Shows or hides the edit view

Select columns... Opens a dialog window for selecting columns to be
displayed in the list.

Select table
relations

Opens a dialog for selecting object relation to view.

Help List Editor help Opens the editor help.

Table 50: Menu items added by the editor

Icon Meaning

Creates object.

Deletes object.

Copies object to the clipboard.

Paste the object or relation from the clipboard. Next to the icon there is a menu
to select the type from.

Updates object view.

User-defined filter for displaying objects.

Table 51: Meaning of toolbar icons
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Icon Meaning

Resets custom filter.

Functions in the List Editor result list

The entries in the result list of the List Editor are displayed with a valid name tag. If an
object is selected in the result list, the object properties and object relations are shown in
the edit view. You can limit the number of entries in the result list by setting a filter. For this
you can use an ad hoc filter or a permanent filter.

Context Menu
Item

Meaning

New Inserts a new object.

Delete Deletes selected object.

Copy Copies the selected object into the clipboard.

Paste Inserts the copied object from the clipboard.

Properties Displays the object properties of the selected entry.

Select columns... Opens a dialog window for selecting columns to be displayed in the
list.

Navigation Shows all other editors that can be used with the selected object.

Table 52: Entries in the result list context menu

TIP:

l In the table header for the result list, click on a column to sort it by the
selected column.

l You can display further object properties in the result list.

Related topics

l Configuring columns for List Editor result lists on page 113
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Configuring columns for List Editor result
lists

To display object properties

1. In the Designer, select the View > Select columnmenu item.

2. You specify which object properties should be additionally shown in which order in
the result list. You can also enter the column width and alignment of the column
description.

3. Click OK.

Icon Meaning

Inserts column in view.

Removes column from view.

Moves column up.

Moves column down.

Specifies how columns are labeled. If selected the column names are displayed.
If this option is not active, the identifiers from the data model are shown.

The column display is reset to the default settings.

Table 53: Meaning of toolbar icons

Multiple editing of list entries in the
List Editor

It is possible to edit more than one object of the same object type at the same time in the
List Editor.

l Use Shift + select or Ctrl + select to select the entries in the result list.

Entries in the list that have different input are specially labeled in the edit view. The values
entered and saved in the fields are stored for all objects.

Displaying object relations in the List Editor

To display object relations

1. Select the View > Select table relationsmenu item.

2. You can specify which object relations are displayed in the List Editor.
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Context
menu item

Meaning

Show relation The editing window for the object relationship is displayed in the
editing view of the editor.

Hide relation The editing window for the object relationship is hidden in the
editing view of the editor.

Table 54: Entries in the dialog's context menu

3. Click OK.

Each relation is shown in its own edit window. To change the assignments, double-click the
icon or choose the required option from the context menu.

Icon Meaning

Object is assigned to the selected base object.

Object is not assigned to all selected base objects (multiple entry editing).

Object is not assigned to an object.

Table 55: Meaning of icons in the view

Context Menu Item Meaning

Assign Assign object to the selected base object.

Remove Remove assignment of object to base object.

Properties Displays the object properties of the selected entry.

Navigation Shows all other editors that can be used with the selected object.

Table 56: Items in the view’s context menu

Working with the SQL Editor

You can use the SQL Editor to run database queries against the internal Designer’s SQLite
database. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.

NOTE: To use the SQL Editor in the Designer, users require the Designer_SQLEditor
program function.
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SQL Editor menu items

When the editor starts, the following menu items are available in the Designer.

Menu Menu item Meaning

Edit Undo Restores state before last change.

Redo Restores state after last change.

Cut Deletes marked code but save in clipboard.

Copy Copies selected code to the clipboard.

Paste Inserts data stored in the clipboard from copy or cut.

Delete Deletes selected code.

Reduce text indent Reduces the indent of the selected code in the query
window.

Increase text
indent

Increases the indent of the selected code in the query
window.

SQL Run (F5) Runs the query.

Show as table Switches output between text and table.

Help SQL Editor help Opens the editor help.

Table 57: Menu items added by the editor

Icon Meaning

Undoes last change.

Redoes last change.

Cuts selected code.

Copies selected code into clipboard.

Inserts code from clipboard.

Deletes selected code.

Reduces the indent of the selected code in the query window.

Increases the indent of the selected code in the query window.

Switches output between text and table.

Runs the query.

Table 58: Meaning of toolbar icons
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Running database queries in SQL Editor

To run a database query

l Start the SQL Editor in the Designer by selecting the Database > Run
SQL Editor menu item.

l Enter your database query in SQLite notation in the query window. The editor
supports highlighting.

l Run the database query using F5.

The result are displayed in the results window.

TIP: To sort by a specific column, click on that column in the table header.

TIP: Use Ctrl + C to copy the individual entries or lines to the clipboard. Select
Shift + Select or Ctrl + select to select multiple lines in the table.
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About us

About us

One Identity solutions eliminate the complexities and time-consuming processes often
required to govern identities, manage privileged accounts and control access. Our solutions
enhance business agility while addressing your IAM challenges with on-premises, cloud and
hybrid environments.

Contacting us

For sales and other inquiries, such as licensing, support, and renewals, visit
https://www.oneidentity.com/company/contact-us.aspx.

Technical support resources

Technical support is available to One Identity customers with a valid maintenance contract
and customers who have trial versions. You can access the Support Portal at
https://support.oneidentity.com/.

The Support Portal provides self-help tools you can use to solve problems quickly and
independently, 24 hours a day, 365 days a year. The Support Portal enables you to:

l Submit and manage a Service Request
l View Knowledge Base articles
l Sign up for product notifications
l Download software and technical documentation
l View how-to videos at www.YouTube.com/OneIdentity
l Engage in community discussions
l Chat with support engineers online
l View services to assist you with your product
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