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1

About this guide
The One Identity Manager User Guide for One Identity Manager Tools User Interface is
intended for end users, system administrators, consultants, analysts, and other IT
professionals who want to learn about secure handling of One Identity Manager tools,
especially the Manager and the Designer.
The interfaces of the Manager and Designer have a similar layout. The basic elements and
functions of the user interface are the same for all of the One Identity Manager tools. The
user interface layout is explained based on the example of the Manager. Default functions
used in connection with the Manager Designer are described.
NOTE: This guide describes One Identity Manager functionality available to the default
user. It is possible that not all the functions described here are available to you. This
depends on your system configuration and permissions.
The One Identity Manager Operational Guide describes the special tasks and functions
offered by the two tools to support One Identity Manager while it is running.
The Manager is the main administration tool for setting up information about employees
and their identities. It displays and maintains all the data required for the administration
of employees, their user accounts, permissions, and company-specific roles in a One
Identity Manager network. Company resources employees require can be entered and
assigned to them.
You can also use the Manager to:
l

Define custom IT policies.

l

Set up an IT Shop from which company resources and assignments can be requested.

l

l

Set up special approval processes for authorizing requests and checking compliance
to IT policy.
Set up attestation procedures for regularly testing the correctness of data about
employees or roles and their assignments.

By implementing One Identity Manager application roles, every One Identity Manager user
obtains only those permissions they require to fulfill necessary administrative duties.
The Designer is the main configuration component in One Identity Manager. The program
offers an overview of the entire One Identity Manager data model. It enables the
configuration of global system settings, for example, languages, or configuration
parameters such as customizing user interfaces for the various administration tools. It also
allows the permissions structure to consolidate the various administrative tasks of each
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user and user groups. Another important task is the definition of workflows for technically
illustrating the administration procedures in the company.

Available documentation
You can access One Identity Manager documentation in the Manager and in the Designer by
selecting the Help > Search menu item. The online version of One Identity Manager
documentation is available in the Support portal under Technical Documentation. You will
find videos with additional information at www.YouTube.com/OneIdentity.

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
About this guide

8

2

One Identity Manager tools user
interface
The user interface layout is explained based on the example of the Manager. The basic
elements and functions of the user interface are the same for all of the One Identity
Manager tools.
Certain components of the One Identity Manager’s graphical user interface are stored in
the One Identity Manager schema and can be tailored to suit customer requirements.
Menu items in the navigation structure, interface forms, and task definitions can be
configured in this way.
Menu items, interface forms, and task definitions are assigned to permissions groups. The
user's effective components of the user interface depend on the authentication module
used for logging in to the One Identity Manager tools. If a user logs in to a One Identity
Manager tool, a system user is found and the available menu items, interface forms, task
definitions, and individual program functions are identified depending on the permission
groups to which this system user belongs and the adapted user interface is loaded.
Data is displayed as objects in the user interface. User interface objects are meta-objects.
You provide a selection of configurable elements that describes how the data stored in the
database is perceived. These objects enable data to be distinguished by specific properties.
They provide an additional control function for configuring the user interface. Hence,
interface forms and tasks are linked to object definitions, which means that different forms
and tasks are displayed in the user interface depending on which object is selected.
For more information about how to customize the user interface to your specific
requirements, see the One Identity Manager Configuration Guide.

The user interface layout
You can control the One Identity Manager tools' graphical user interface with using mouse
and key combinations. A minimum screen resolution of 1280 x 1024 pixels is recommended
with at least 16 bit color for the best display.
The user interface consists of the following components:
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A. Title bar
In the title bar, you can see the program icon, program name, and connected
database shown using the notation <user>@<database server>\<database
(description)>.
B. Menu bar
The menu bar gives you different menus and menu items. The menus Database and
Help are always there. If a database is open, you can see more menus.
C. Toolbar
Each program component comes with its own toolbar.
D. Editing section
The editing section has different views for displaying and editing data.
E. Status bar
The status bar displays different status data. Some status data is shown by way
of icons. Which icons are displayed is partially dependent on the program
settings selected.
Figure 1: Manager user interface
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Using the help in the Manager
You can access One Identity Manager documentation in the Manager by selecting the Help
> Search in local help menu item.
You can display the help for the individual Manager forms using the Help > Form help
menu item or F1.
With some forms, a separate dialog box appears. Use the help icon (?) in the title bar of the
dialog window to open the help for a dialog window.
Every form also has a help display for the columns shown. Clicking on the help icon
changes the cursor into the help icon. You can then click a column description to display
tips about using the column in the form of tooltips.

Status bar information in the Manager
The status bar displays different status data. Some status data is shown by way of icons.
Which icons are displayed is partially dependent on the program settings selected. The
status bar comes in different colors.
Table 1: Meaning of the colors
Color

Meaning

none

Development environment database is connected.

Red

Simulation mode is enabled.

Green

Test environment database is connected.

Yellow

Productive environment database is connected.

Table 2: General icons in the status bar
Icon Meaning
Current user.
The DBQueue Processor was stopped.
The services were stopped.
The database is connected.
Database status (database activity such as loading or saving objects).
The database must be compiled.
The database is in recovery mode. It is not possible to process data at this time.
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Icon Meaning
There are invalid script assemblies. The database must be compiled.
No connection.
Display for step-by-step preparation of a database update. All database users will
be informed about the upcoming update. The system does accept anymore
processes.
Display for step-by-step preparation of a database update. Users cannot log in to
the database anymore. All running processes will still be completed.
Display for step-by-step preparation of a database update. The database is
updating.
Table 3: Additional icon in the status bar in the Manager
Icon

Meaning
Quick edit mode is enabled.
The field definitions (technical tables and column names) are displayed.
Additional information on the navigation objects is displayed.
The program is in simulation mode.
The system data was modified.
A warning has been written to the error log.
An error message has been written to the error log.

The Manager's status bar also shows the following information:
l

The connected database in the following format: <Server>\<database (description)>

l

The definition of the current object

l

The name of the activated form in the following format: <logical form>
[(<physical form>)]

TIP: Double-click the name in the status bar to copy the object definition, the form name
or the database connection name to the clipboard.

Related topics
l

The user interface layout on page 9

l

Features of the document view on page 30

l

Displaying the column names on page 34

l

Detailed information about the user interface on page 59

l

Current user on page 13
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Current user
The program's status bar shows the name of the current user. Depending on the
authentication module used, this can be the full name of the person or the designation of
the current system user. Use the tooltip to show the full name of the current user and the
current system user.
To get more information about the current user
l

To display user information, double-click the

icon in the program status bar.

Table 4: Extra information about the current user
Property

Meaning

System users

Name of system user

Authenticated
by

Name of the authentication module used for logging in.

Employee UID
(UserUID)

Unique ID for the current user’s employee if an employee related authentication module is used to log in.

SQL access
level

Access level of the database server used to log in.

Read-only

The system user has only has read permissions. Modification to data are
not possible.

Dynamic user

The current user uses a dynamic system user. Dynamic system users
are applied when a role-based authentication module is used.

Administrative The current user uses an administrative system user.
user
Remarks

More details about the system user in use.

Permissions
group

Permissions groups that are assigned to the system user. The permissions groups determine the user's user interface and object permissions.

Program
functions

Program functions assigned to the system user The menu items and
functions available depend on the program functions.

Changing the password of the logged in user
To change the password:
1. Select the Database > Change password menu item and enter the following
information:
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l

Old password: Enter the previous password.

l

New password: Enter the new password.

l

Confirm new password: Enter the new password again.
NOTE: The password must comply with the password policy. To display the
requirements, click the Password requirements link.

2. Save with OK.

Menu items in the Manager
Table 5: Meaning of items in the menu bar
Menu

Menu item

Database New connection

Meaning

Shortcut

Establishes a database connection.

Ctrl + Shift
+N

Close connection

Closes the current database connection.

Change
management

Opens a dialog box for editing change labels.
This menu item is only available in expert
mode.

Start/stop
simulation

The program switches to simulation mode or to
working mode.
For detailed information about the simulation,
see the One Identity Manager Operational
Guide.

Change
management

Opens a dialog box for editing change labels.
This menu item is only available in expert
mode.
For detailed information about working with
change labels, see the One Identity Manager
Operational Guide.

Export data

A form opens in which you can confirm the
export data.
For detailed information about exporting data,
see the One Identity Manager Operational
Guide.

Show deferred Deferred operations are displayed.
operations
For detailed information about planning activation times, see the One Identity Manager
Operational Guide.
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Menu

Object

Menu item

Meaning

Shortcut

Pending
changes

Shows changes pending for objects and their
processing status.

Check data
consistency

This opens the consistency check form.

Change
password

The logged in user can change the password.

Settings

For configuring general program settings.

Exit

Exits the program.

Alt + F4

New

A new object with the displayed object type is
added.

Ctrl + N

Save

Saves all changes to an object.

Ctrl + S

For detailed information on checking data
consistency, see the One Identity Manager
Operational Guide.

Set the change You can set the time of the change.
time stamp
For detailed information about planning activation times, see the One Identity Manager
Operational Guide.
Delete

Deletes selected object.

Ctrl + D

Set the
deletion time

You can set the time that the object is deleted.

Undo delete

After confirmation, the deletion process is
reversed. This option is only available if the
object was marked for deletion.

Discard
changes

Any unsaved form entries are discarded.

Ctrl + Shift
+D

Reload

The object is reloaded.

Ctrl + F5

Properties

Show other properties of the active object. This
menu item is only available in expert mode.

Reapply
templates

All object templates are reapplied. This menu
item is available only in the object's main data
form.

Add to
favorites or
remove from

Add the current object to your favorites or
remove it from your favorites. These options
are shown alternately.

For detailed information about planning activation times, see the One Identity Manager
Operational Guide.

Ctrl + B
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Menu

Menu item

Meaning

Shortcut

Back

Shows the previous form in the order in which
the forms were viewed.

Alt + left
arrow

Forward

Shows the next form in the order in which the
forms were viewed.

Alt + right
arrow key

favorites
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Menu

Menu item

Meaning

Shortcut

View

Navigation

Activates the navigation view.

Ctrl + Q

Result list

Opens the result list.

Ctrl + R

Documents

Enables the current document.

Ctrl + O

Favorites

Shows or hides the favorites list.

Tasks

Shows or hides the task view.

Error log

Shows or hides the error log.

Process
Information

Shows or hides the process view.

TimeTrace

Shows or hides the TimeTrace.
For detailed information about TimeTrace, see
the One Identity Manager Operational Guide.

Plugins

Database
search

Shows or hides the database search.

Start page

The start page is displayed.

Enable quick
edit mode

The quick editing of objects is enabled or
disabled.

Close current
document

Closes the current document.

Close all
documents

Closes all open documents.

Enable
document

Shows all open documents. You can toggle from
one open document to the next.

Layout

Changes the layout of the program’s interface.

Display field
definitions

The technical table and column names are
shown in the editing forms. This menu item is
only available in expert mode.

Display
navigation
objects

Displays the loaded navigation objects. This
entry is available only if the program setting
Show additional navigation information is
enabled.

Name of the
plugin.

Shows the available plugins so that you can
apply them.

F4

Ctrl + Shift
+ L (loads
in expert
mode)
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Menu

Menu item

Meaning

Shortcut

Help

Community

Opens the One Identity Manager community
website.

Support portal

Opens the One Identity Manager product
support website.

Training

Opens the One Identity Manager training portal
website.

Online
Opens the One Identity Manager documentation
documentation website.
Search

Opens the search dialog box.

Form help

Opens the help for this form.

Info

Shows the version information for program.

F1

Table 6: Toolbar functions
Icon Meaning
Show homepage.
Show the previous form in the order in which the forms were viewed. You can see
the form history from the selection menu. You can select any form you wish from
here.
Show the next form in the order in which the forms were viewed. You can see the
form history from the selection menu. You can select any form you wish from
here.
Show or hide the database search dialog.
Add a new object of that object type.
Saves changes.
Set time at which to save an object's changes. For detailed information about
planning activation times, see the One Identity Manager Operational Guide.
Deletes object.
Set time at which to delete the selected object. For detailed information about
planning activation times, see the One Identity Manager Operational Guide.
Redo delete. This option is only available if the object was marked for deletion.
Discard unsaved changes from the form.
Update object.
Add object to favorites.
Remove object from favorites.
Print form. Printer settings are configured in the configuration menu.
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Views in the Manager
The editing area in the Manager has different views for displaying and editing data.
Table 7: Views in the editing area
View

Description

Navigation
view

The navigation view shows suggested navigation starting points for the
current user.

Result list

When you select a menu item in the navigation view, the result lists shows
all the objects that correspond to the object definition and the conditions of
the menu item.

Document
view

The document view shows the forms to edit a selected object.

Task view

The task view shows the tasks and reports available for an object.

Favorites
list

This view is used to compile individual menu items into a user-specific
favorites list.

Error log

The error log shows errors and warnings that occurred when working with
the Manager. For detailed information about Error log, see the One Identity
Manager Process Monitoring and Troubleshooting Guide.

Process
This view is used to analyze the process data resulting from data changes.
Information For detailed information about the evaluation of process information, see
the One Identity Manager Operational Guide.
TimeTrace

In this view you can track changes to an object that were made up to any
point in the past. For detailed information about TimeTrace, see the One
Identity Manager Operational Guide.

Detailed information about this topic
l

The user interface layout on page 9

l

Features in the navigation view on page 21

l

Functions in the result list on page 25

l

Features of the document view on page 30

l

Features in the task view on page 28

l

Features in the favorites list on page 29
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Layout mode in the Manager
The Manager can display the editing area in standard mode or expert mode. The layout of
the default view varies between modes. The current user's layout is saved in the user
configuration so that when you restart the program the last layout you used is shown.

Detailed information about this topic
l

Simple layout mode in the Manager on page 20

l

Expert mode in the Manager on page 20

Simple layout mode in the Manager
The simple layout mode provides two other layouts in addition to the default layout.
To select the simple layout mode in the Manager
1. In the Manager, select the Database > Settings menu item.
2. On the User tab, disable the Enable expert mode option.
To change the layout in the Manager
l

l

To specify a layout in the Manager, select the View > Layout > View 1 or the
View > Layout > View 2 menu item.
To reset the layout to the default setting in the Manager, select the View > Layout
> Restore default menu item.

Related topics
l

Expert mode in the Manager on page 20

Expert mode in the Manager
In expert mode you can use the mouse to change the position and size of the editing
windows in the user interface. You can use the pin in the title bar of a window to enable or
disable the auto-hide mode. If this mode is enabled, the selected window slides out of or
into the area. To select a window in auto-hide mode, use the symbol in the navigation
toolbar on the side. There are other menu items and functions available in expert mode.
To select expert mode in the Manager
1. In the Manager, select the Database > Settings menu item.
2. On the User tab, enable the Enable expert mode option.
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To change the layout in the Manager
l

l

l

To save the layout in the Manager, select the View > Layout > Save menu item
and enter a Name.
To load a layout in the Manager, select the View > Layout > Load or Ctrl + Shift
+ L menu item.
To reset the layout to the default setting in the Manager, select the View > Layout
> Restore default menu item.

Table 8: Other menu items in expert mode
Menu

Menu item

Meaning

Shortcut

Database Change manage- Opens a dialog box for editing change labels.
ment
View

Object

Display field
definitions

The technical table and column names are
shown in the editing forms.

Layout > Save

Save the current layout.

Layout > Load

Load a layout.

Properties

Show other properties of the active object.

Ctrl +
Shift + L

Table 9: Additional context menu items
Context
menu

Meaning

Definition

This shows advanced technical information about configuring a menu item.
This menu item is only available in navigation view. You must also enable the
Show additional navigation information program setting.

Properties Shows other properties of the object.

Related topics
l

Simple layout mode in the Manager on page 20

l

Displaying the column names on page 34

l

Detailed information about the user interface on page 59

l

Displaying extended properties for objects on page 77

Features in the navigation view
The navigation structure of the user interface is hierarchical and allows users to drill down
to the selection of an object definition. The top level of the hierarchy is used to classify the
data managed by One Identity Manager into specified categories. Categories include a
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range of different menu items. Select a category on the category tab. You can configure
additional settings in the configuration menu.
Figure 2: Navigation view in the Manager with the "Organizations" category
as an example

TIP: If menu items are linked to preprocessor-relevant configuration parameters, you
can display the preprocessor conditions behind the menu items. To do this, enable the
program setting Show additional navigation information.
Specific mouse commands are available:
l

l

You can open or close a menu item by double-clicking on the entry name.
Click the name of the menu item to show the found objects in the result list, as long
as a corresponding object for that object type is found. If there are no objects for a
defined menu item, an empty result list is shown.

Table 10: General key combinations for the navigation view
Shortcut

Action

Ctrl + Q

Activate navigation structure.

Down arrow, up arrow, page down key, page up key,
home, end

Move up/down the navigation
structure.

<+> or right arrow key

Open menu item.
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Shortcut

Action

<-> or left arrow key

Close menu item.

Data

Select an entry.

F5

Update the navigation view.

The navigation view has its own context menu. Menu commands are shown or hidden
depending on the selected menu item.
Table 11: Entries in the context menu of the navigation view in the Manager
Context
Meaning
Menu Item
New

A new object with the selected object type is added. Already entered insert
values are applied.

Open on
new tab

The object is opened in a new form in the document view.

Refresh
view

Updates the navigation view.

Search

The system searches for objects in the navigation.

Add to my
Copies the selected menu item to the My One Identity Manager
One Identity category. This helps you navigate quickly to frequently used menu items.
Manager
The data is saved in the user configuration.
Add to
favorites

Adds the selected object to your favorites.

Remove
from
favorites

Removes the selected object from your favorites.

Show
process
information

The process view shows the process data for the selected object. For
detailed information about the evaluation of process information, see the
One Identity Manager Operational Guide.

Tasks

The available tasks for the object are displayed and you can run the
desired task.

Definition

Shows detailed information about configuring the menu item. This menu
item is only available in expert mode.

Show
deferred
operations

Shows the deferred operations for the objects in this category. For detailed
information about planning activation times, see the One Identity Manager
Operational Guide.

The navigation view features a configuration bar with its own configuration menu.
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To open the configuration menu of the navigation view
l

Use the >> button.

Table 12: Entries in the navigation view configuration menu
Entry in configuration menu

Meaning

Show more categories

More categories are shown in the list. The category icon is
removed from the configuration bar.

Show fewer categories

More categories in the list are hidden. These are represented by
icons in the configuration bar.

Settings

Opens the program settings.

Add or remove
categories

Categories can be removed from or added to the list.

Related topics
l

My One Identity Manager on page 24

l

Manager program settings on page 55

l

Detailed information about the user interface on page 59

My One Identity Manager
The category My One Identity Manager shows the user-specific entries in the Manager.
All the available infosystems and specific reports for the current user are shown here. In
this category you can create and apply user-specific filters.
To copy a menu item to the My Manager category in One Identity Manager
l

Click Add to My .One Identity Manager
This helps you navigate quickly to frequently used menu items. The data is saved in
the user configuration.

To delete a menu item from the My Manager category in One Identity Manager
l

Click Remove from My .One Identity Manager

Table 13: Additional entries in the context menu for the my One Identity
Manager category
Context Menu
Item

Meaning

Remove from My

Removes the selected menu item from this category.
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Context Menu
Item

Meaning

One Identity
Manager
New filter

Search criteria for database queries are saved as filters.

Edit filter

The selected filter can be edited.

Remove filter

Deletes the selected filter.

Attaching

The selected filter is attached to a category. When you select a
category, all objects that correspond to the filter are shown on a
separate form page.

Export filter

Exports the selected filter as an XML file.

Import filter

Imports filters that exist as XML files.

Related topics
l

Advanced database search on page 72

l

Attaching filters in the Manager on page 68

l

Exporting and importing filters in the Manager on page 68

Functions in the result list
The result list shows all the objects that correspond to the object definition and the
conditions of the selected menu entry. Select an entry from the list. The object is loaded
and the first available form appears in the document view. If there are no objects for
the selected menu entry, the document view continues to show the most recently
selected form.
A list title is shown in the title bar of the result list. This depends on which menu item in the
navigation structure was used to select the object. This list title also contains the number of
elements in a list.
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Figure 3: Example for result list in the Manager

In the result list, an object is marked with the symbol that was set when the interface was
configured. If an object is deleted by the One Identity Manager Service, the object is
initially marked for deletion. It is permanently deleted only after a set time period. Objects
that are selected for deletion are marked with the icon .
NOTE: Objects marked for deletion are struck through on the overview form.
By default, an object is loaded by means of a double-click and the first available form is
displayed in the document view.
To load objects with a single click
1. Select the Database > Settings menu item.
2. On the User tab, activate the Use single clicks option.
Select single objects one after the other to update the opened form in the document view.
Only one form is open at a time.
To display multiple forms in the document view:
l

Use Alt + Click or click Open on new tab from the context menu to open
the objects.
This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

To edit multiple objects at the same time:
1. Use Shift + selection or Ctrl + selection to select the objects in the result list.
2. Open the main data form using Input, the corresponding icon in the result list or the
Tasks > Change main data context menu item.
New objects are displayed below the Added entry in the result list. The objects used are
displayed below the Recently used entry in the result list.
To display recently used objects in the Manager
1. Select the Database > Settings menu item.
2. On the User tab, activate the Show recently used objects option and enter the
Object type count.
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Table 14: Common key combinations for the result list in the Manager
Shortcut

Action

Ctrl + R

Enable result list.

Down arrow, up arrow, page down key,
page up key, home, end

Move up/down the list.

Enter, Alt + Enter

Open an item.

Shift + selection + Enter , Ctrl +
selection + Enter

Select multiple entries and open the main data
form to edit multiple entries.

F5

Update the result list.

The result list has its own toolbar and context menu.
Table 15: Toolbar features in the Manager
Icon

Function
Edit. Opens the main data form.
New. Creates a new object.
Delete. Deletes the object.
Undo delete. Redo delete.
Reload the data. Reloads the objects.
Search. Search in result list.
Filter. Filter result list.
Export result list.

Table 16: Entries in the result list context menu in the Manager
Context
Menu
Item

Meaning

New

A new object with the selected object type is added. Already entered insert
values are applied.

Delete

The selected object is deleted once the security prompt is confirmed.

Undo
delete

After confirming the security prompt, the object is undeleted. This option is
only available if the object was marked for deletion.

Open on
new tab

The object is opened in a new form in the document view.

Search

The system searches for objects in the navigation.
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Context
Menu
Item

Meaning

Add to
favorites

Adds the selected object to your favorites.

Remove
from
favorites

Removes the selected object from your favorites.

Show
The process view shows the process data for the selected object. For
process
detailed information about the evaluation of process information, see the
information One Identity Manager Operational Guide.
Tasks

The available tasks for the object are displayed and you can run the desired
task.

Properties

Show other properties of the active object. This menu item is only available
in expert mode.

Related topics
l

Expert mode in the Manager on page 20

l

Limiting list sizes using simple filters on page 61

l

Displaying extended properties for objects on page 77

l

Multiple object edit in the Manager on page 78

Features in the task view
When you select an object, the task view shows the tasks and title of available reports. To
run a task or open a report, select an item in the task view. Use the tooltip to show a more
detailed description of a task or a report.
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Figure 4: Task view in the Manager

TIP: If tasks are linked to preprocessor-relevant configuration parameters, the
preprocessor conditions are shown behind the tasks. To do this, enable the program
setting Show additional navigation information.

Related topics
l

Detailed information about the user interface on page 59

Features in the favorites list
Links to frequently visited objects are stored in the favorites list in the Manager.
Figure 5: Favorites list in the Manager

To copy an entry to the favorites in the Manager
l

In the Manager, select the entry and select the Add to favorites context menu.
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To delete an entry from the favorites in the Manager
l

In the Manager, select the entry and select the Remove from favorites
context menu.

The favorites list has its own toolbar and context menu.
Table 17: Meaning of entries in the special toolbar in the Manager
Icon

Meaning
Sort your favorites alphabetically.
Sort your favorites by object type.
Delete all favorites.
Delete selected favorites.

Table 18: Entries in the context menu of the favorites list in the Manager
Context
Menu Item

Meaning

Open on new
tab

The object is opened in a new form in the document view.

Search

The system looks for objects in the favorites list.

Remove
selected
favorites

The selected favorites are removed from the favorites list.

Tasks

A submenu shows all the tasks that are available for the selected object.
Select one of the tasks to open the relevant form.

Properties

Show other properties of the active object. This menu item is only
available in expert mode.

Related topics
l

Displaying extended properties for objects on page 77

Features of the document view
When you select an object in the result list, the first available form is displayed in
document view. As a minimum, the following forms are displayed for each editable object:
l

Overview form
This form is used only to display selected data for an object.
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l

Main data form
Use this form to change the object data.

Every form has a form tab bar that displays the selected object according to a set display
template. For objects that were marked as pending during a synchronization, the display
template is provided with the [Outstanding] ID.
Every form has a context menu with form-specific entries. In expert mode, you can use the
Properties entry in the form context menu to view additional object properties and the
permissions.
Figure 6: Form in the Manager

To open the forms for an object:
l

l

l

When you select an object on the result list, the first form always opens (usually the
overview form).
From the result list, select single objects one after the other to update the opened
form in the document view. Only one form is open at a time.
To open other forms, select the task from the task view or from the form's
context menu.

To display multiple forms in the document view:
l

Use Alt + Click or the Open on new tab context menu to open the objects.
This means that you can quickly switch between objects without having to reload the
object from the list again. The forms stay open when you switch between categories.

To close the forms:
l

From the menu, select the View > Close active document or the View > Close
all documents menu item.

By default, an object‘s overview form is displayed first. You can, however, configure the
program to show the edit form for the object first, which allows faster editing.
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To enable quick edit mode:
l

In the Manager, use the

icon in the result list.

It is only possible to quick edit the selected object.
l

Select the View > Enable quick edit mode menu item.
Restart the program to enable quick edit mode.

l

From the Database > Settings menu item, select the Enable quick edit mode
program setting.
Quick edit mode remains enabled even if you restart the program.

The status bar in the Manager also shows the following information when you open a form:
l

l

The definition of the current object
The name of the activated form in the following format: <logical form>
[(<physical form>)]

TIP: Double-click the name in the status bar to copy the object definition and the form
name to the clipboard.
The forms use different controls and functions.

Related topics
l

Detailed information about the user interface on page 59

l

Displaying extended properties for objects on page 77

Overview form
Form elements are used to present the information on the overview forms.
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Figure 7: Example of elements in an overview form

The display text of the menu item, the display text for the objects to be shown and the
menu item icon are displayed in the header of a form element. Other data represents the
object properties and values. There is a tooltip for each property showing a description for
use. Some form element entries are highlighted in color when you click on them with the
mouse. Then you can click on the entry to switch to the referenced object.
If the form element is used for mapping lists, the items are displayed with their names.
The number of items is shown in the form element header. There is also an icon in the form
element header for showing and hiding the items. A tooltip is also shown for the list items.
Table 19: Form element icon
Icon

Meaning
Show list items.
Hide list items.

NOTE: Objects marked for deletion and outstanding objects are struck through on the
overview form.

Input field
Input fields are used to edit strings, numbers, and dates. A default context menu is
available for input fields. Mandatory input fields are marked with a triangle . Whether an
input field is required or not depends on the minimum column length defined in the model
tables. Other required fields are defined in the customizers.
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Figure 8: Input field with required field

TIP: You can use the Ctrl + Alt + Enter key combination to enlarge the input fields for
entering multiline texts.

Labeling changed data
Changes to data are labeled with extra icons in front of the modified value. As long as the
changes have not been saved, you can undo the changes by clicking on the icon.
Figure 9: Labeling changed data

Table 20: Labeling the input fields when data changes
Icon

Meaning
Changed value. The value is not yet saved. Click the icon to discard the
change.
The value will be changed at a specified time. You can change the value only at
the specified time.
The value will be changed at a specified time.

For detailed information about planning activation times, see the One Identity Manager
Operational Guide.

Displaying the column names
The column name is shown for every input field. If the full column name is too long to
display, it is shortened with [...]. Use a tooltip to display the full name.
In the Manager, you can display the technical names of the columns in expert mode. in the
format column@table.
To display the technical names in expert mode in the Manager
l

In the Manager, select the View > Show field definition menu item.

Related topics
l

Expert mode in the Manager on page 20
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Translating entries
For more information about localization in One Identity Manager, see in the One Identity
Manager Configuration Guide.
If a column is marked as multilingual, an extra button

is displayed next to the input field.

NOTE:
l

l

l

l

l

The value is always entered in the input field in the specified default language. The
value is then translated into the required languages.
The translations are only used to display a value, for example, in the overview
form or in lists. The input fields to be edited still show the value entered in the
default language.
You can edit translations in different places. When you change a translation, all
those places are shown. Before changing a translation, check in the Designer about
how it is used.
Users can only edit object and column translations for which they have
permissions.
To edit all translations, users require the Allow translation of text data
regardless of the edit permissions for the base object program function
(Common_Translation).

To translate an entry:
1. Click

beside the input field to open the dialog window for entering the translations.

2. Use next to the translation field to delete a translation.
NOTE: You can use the

button beside the translation input to delete a translation.

3. Click Save.

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
One Identity Manager tools user interface

35

Figure 10: Translating entries

Entering a list of permitted values
If you have the option to set a list of permitted values for a column, the input field
looks like this:
l

If there is no defined list, enter the value in the simple input field that appears.

l

If there is a defined list, select the value from the selection list that appears.

Figure 11: Selecting from a list of permitted values

The control on the default forms in the Manager is only available for the predefined
columns and for the user-defined columns (generally Spare field no. 01–Spare
field no. 10).

Entering multiple values
If a column is suitable for entering multiple values, you will see extra icons next to the
input field.
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Figure 12: Entering multiple values

Table 21: Icons for entering multiple properties
Icon

Meaning
Insert data. A separate input form opens.
Delete data.

Setting values
Use the slider to set a value within a defined range. The value appears next to the slider
and can be displayed in full with the tooltip. The color indicates how critical the value is
assessed to be.
Figure 13: Slider

Entering scripts
This input field is used in the editors when the input data needs to have a specified
syntax (for example SQL, XML, or VB.Net). It has an advanced edit mode that provides
additional actions.
To switch to advanced mode
l

Press Ctrl + Alt + Enter or click the button at the bottom right.

Figure 14: Directly entering a database query
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Table 22: Meaning of icon in advanced edit mode
Icon

Meaning
Quits advanced edit mode.
Undoes last change.
Redoes last change.
Cuts selected code.
Copies selected code into clipboard.
Inserts code from clipboard.
Deletes selected code.
Decreases insert.
Increases insert.
Automatic text formatting.
Formats text selection automatically.
Shows/hides line numbers.
Inserts comments.
Removes comments.
Inserts or removes line numbers.
Inserts or removes automatic line breaks.
Shows or hides spaces and tabs.
Searches within code.
Inserts code snippet.
Shows list of objects properties.
Shows auto completion list.
Shows list with parameter information.
Shows additional information.

Table 23: Shortcut for editing scripts
Shortcut

Description

Ctrl + C

Copy to clipboard.

Ctl + Ins

Copy to clipboard.

Ctrl + X

Cut and copy to clipboard.
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Shortcut

Description

Shift + Del

Cut and copy to clipboard.

Ctrl + L

Cut row and copy to clipboard.

Ctrl + V

Paste from clipboard.

Shift + Ins

Paste from clipboard.

Ctrl + Y

Redo action.

Ctrl + Shift + Z

Redo action.

Ctrl + Z

Undo action.

Backspace

Remove character behind cursor.

Shift + Backspace

Remove character behind cursor.

Ctrl + Backspace

Remove word behind cursor.

Del

Delete character in front of cursor.

Ctrl + Shift + L

Delete row.

Ctrl + Del

Delete to end of next word.

Data

Insert line break.

Shift + Return.

Insert soft line break.

Ctrl + Return

Insert row above.

Ctrl + Shift + Return

Insert row below.

Ctrl + Space

Auto-complete.

Ctrl + Space + Space

Show list with parameter information.

Tab

Insert indent/tab.

Shift + Tab

Remove indent/tab.

Ctrl + U

Change marked characters to lowercase.

Ctrl + Shift + U

Change marked characters to uppercase.

Ins

Toggle insert mode.

Ctrl + T

Swap characters in front and behind cursor.

Ctrl + Shift + T

Swap words in front and behind cursor.

Shift + Alt + T

Swap row with previous row.

Alt + PgUp

Move row up.

Alt + PgDn

Move row down.
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Shortcut

Description

PgUp

Move up

PgDn

Move down.

Left arrow

Move left.

Right arrow

Move right.

Ctrl + Left arrow

Move to previous word.

Ctrl + Right arrow

Move to next word.

Home

Move to start of line.

End

Move to end of line.

Ctrl + Home

Move to start of script.

Ctrl + End

Move to end of script.

PgDn

Move up a page.

PgUp

Move down a page.

Ctrl + PgUp

Move to visible start.

Ctrl + PgDn

Move to visible end.

Ctrl + ]

Move to next bracket. (not possible on German keyboard)

Ctrl + Down arrow

Scroll down.

Ctrl + Up arrow

Scroll up

Ctrl + F

Open search dialog.

F3

Search next.

Ctrl + F3

Search forward.

Shift + F3

Search backward.

Ctrl + Shift + F3

Find previous.

Ctrl + H

Replace.

Ctrl + I

Search forward incrementally.

Ctrl + Shift + I

Search backward incrementally.

Ctrl + Shift + Num-

Reduce code block selection.

Ctrl + Shift + Num+

Extend code block selection.

Esc

Remove selection.

Shift + Down arrow

Extend selection down.
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Shortcut

Description

Shift + Up arrow

Extend selection up.

Shift + Left arrow

Extend selection left.

Shift + Right arrow

Extend selection right.

Ctrl + Shift + Left arrow

Extend selection to previous word.

Ctrl + Shift + Right arrow

Extend selection to next word.

Shift + Home

Extend selection to start of line.

Shift + End

Extend selection to end of line.

Shift + Alt + Home

Extend selection to start of script.

Ctrl + Shift + End

Extend selection to end of script.

Shift + PgUp

Extend selection by one page up.

Shift + PgDn

Extend selection by one page down.

Ctrl + Shift + PgUp

Extend selection to visible start.

Ctrl + Shift + PgDn

Extend selection to visible end.

Ctrl + A

Select all.

Ctrl + Shift + W

Select word.

Ctrl + Shift + ]

Select up to the next bracket. (not possible on German
keyboard)

Shift + Alt + Down arrow

Extend selected block down.

Shift + Alt + Up arrow

Extend selected block up.

Shift + Alt + Left arrow

Extend selected block left.

Shift + Alt + Right arrow

Extend selected block right.

Ctrl + Shift + Alt + Left
arrow

Extend selected block by one word to the left.

Ctrl + Shift + Alt + Right
arrow

Extend selected block by one word to the right.

Ctrl + mouse wheel

Adjust text size.

There is additional help provided for creating script code.

Syntax highlighting
The input fields support syntax highlighting depending on the syntax type.
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Auto-completion
You can use auto-completion when you write script code. The amount of scripted code to
enter is reduced by displaying the names of properties or functions that can be used. To
use auto-completion, use the shortcut Ctrl + SPACE in the relevant positions within the
input fields. The contents of the list is determined by the key words in the code.

Entering code snippets
One Identity Manager provides code snippets for you to use as templates. You can insert
code snippets using the following options:
1. Using the

icon

a. Select the

icon.

b. Select the code snippet.
2. Using a shortcut
a. Press F2.
b. Select the code snippet.
3. Using an aliases
a. Enter an alias.
b. Use Tab to insert the code snippet.
NOTE: Be aware of case sensitivity when you enter the alias.
NOTE: If you select a code snippet directly using a shortcut or the
tion and the shortcut name are displayed in a tooltip.

icon, a short descrip-

Inputting values using dollar ($) notation
In input fields where a VB.NET term is expected, a help list opens when you enter $. All
properties of the current object are displayed. You can also see a tooltip with a detailed
description of the property. When you select a foreign key (FK) column, you can navigate
to the columns in the relevant table using the arrow keys. To end the selection in the target
column, press Enter or double-click. The complete $ notation for your selection should now
be shown in the input column. To close the help list without copying any data, press Esc or
leave the input field.
Figure 15: Help list for dollar notation
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Table 24: Meaning of icons used in the help list for dollar notation.
Icon

Meaning
Property of current object.
Primary key (PK).
Foreign key (FK).
Dynamic foreign key
Table
Special properties
Script

Table 25: Help list functions for dollar notation
Shortcut

Action

Arrow down key

Opens the help list.

Arrow up key, arrow down
key

Navigate to previous or next entry.

Arrow left key, arrow right
key

Navigate to the object above or below over the foreign
key.

Data

Accepts the value in dollar notation.

Entering database queries
It is sometimes necessary to enter database queries. You can enter the database queries
as a SQL query directly or compile the database queries with a wizard. Use the ,
or
buttons to switch to the appropriate view.
Table 26: Meaning of the icons
Icon

Meaning
Enter a database query as a SQL query.
WHERE clause wizard.
Filter designer.

Detailed information about this topic
l

Wizard for entering database queries on page 44

l

Filter designer on page 45
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Wizard for entering database queries
The wizard helps you to formulate a condition (where clause) for database queries. The
complete database query is composed internally. It always refers to the database table,
which is preset when the Where clause wizard starts.
Figure 16: WHERE clause wizard.

There are predefined operators to make it easier to create conditions. The operators are
underlined. Operators with a help entry for the permitted value (such as column selection,
data input or free text) are shown in parentheses (<<Operator>>).
To create a database query using the WHERE clause wizard
1. Start the WHERE clause wizard with the

button.

2. Create the database query.
l

l

l

When you hover over an operator, the cursor changes to a hand symbol.
If an operator has only two permitted values you can click to switch between
the values.
Click an operator with more than two permissible values to open a menu listing
the permissible operator values.
Click to select the required entry and then use the button to confirm the
selection.
- OR Double-click an entry to select the value.

l

A selection window opens in which you can select all database columns of the
base object and its related objects. Use SQL name to switch between the
display name and the technical name of tables and columns.
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l

l

For complex database queries, you have the option of linking several
conditions together. After each condition there is a row showing the logical
operator for the connection, followed by another row for the next condition.
Use the button in front of a condition to delete it from the query.
Use the Expert view button to switch to direct entry of the query in SQL
syntax. Use the Wizard view button to switch back to the simple input mode.

3. Click Continue.
The preview shows all the entries that meet the defined condition.
4. Click Continue.
The database query condition is shown in SQL syntax.
5. Click Finished.

Filter designer
The filter designer helps you formulate a condition for database queries. The complete
database query is composed internally. The database query always references the
Person table.
Figure 17: Filter designer

To create a database query using the filter designer
1. Start the wizard by pressing

.

2. Using the all operator, specify whether at least one or all of the conditions defined
below must be fulfilled.
l

When you hover over the operator, the cursor changes to a hand symbol.

l

By clicking the operator, switch between the all and at least one values.

3. Create the conditions.
a. In the first menu, specify the condition type.
Depending on the condition type, other menus are displayed.
Table 27: Permitted condition types
Condition Type

Meaning

Property

Employee object properties. The drop-down menu with
permitted properties is already restricted to the most
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Condition Type

Meaning
important employee properties.

For the account
with the target
system type

Employee’s user account. Valid user account properties
depend on which target system is selected.

For entitlements
with the target
system type

Employee target system group. Valid group properties
depend on which target system is selected.

SQL Query

Free choice of SQL query (WHERE clause). To use the
WHERE clause wizard, click .

You can only select columns that are shown in the Unified
Namespace and for which the Display in the filter
designer option is enabled.

You can only select columns that are shown in the Unified
Namespace and for which the Display in the filter
designer option is enabled.

b. From the additional menus, select the object attributes for the condition.
All other controls are operators and properties that you require to formulate
the condition. You can only select one entry from the drop-down menu. You can
select more entries from extended drop-down menus, where the properties are
displayed hierarchically and then added to the condition using an "or" operator.
You may enter text directly into input fields. Pop-up menus and input fields are
shown and hidden dynamically.
c. To insert another condition, click
an AND link.
d. To delete a condition, click

. All partial conditions are linked by

.

e. To the preview window, click
are displayed.

. All objects determined by the condition

Entering custom filter conditions
At certain points you can define custom filter conditions. The filter conditions are
formulated like a condition (WHERE clause) for a database query.
You can enter database queries directly or put them together with a wizard. Use the
buttons to switch to the relevant view.
l

and

The comparison operators =, <>, <, >, <=, >=, and like are supported for defining
conditions.

l

To link condition you can use the logical operators AND, OR, and NOT.

l

You can use variables in your condition definitions. Variable must be masked.
Syntax: '$<variable>$'
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NOTE: If the condition contains a dollar sign, which is not labeling a variable, it
must be masked with $.
Example: '300 $$' compared to the value '300 $'
TIP: If you enter a condition directly, you can access predefined variables with
the
button.
Each condition is displayed in a special control in the wizard. The controls contain
connection points to logically join single conditions or delete single conditions. The
connection points are set if you mouse over the edge of the respective control.
Figure 18: Wizard for entering filters

To create a filter with a wizard
1. Click Create condition.
This inserts a control for the first condition.
2. Enter the condition.
a. Click the left-hand part of the condition and select the property to filter by.
The properties for filtering are listed in the menu. You can also define other
properties and use variables.
b. Specify the comparison operator. Click the comparison operator to change it.
The comparison operators =, <>, <, >, <=, >=, and like are supported for
defining conditions.
c. Specify the comparison value on the right-hand side of the condition.
You can enter a string for a comparison value or select a property from the list.
You can also use variables.
NOTE: To switch back to the input field again, select Input field from
the menu.
3. To link condition you can use the logical operators AND, OR, and NOT.
a. Mouse over the edge of the control to which you wish to create a link.
The connection points appear.
b. Mouse over a connection point and select the connection.
This adds a new control for the next condition.
NOTE: To remove a control, select the Delete connection point.
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Selecting from lists
Use the menu to select an element.
NOTE: You can add to some menus, in which case an entry selection appears in the list.
The extended menu links to elements from a different database table. To better display
your hierarchical structures, from this menu you can select from hierarchy trees as well as
flat structures.
Figure 19: Extended menus

To select a value form an extended menu
1. Open the menu by clicking the arrow.
2. Enable or disable an entry using a single click and close the menu.
- OR Enable or disable an entry by double-clicking.
The menu closes automatically.
TIP: As you enter text in the input field, the system filters the selection data for you.
When you open the menu you can see the entries that contain the text you entered. If the
entered text is unique, you can also select the relevant entry using the tab.
To search in the menu
1. Click the magnifying glass in the menu title bar to open the search dialog.
2. Enter your search term.
3. Set the option Case sensitive if required.
4. Start the search with the Search or Enter button.
5. Use F3 to continue searching.
6. End the search with Esc.
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Selecting a dynamic entry
Some foreign key relationships are identified dynamically in One Identity Manager. There
are two steps to selecting a dynamic foreign key.
1. Specify the table in which the object should be identified.
2. Select the actual object.
Figure 20: Selecting dynamic entries

To specify a dynamic entry:
1. Click

next to the field.

2. Under Table, select in the table in which to identify the object.
3. Select the actual object from the next list.
4. Click OK.

Setting a date
As well as manually entering a date, you can copy a date into the input field from the
control. Open the control using the [...] button beside a date input field.
Figure 21: Control for setting a date

The title bar of the control repeats the name of the corresponding input field.
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To select a date:
1. Today's date is identified by a colored border. Click Today to select today's date.
- OR Select the date using the calendar.
a. Select the month and year using the arrow beside the Month year control or
click the Month year control.
b. Select the day by clicking in the calendar.
2. Click OK.

Editing login hours
This control is used, for example, to configure the daily login hours for a user account.
Figure 22: Login time control

The calendar shows a 7-day week, each box represents one hour. The configured login
times are shown in color, respectively. If a box is filled, login is allowed. If the box is
empty, login is denied.
To specify login times
l

Select a time period with the mouse or keyboard.

l

Select Assign to enable login in the selected period.

l

Select Remove to deny login in the selected period.

l

Select Reverse to invert the selected period.

l

Use the arrow keys to reset or repeat a selection.

Layout of object relations
This control element shows the relations between the One Identity Manager database
objects (Parent/ChildRelation).
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l

Only the assigned elements are displayed in the Remove assignments pane.
You can remove assigned elements here.

l

In the Add assignments pane, you can see all the elements.
Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.

To activate or deactivate an assignment
l

Use the control's context menu.
- OR -

l

Double-click an entry.

Figure 23: Displaying assignments in the control element
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Table 28: Meaning of icons in the control element
Icon

Meaning
Object is assigned to the selected base object.
Object is not assigned to an object.
Object is assigned to another object.

NOTE: In the list, assigned elements come before unassigned elements.
Table 29: Control element context menu items
Entry

Meaning

Assign

Assign object to the selected base object.

Remove

Remove assignment of object to base object.

Assign child objects

In a hierarchical structure, assign the selected object and its
child objects to the base object.

Remove child objects

In a hierarchical structure, remove the assignments of the
selected object and its child object to the base object.

Assign all objects

Assign all existing objects to the base object.

Remove all assignments

Remove all assignments to the base object.

Search

Opens the search dialog.

Go to object

Go to the selected object.

Go to assigned object

Go to this object's assigned base object.

Show objects already
Objects that are assigned to other objects are shown in the
assigned to other objects. Add assignments pane.
Hide objects already
Objects that are assigned to other objects are hidden in the
assigned to other objects. Add assignments pane.

Displaying assignments
The membership tree shows the direct and indirect assignments to a base object. It also
shows the source of the indirectly assigned objects. This means that the object was
assigned to a base object through a dynamic role, for example, or through inheritance.
l

l

Only the assigned elements are displayed in the Remove assignments pane. You
can remove the assignments here.
Under Add assignments you can see all the elements.
Make new assignments or remove existing ones here. If allowed, you can use a filter
to further restrict the selection of elements you want to show.
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NOTE: Objects marked for deletion and outstanding objects are struck through on the
overview form.
To activate or deactivate an assignment
l

Use the control's context menu.
- OR -

l

Double-click an entry.

Figure 24: Displaying assignments

Table 30: Meaning of icons in the membership tree
Icon Meaning
Object is assigned directly to the selected base object.
Object is assigned indirectly to the selected base object.
Object is assigned directly and indirectly to the selected base object.
Object is not assigned to a base object.
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Icon Meaning
Inheritance interruption. Only when objects are assigned in hierarchical structures.
Indirect assignment.
Assignment through dynamic roles.
Assignment not yet effective. The DBQueue Processor has not yet calculated the
assignment.
The change in value is planned for a specific date and time.
NOTE: The list displays assigned elements before unassigned elements.
Table 31: Entries in the membership tree context menu
Entry

Meaning

Assign

Directly assign the selected object to the base object.

Remove

Remove the assignment of the selected object to the base object.

Assign child
objects

In a hierarchical structure, assign the selected object and its child objects
to the base object.

Remove
In a hierarchical structure, remove the assignments of the selected object
child objects and its child object to the base object.
Assign all
objects

Directly assign all existing objects to the base object.

Remove all
Remove all direct assignments to the base object.
assignments
Search

Opens the search dialog.

Go to object

Go to the selected object.

Extended
properties

Switches to the detailed form for the selected object, where you can make
additional assignments. A prerequisite for this is that the selected object is
assigned and this assignment has been saved.

NOTE: Use the Search function to search the entire assignment tree for the occurrence
of specific texts. The search sequence does not follow the displayed hierarchical
structure of the tree, but instead the internal structures of the control element. As such,
the search seems to jump through the tree at random. All records are searched to find
the requested object.
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General control key combinations
Table 32: General control key combinations
Shortcut

Action

Tab, shift + tab, left arrow key, right arrow key, down
arrow, up arrow

Move within the controls.

Down arrow, up arrow, page down key, page up key,
home, end

Move in lists and in hierarchical
structures.

<+> or right arrow key

Open hierarchy level.

<-> or left arrow key

Close hierarchy level.

Space or Enter

Select an entry.

Shift + Return.

Select multiple entries.

F4 or Alt + down arrow

Open selection list.

Del

Remove entry from the list.

Manager program settings
General configuration settings are specified in the Manager.exe.config configuration file.
Valid global configuration settings can also be defined through the global configuration file
Global.cfg in One Identity Manager's own format. The configuration files are stored in the
program directory. For more information, see the One Identity Manager Process Monitoring
and Troubleshooting Guide.
To change the program settings in the Manager
l

In the Manager, select the Database > Settings menu item.

Detailed information about this topic
l

User settings in the Manager on page 56

l

Special settings for individual program components in the Manager on page 57

l

General program settings in the Manager on page 58

l

Plugins available in the Manager on page 59
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User settings in the Manager
On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.

General
l

l

l

l

l

Show balloon tips: Specifies whether speech bubbles, which provide information
about program functionality, are shown in the program.
Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.
Show additional icons: Specifies whether icons are shown in the task list in
addition to the descriptions.
Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.
Use technical display values: Specifies whether display names or technical
names are used when collating data exports.

Behavior
l

Enable quick edit mode: Specifies whether quick editing is enabled.
By default, an object‘s overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

l

l

Enable expert mode: Specifies whether expert mode is used. Setting this option
switches the program from standard view mode to advanced mode.
Enable list limit: Specifies whether the number of elements shown in the result list
and list items in controls should be limited.
If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.

l

Use system settings: Specifies whether the system settings should be used for the
list limit.
If this option is activated, then the global system settings from the Common |
DBConnection | ListLimit parameter is used. If the number of results is greater
than the defined number, a filter dialog opens.

l

Objects: Personal setting for the object list limit. If the number of results is greater
than the defined number, a filter dialog opens.
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Usage
l

l

l

Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.
Show recently used objects: Specify whether or not the most recently used
objects are displayed. If this option is set, the objects used last are shown in a
separate node in the result list.
Object type count: This number specifies how many objects per object type are
shown per menu entry when the option Show recently used objects is enabled.

After starting
l

Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

Related topics
l

Manager program settings on page 55

l

Layout mode in the Manager on page 20

l

Limiting list entries using the list limit on page 60

Special settings for individual program
components in the Manager
On the Features tab, you can create special program settings for individual program
components. The settings are stored in the One Identity Manager database user account
configuration.

Simple search
l

Default search operator: Search operator to be used by default for simple
searches. Permitted values are starts with, contains or equals.

Process information
The settings in the Process information area relate to the process view and are visible
only when this functionality has been activated. For detailed information about the
evaluation of process information, see the One Identity Manager Operational Guide.
l

Display complexity: Set the display range. Permitted values are:
l

Activities: Activity information (top hierarchy level) is shown.

l

Details: Information about activities and their details is shown.
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l

l

Single step details: Set the depth of detailed information shown for individual
steps. Permitted values are:
l

l

l

l

l

Single steps: Information about activities, details, and individual steps at the
selected depth is shown.

Basic information: Individual steps with a detail depth of basic
information are shown.
Extended information: Single steps with a detail depth of basic
information and extended information are shown.
Complete information: Single steps with a detail depth of Basic
information, Supplementary information, and Complete information
are shown (technical view).

Show whole tree: If this option is activated, the entire hierarchy tree automatically
opens when the process view is loading. If this option is deactivated, the hierarchy
tree is not opened when the process view is loaded.
Show selected process automatically: If this option is activated, the entire
hierarchy tree automatically opened when a process is selected. If this option is
deactivated, the hierarchy tree is not opened when a process is selected.

Related topics
l

Manager program settings on page 55

General program settings in the Manager
On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings
l

l

Language: Language used for formatting data, such as date formats, time formats,
and number formats.
Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Miscellaneous
l

l

Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.
Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.
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NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

Related topics
l

Manager program settings on page 55

l

Detailed information about the user interface on page 59

Plugins available in the Manager
The Plugins tab shows the available program plugins with a short description of
their features.
To enable or disable a plugin in the Manager
l

Double-click the plugin name.

NOTE: You can choose more plugins in the Manager menu by clicking Plugins.

Related topics
l

Manager program settings on page 55

Reloading changes to the user interface
In the status bar, the

icon indicates that the user interface was modified.

To reload modifications to the system data
1. In the status bar, double-click the icon

.

2. Enable the Restore user interface option. After loading the modifications, the
system then navigates back to the point in the interface that you were
previously using.
3. Click Yes.

Detailed information about the user
interface
You will usually need to display more information about individual interface elements, such
as menu entries or forms, only if the program's user interface is edited.
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To display detailed information
1. Select the Database > Settings menu item.
2. On the Program tab, enable the Show additional navigation information
option.
NOTE: The option is not saved permanently. It has to be reset when the
program is started.
The following information appears:
l

Manager shows the form name in the status bar. It displays in the following format:
<logical form> [(<physical form>)]
TIP: Double-click the form name to copy the name to the clipboard.

l

l

l

In the Manager, the Show system data entry is displayed in the menu bar in the
View menu. This opens a form that lists detailed information about the loaded menu
items, forms, and form definitions.
In the Manager, in expert mode, the Definition context menu entry is displayed in
addition in the navigation view. This shows advanced technical information about
configuring a menu item.
If menu entries or tasks are linked to preprocessor-relevant configuration
parameters, the preprocessor conditions are shown behind the menu items and
tasks.

Related topics
l

Expert mode in the Manager on page 20

l

Manager program settings on page 55

Limiting list entries using the list limit
Table 33: Configuration parameter for limiting results
Configuration
parameter

Effect

Common | DBConnection | ListLimit

This configuration parameter specifies the number of list entries
above which the filter request becomes effective

Common | DBConnection |
WebListLimit

This configuration parameter specifies the number of list entries
above which the filter request in the web front becomes effective.

You can use a list limit to limit the number of elements displayed in a result list and in the
control elements with list values (for example, menus). If the number of results exceeds
the limit, a filter dialog opens.
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In the Designer, you can globally define the maximum number of entries displayed before
the filter dialog is opened in the Common | DBConnection | ListLimit configuration
parameter. In addition, the current user can use the system setting or enter their own
limit. The personal limit overwrites the global value in the configuration parameter.
To use the system settings
1. Select the Database > Settings menu item.
2. On the User tab in the Behavior pane, enable the Enable list limit and Use
system settings options.
This setting applies the global value defined in the Common | DBConnection |
ListLimit configuration parameter.
To use a personal limit
1. Select the Database > Settings menu item.
2. On the User tab in the Behavior pane, enable the Enable list limit.
3. On the User tab in the Behavior pane, disable the Use system settings option and
enter the number of objects in Objects.

Related topics
l

Limiting list sizes using simple filters on page 61

l

User-defined filters in the Manager on page 63

l

Searching for list entries on page 62

l

Database search in the Manager on page 70

Limiting list sizes using simple filters
You can use the filter dialog to limit the entries in a list though defined filter criteria. A filter
remains in use until you reset it. Settings in the filter dialog are saved in the user
configuration.
If you want to start certain search queries more frequently, create search queries for the
advanced database search or create user-defined filters.
To limit a result set
1. In Filter condition, enter the text to use as a basis for filtering. Use of * as wild
cards is permitted. Case sensitivity is not taken into account.
2. In Apply to, enable the properties to which the filter condition is to be applied.
3. If you only want lists to show objects that meet the filter condition and are already
assigned to the base object, enable the Only show current assignment option.
NOTE: This option is only available for lists with object assignments.
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4. Click Apply.
NOTE: To display all objects, click Show all. The filter condition is not applied
in this case.

Example:
This filter condition is used to search for all parts of an employee’s full name. This is
put together in the following manner:
Full name
Last name, first name
Example:
Miller, Max
Miller-Mayer, Max
Macmiller, Max
Filter
condition

Description

Find, according to
example

Miller or
*Miller*

Finds all employees whose full name contains Miller, Max
the string Miller.
Miller-Mayer, Max
Macmiller, Max

Miller*

*Miller

Finds all employees whose full name begins
with the Miller.

Miller, Max

Finds all employees whose full name ends
with the Miller.

No entry

Miller-Mayer, Max

Related topics
l

Limiting list entries using the list limit on page 60

l

Searching for list entries on page 62

l

User-defined filters in the Manager on page 63

l

Database search in the Manager on page 70

Searching for list entries
Use the search dialog to search for entries within a list.
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To search in a list
1. Open the search dialog from the Search context menu, by clicking the
the shortcut Ctrl + F.

icon or with

2. Enter the Search term or select a previous one from the list using the arrow button.
3. Set the Case sensitive option if required.
4. Start the search with the Search or Enter button.
5. Use F3 to continue searching.
6. End the search with Esc.
Table 34: Shortcuts for the search dialog box
Shortcut

Action

Ctrl + F

Open search dialog.

Data

Start search.

Esc

End search.

F3

Search next.

For a wider ranging search, use the database search function.

Related topics
l

Database search in the Manager on page 70

User-defined filters in the Manager
You make use of user-defined filters if you wish to run specific search queries frequently.
You can create your own (private) filters or public filters.
User-defined filters allow you to run the following searches:
l

l

l

Searching for a search term with placeholders within the display values of the
selected object definition
Searching entries with a SQL condition
Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Detailed information about this topic
l

Creating filter queries using wildcards in the Manager on page 64

l

Creating filter queries in the Manager using SQL conditions on page 65

l

Creating filter queries using full-text search in the Manager on page 66

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
One Identity Manager tools user interface

63

l

Applying filters in the Manager on page 67

l

Publishing filters in the Manager on page 67

l

Exporting and importing filters in the Manager on page 68

l

Attaching filters in the Manager on page 68

l

Editing filters in the Manager on page 69

Creating filter queries using wildcards in
the Manager
A search query using placeholders searches for the search pattern in the display values of
the selected object definition.
To create a filter query using placeholders in the Manager
1. In the Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. In the Define a filter dialog, select the Wildcard filter method.
4. In the Filter parameter pane, enter the following information.
l

l

Filter objects of: Select the object definition in which to perform the search.
Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.
Examples:
Pattern* - searches for all entries whose display value starts with the
Pattern string
*Pattern - searches for all entries whose display value ends with the
Pattern string
*Pattern* - searches for all entries whose display value contains the
Pattern string
Pattern - searches for all entries whose display value matches the
Pattern string

5. (Optional) If required, specify the following settings in the Optional
parameter pane.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.
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7. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
8. To save the filter, click Save.

Related topics
l

Creating filter queries in the Manager using SQL conditions on page 65

l

Creating filter queries using full-text search in the Manager on page 66

l

Publishing filters in the Manager on page 67

Creating filter queries in the Manager using
SQL conditions
A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.
To create a filter query using a SQL condition in the Manager
1. In the Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. In the Define a filter dialog, select the SQL filter method.
4. In the Filter parameter pane, enter the following information.
l

l

Filter objects of: Select the object definition in which to perform the search.
Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
directly or compile the database queries with a wizard. Use the Expert view
or Simple view button to switch to the appropriate view.

5. (Optional) If required, specify the following settings in the Optional
parameter section.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.
7. (Optional) To make the filer available to all users
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a. Click Publish.
b. Confirm the security prompt with Yes.
8. To save the filter, click Save.

Related topics
l

Creating filter queries using wildcards in the Manager on page 64

l

Creating filter queries using full-text search in the Manager on page 66

l

Publishing filters in the Manager on page 67

Creating filter queries using full-text search
in the Manager
NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.
A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.
To create a filter query in the Manager using the full-text search
1. In the Manager, select the My One Identity Manager > Filters category.
2. Select the New filter context menu item.
3. In the Define a filter dialog, select the Full text filter method.
4. In the Filter parameter pane, enter the following information.
l

l

Filter objects of: Select the object definition in which to perform the search.
Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. (Optional) If required, specify the following settings in the Optional
parameter section.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. In the Save filter section, enter a name and description for the search filter.
7. (Optional) To make the filer available to all users
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a. Click Publish.
b. Confirm the security prompt with Yes.
8. To save the filter, click Save.

Related topics
l

Creating filter queries using wildcards in the Manager on page 64

l

Creating filter queries in the Manager using SQL conditions on page 65

l

Publishing filters in the Manager on page 67

Applying filters in the Manager
To use a filter in the Manager
l

In the Manager, select the filter in the My One Identity Manager >
Filters category.

Related topics
l

Advanced database search on page 72

Publishing filters in the Manager
NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).
You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.
To publish a filter in the Manager
1. In the Manager, select the filter in the My One Identity Manager >
Filters category.
2. Select the Edit filter context menu item.
3. Click Publish.
4. Confirm the security prompt with Yes.
5. Click Save.

Related topics
l

Creating filter queries using wildcards in the Manager on page 64

l

Creating filter queries in the Manager using SQL conditions on page 65
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l

Creating filter queries using full-text search in the Manager on page 66

l

Exporting and importing filters in the Manager on page 68

Exporting and importing filters in the
Manager
To make custom filters available to other users, you can export and import them.
To export a filter in the Manager
1. In the Manager, select the filter in the My One Identity Manager >
Filters category.
2. Start the export using the Export filter context menu.
3. Using the file browser, select the directory path for the report and enter a file name
for the filter.
4. Click Save.
The filter file (*.xml) is generated.
To import a filter in the Manager
1. In the Manager, select the My One Identity Manager > Filters category.
2. Start the export using the Import filter context menu.
3. Select the filter file from the file browser.
4. Click Open.

Related topics
l

Attaching filters in the Manager on page 68

l

Publishing filters in the Manager on page 67

Attaching filters in the Manager
You can attach filters to various categories so you can quickly access the filtered objects.
To attach a filter in the Manager
1. In the Manager, select the filter in the My One Identity Manager >
Filters category.
2. Select the Attach context menu.
3. Select one or multiple menu categories to attach the filter to.
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When you select a category with an attached filter in the navigation view, all objects that
correspond to the filter are displayed on a separate form page. The following functions
are available:
l

l

Double-click an entry on this form page to switch to the corresponding object. The
first available form is opened.
Open the export form using the Export data task or click Export data on the
context menu. The filter condition of the attached filter is already applied as an
export condition. For detailed information about exporting data, see the One Identity
Manager Operational Guide.

Editing filters in the Manager
NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).
To edit a filter in the Manager
1. In the Manager, select the filter in the My One Identity Manager >
Filters category.
2. Select the Edit filter context menu item.
3. Edit the filter settings in the Define a filter dialog.
4. Click Save.

Related topics
l

Creating filter queries using wildcards in the Manager on page 64

l

Creating filter queries in the Manager using SQL conditions on page 65

l

Creating filter queries using full-text search in the Manager on page 66

Deleting filters in the Manager
NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).
To delete a filter in the Manager
1. In the Manager, select the filter in the My One Identity Manager >
Filters category.
2. Select the Remove filter context menu item.
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Database search in the Manager
In the Manager, you can run a simple database search or an advanced database search.
Run a simple database search once. You cannot save a simple database search. Use an
advanced database search if you wish to run specific search queries frequently. You can
save the search query.

Detailed information about this topic
l

Simple database search on page 70

l

Advanced database search on page 72

Simple database search
The simple database search allows you to run the following searches:
l

l

Searching for a search term with placeholders within the display values of the
selected object definition
Searching for a search term across all columns of an object definition that are
indexed for the full-text search

Detailed information about this topic
l

Running simple database searches using wildcards on page 70

l

Running simple database searches using full-text search on page 71

Running simple database searches using
wildcards
A search query using placeholders searches for the search pattern in the display values of
the selected object definition.
To run a simple database search in the Manager with placeholders
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. Enter the following information in the Search section.
a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.
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b. Search text: Enter the search term. You can use * as a wildcard. Case
sensitivity is not taken into account.
Examples:
Pattern or pattern* - searches for all entries whose display value starts with
the Pattern string
*Pattern - searches for all entries whose display value ends with the
Pattern string
*Pattern* - searches for all entries whose display value contains the
Pattern string
c. Full-text search: Disable the option.
3. Start the search using the Search button.
TIP: Press

to set the current query as the default for future search queries.

Related topics
l

Running simple database searches using full-text search on page 71

Running simple database searches using fulltext search
NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.
A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.
To run a simple database search in the Manager as a full-text search
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. Enter the following information in the Search section.
a. Search in: Select the object definition. All object definitions in the currently
selected category are displayed.
b. Search text: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.
c. Full-text search: enable the option.
3. Start the search using the Search button.
TIP: Press

to set the current query as the default for future search queries.
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Related topics
l

Running simple database searches using wildcards on page 70

Advanced database search
The advanced database search allows you to run the following searches:
l

l

l

Searching for a search term with placeholders within the display values of the
selected object definition
Searching entries with a SQL condition
Searching for a search term across all columns of an object definition that are
indexed for the full-text search

TIP: The saved search queries are displayed in the Manager in the My One Identity
Manager > Filters category. You can run or edit the search queries there or export
them for other users.

Detailed information about this topic
l

Creating search queries using wildcards on page 72

l

Creating search queries using SQL conditions on page 73

l

Creating search queries using full-text search on page 74

l

Running advanced database searches on page 76

l

User-defined filters in the Manager on page 63

Creating search queries using wildcards
A search query using wildcards searches for the search pattern in the display values of the
selected object definition.
To create a filter query using wildcards in the Manager
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. To open the advanced database search, click the Advanced button in the
Search section.
3. Click New search and select the Wildcard search method.
4. In the Search parameter pane, enter the following information.

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
One Identity Manager tools user interface

72

l

l

Search in: Select the object definition in which to perform the search.
Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.
Examples:
Pattern* - searches for all entries whose display value starts with the
Pattern string
*Pattern - searches for all entries whose display value ends with the
Pattern string
*Pattern* - searches for all entries whose display value contains the
Pattern string
Pattern - searches for all entries whose display value matches the
Pattern string

5. (Optional) If required, specify the following settings in the Optional
parameter pane.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search pane and click Save.

Creating search queries using SQL conditions
A search query with an SQL condition searches all entries of the selected object definition
that match the SQL condition.
To create a filter query using an SQL condition in the Manager
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. To open the advanced database search, click the Advanced button in the
Search section.
3. Click New search and select the SQL search method.
4. In the Search parameter pane, enter the following information.
l

l

Search in: Select the object definition in which to perform the search.
Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as an SQL query
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directly or compile the database queries with a wizard. Use the Expert view
or Simple view button to switch to the appropriate view.
5. (Optional) If required, specify the following settings in the Optional
parameter section.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.

6. To save the search, enter a name and a description for the search filter in the Save
search section and click Save.

Creating search queries using full-text search
NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.
A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.
To create a search query in the Manager using the full-text search
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. To open the advanced database search, click the Advanced button in the
Search area.
3. Click New search and select the Full text search method.
4. In the Search parameter pane, enter the following information.
l

l

Search in: Select the object definition in which to perform the search.
Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. (Optional) If required, specify the following settings in the Optional
parameter area.
l

l

Sort criteria: Specify the properties (columns) by which to sort the search
result. Click
to show all available properties according to the object
definition. Click on a name to transfer the entry to the input field.
Display template: Specify the format in which the results are displayed.
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Click
to show all available properties according to the object definition. Click
on a name to transfer the entry to the input field.
6. To save the search, enter a name and a description for the search filter in the Save
search area and click Save.

Rules and examples for the full-text search
Table 35: Rules with examples for searching
Example Description
John Doe

Finds John Doe but not John Donut.
Search results must contain all of the separate terms in the query. A logical
AND is used.

John OR
Doe

Finds Jane Doe and John Donut.

John NOT
Doe

Finds John but not John Doe.

J*

Finds John and Joanna.

Placing OR between the search terms, acts as a logical OR operator. The
result of this search contain at least one of the two search terms.

The results of this search do not contain the term that comes after NOT.

The * functions as a wildcard for any number of characters to complete the
term.
Do?

Finds Doe but not Donut.
The ? functions as a wildcard for a single character to complete the term.

"John
Doe"

Provides results in which the search terms John and Doe follow one another.

John
Doe~

Finds Jon Does but also other similar results. A tilde ~ after the search term
indicates that the search should also find similar results. The means that
incorrectly spelled terms can be found as well.

Results of this search contain the string in quotes as phrase.

You can specify the level of similarity by adding a number between 0 and 1
(with decimal point) after the tilde ~. The higher the number, the more
similar the results.
During the search, the search strings are broken down into tokens by the search index in
use. The search terms are compared with these tokens.
Use the Common | Indexing | IndexNonTokenChars configuration parameter to
specify which delimiters are to be used. The configuration parameter can be extended if
certain characters in the search text have linking function.
If the Common | Indexing | IndexUseLegacyAnalyzer configuration parameter is
enabled, alternative tokenizing is performed also. The alternative method of tokenizing is
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preferable for long tokens. For example, if the string Department_01 is a token, the
partial string Department is not considered to be a token.
The following tokens are named.
Table 36: Tokens for alternative tokenizing
Token

Description with example

Words

Sequence of letters and/or numbers

Enumeration

Words linked by punctuation marks (_-/.,) of which at least every second
one contains a number.
An example is Department_01.
Sequences are also decimal numbers and IP addresses.

Email
addresses

An email address is often made up of first name, last name, company
name and generic top-level domain (for example .com). The order or
spelling of the first and last names may vary (for example, use of
initials). The special character @ and the punctuation mark (.) not only
separate each part of the email address but also links them so that
Examples of email addresses are Ben.King@example.com and
C.Harris@example.com.

Host names

For example website.example.com.

Acronym

For example U. S. A.

Apostrophe

For example O'Reilly.

@, &
surrounded
by letters

For example Me&you.

Umlauts such
as ä, ö, ü

For example Max Müller.

NOTE: Changing the configuration parameter means rebuilding the search index, which
may take some time.

Running advanced database searches
To run an advanced database search in the Manager
1. In the Manager, select the View > Database search menu item.
The database search is displayed in the navigation view.
2. To open the advanced database search, click the Advanced button in the
Search section.

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
One Identity Manager tools user interface

76

3. Double-click the search filter in the Saved filters area.
4. Start the search using the Search button.
TIP: The saved search queries are shown in the My One Identity Manager > Filters
category. You can run or edit the search queries there or export them for other users.

Related topics
l

User-defined filters in the Manager on page 63

Displaying extended properties for
objects
NOTE: The Manager must be running in expert mode to show object properties.
To show extended object properties
l

Select the object and open the Properties item in the context menu.
l

On General, you can see the object‘s general properties, for example, ID,
status, or primary key.
TIP: The primary key can be copied in different formats. To do this, click the
Primary key or the Table relations caption.

l

All the object columns are displayed in a grid on Properties with their values.
You can choose between a simple column view and the advanced view with
additional data for column definitions.
Individual properties can be highlighted with an icon.
To customize the display properties
l

l

On the Properties tab, select the
required display properties.

Property pages icon and set the

On the Permissions tab, based on the permissions groups, you see what
permissions apply to an object. The first entry shows the basic permissions for
the table. The permissions for this particular object are displayed beneath that.
The other entries show the column permissions.
TIP: Double-click the table entry, the object entry, or a column entry to
display the permissions group from which the permissions were determined.
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Table 37: Icon used for permissions
Icon

Meaning
Permissions exist.
Permissions have been removed by the object layer
Permissions limited by conditions.

l

l

You can see which change labels the object belongs to on the Change labels
tag. Here you can assign a new or an existing change label to the object and its
dependent objects. For more information about working with change labels,
see the One Identity Manager Operational Guide.
On the Export tab, you can export the object in the One Identity Managerinternal transfer format.

Related topics
l

Expert mode in the Manager on page 20

Multiple object edit in the Manager
It is possible to edit more than one object of the same object type at the same time in the
Manager. The form tab of the main data form shows the number of selected objects and the
object type. Input fields with different values are labeled with the
icon. When you edit an
input field and save your changes, the change applies to all open objects.
To edit multiple objects at the same time:
1. Use Shift + selection or Ctrl + selection to select the objects in the result list.
2. Open the main data form either with Enter, clicking the
icon in the result list, or
selecting Tasks > Edit main data in the context menu.

Committing data on change conflicts
If two users change the same object at the same time, this can cause conflicts when
the object is saved, especially if the same property is changed. In this case, a dialog
box appears when you save the object. You can use this dialog box to view and apply
the changes.
All changes to the object that caused a conflict are shown.
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Figure 25: Display of change conflicts

To apply your changes:
l

Active the check box in the Apply column for your values that you wish to save.

Table 38: About change conflicts
Column

Description

Property

Property of the object that triggered a change conflict.

Your change

Value of the property you entered and wish to save.

Change made by
other user

Value of the property that had already been saved by the other user.

Apply?

Specify if your value should be applied.
To apply your value, select the check box. Otherwise the system
keeps the value saved by the other user.

Result

Current property value.
If you activate the check box in the Apply column, the value you
entered is displayed.
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3

Working with the Designer
The interfaces of the Manager and Designer have a similar layout. You can find
detailed information about the basic features under One Identity Manager tools user
interface on page 9.
The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the Designer, the available
editors are displayed together with the tasks that can be run in the task view.

General tips for the Designer
During the startup process the Designer fills an internal database. SQLite is used for the
database system. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.
Depending on the program’s configuration, the internal database is either loaded into main
memory or copied to the hard drive of the workstation. To avoid data inconsistencies, only
one instance of the program should be started per database. If the database from the first
instance is copied to hard disk then the databases for all other instances are loaded into
main memory.
All changes to objects in the program are made in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are recorded in a change log. If the internal database is stored on the
hard drive, all additional changes are also logged to this database. This means that you can
restore to the last working state after connecting to the database if the program crashes.
When the data is transferred all recorded changes are made to the One Identity Manager
database. This is done at object level so that, for example, processes are generated and
formatting rules are observed. The principle "last writer wins" applies here as opposed to
the previous object processing. That means that changes have been made by a user to
object properties in the mean time are overwritten.
Depending on the program settings, the internal database is deleted from the hard drive
when the program has finished. This means that all the data has to be loaded from the One
Identity Manager database when the program is restarted. If the internal database is not
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deleted when the program finishes, the next program start up can be accelerated because
only changes from the One Identity Manager that is connected have to be loaded.

Menu items in the Designer
Table 39: Meaning of items in the menu bar
Menu

Menu item

Meaning

Shortcut

Establishes a database connection.

Ctrl +
Shift + N

Save to
database

Displays the change log. Changes to the data can
be saved to the One Identity Manager database.

Ctrl +
Shift + S

Reload data

Data is reloaded from the One Identity Manager
database.

Compile
database

Starts the Database Compiler.

Change
management

Opens a dialog box for editing change labels.

Check data
consistency

Opens the Consistency Editor.

Start SQL
editor

Starts the SQL editor.

Change
password

Changes current user’s password.

Settings

For configuring program settings.

Exit

Exits the program.

Database New
connection

For detailed information about compiling the
database, see the One Identity Manager
Operational Guide.

Ctrl +
Shift+ B

For detailed information about working with
change labels, see the One Identity Manager
Operational Guide.

For detailed information on checking data
consistency, see the One Identity Manager
Operational Guide.

Alt + F4
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Menu

Menu item

Meaning

Shortcut

View

Navigation

Activates the navigation view.

Ctrl + Q

Tasks

Shows or hides the task view.

Ctrl + T

Error log

Shows or hides the error log.

Ctrl + E

Object import

Shows or hides the view for importing objects.

Ctrl + I

Search

Shows or hides the search dialog box.

Ctrl +
Shift +F

Close current
document

Closes the current document.

Close all
documents

Closes all documents that are open in the
document view.

Activate
document

Shows all open documents in a selection list.

Layout

Restores the default layout of the program’s
graphical interface. You can save layouts and load
them again.

Enable quick
edit mode

The quick edit mode is enabled or disabled.

Community

Opens the One Identity Manager community
website.

Support portal

Opens the One Identity Manager product support
website.

Training

Opens the One Identity Manager training portal
website.

Help

Online
Opens the One Identity Manager documentation
documentation website.
Search

Opens the search dialog box.

Help for the
Designer

Opens program help.

transport
history

Display a chronological list of migration, imports,
and exports of transport packages.

Info

Shows the version information for program.

F1

NOTE: Specific help information is available for
each editor.
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Table 40: Functions in the standard toolbar
Icon Meaning
Saves changes to the One Identity Manager database.
Shows the previous object in the order that the forms were viewed (object
history).
Shows next object in the order they have already been viewed (object history).
Database column help. Clicking on the help icon changes the cursor into the help
icon. Then when you click on a column description, tips for using the column are
displayed in the form of tooltips.
Prints the edit view. Printer settings are configured in the configuration menus.

Using the help in the Designer
You can access One Identity Manager documentation in the Designer by selecting the Help
> Search in local help menu item.
You can open the general help for Designer from the Help menu or by selecting F1. The
Help menu offers specific help information for each editor.
In addition, a Designer help is available for individual properties of the currently
displayed object. Clicking on the help icon
changes the cursor into the help icon. Then
when you click on a column description, tips for using the column are displayed in the
form of tooltips.

Views in the Designer
The following views are displayed in the Designer: There are several editors used
for editing data. Their functionality and methods are tailored to the different
configuration tasks.
Table 41: Designer views
View

Description

Navigation The navigation structure of the user interface is hierarchical and allows users
view
to drill down to the selection of an object definition. The top level of the
hierarchy is used to classify One Identity Manager data into specified categories.
Document
view

Overview forms and selected editors are displayed in the document view.
When an object is selected in the navigation view, the corresponding
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View

Description
overview form is displayed.
TIP: If quick edit is enabled, you skip the overview and go straight to the
first editor available for the object.

Task view

When you select an object in the navigation view, the available editors are
displayed together with the tasks that can be run. The relevant editor is
opened in the document view when the object is selected.

Change
log

Changes made by the user are recorded in the change log.

Error log

The program’s error log displays all warnings and error messages that have
occurred since the program started up. When the Designer restarts, the
error log is reinstalled. For detailed information about the error log, see the
One Identity Manager Process Monitoring and Troubleshooting Guide.

Change
label

In this view, change labels are created and edited. For detailed information
about working with change labels, see the One Identity Manager Operational
Guide.

Related topics
l

The editors in the Designer on page 95

l

Logging and committing objects in the Designer on page 87

Designer program settings
General configuration settings are specified in a configuration file Designer.exe.config.
Valid global configuration settings can also be defined through the global configuration file
Global.cfg in One Identity Manager's own format. The configuration files are stored in the
program directory. For detailed information, see the One Identity Manager Process
Monitoring and Troubleshooting Guide.
To change the program settings in the Designer
l

In the Designer, select the Database > Settings menu item.

Related topics
l

General tips for the Designer on page 80

l

User settings in the Designer on page 85

l

General program settings in the Designer on page 86
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User settings in the Designer
On the User tab, configure your user-specific program settings. These settings are stored
in the One Identity Manager database user configuration.

General
l

l

l

l

l

Show balloon tips: Specifies whether speech bubbles, which provide information
about program functionality, are shown in the program.
Show large images in navigation panes: Specifies whether smaller or larger
icons are displayed on the categories.
Show additional icons: Specifies whether icons are shown in the task list in
addition to the descriptions.
Use single clicks: Specifies whether objects are loaded with a single click or by
double-clicking.
Show additional navigation information: If this option is activated, additional
information is shown for individual interface components.
NOTE: The option is not saved permanently. It has to be reset each time the
program is started.

After starting
l

Visible root nodes: The number of categories to be displayed initially in the
navigation view. Changes become effective after a restart.

Behavior
l

Enable quick edit mode: Specifies whether quick editing is enabled.
By default, an object‘s overview form is displayed first. You can, however, configure
the program to show the edit form for the object first, which allows faster editing. In
order to do this quick edit mode has to be enabled. Quick edit mode is indicated by an
additional icon in the program’s status bar.

l

l

l

Show "Getting Started": Specifies whether the Getting Started category is
shown or hidden.
Show system data: Specifies whether comprehensive system information such as
system tables, script occurrences, preprocessor dependencies are shown.
Enable list limit: Specifies whether the number of elements shown in the result list
and list items in controls should be limited.
If this option is enabled, the number of elements must be entered. To do this,
you can choose between the global system settings or the local, personal setting
for the user.
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l

Use system settings: Specifies whether the system settings should be used for the
list limit.
If this option is activated, then the global system settings from the Common |
DBConnection | ListLimit configuration parameter are used. If the number of
results is greater than the defined number, a filter dialog opens.

l

Objects: Personal setting for the object list limit. If the number of results is greater
than the defined number, a filter dialog opens.

Usage
l

l

Form history length: Number of forms available to browse through in the form
history. You find the form history in the menus attached to the <Back> and
<Forward> buttons in the main toolbar.
Entries in the search history: Number of entries available in the search history.

Related topics
l

Designer program settings on page 84

General program settings in the Designer
On the Program tab, enter the common program settings. These settings are saved in the
registry database on the workstation.

Language settings
l

l

Language: Language used for formatting data, such as date formats, time formats,
and number formats.
Other user interface language:Language for the user interface. The initial
program login uses the system language for the user interface. Changes to the
language settings take effect after the program has been restarted.The language is
set globally for all One Identity Manager programs, which means the language
setting does not have to be configured for each program individually.

Designer database settings
l

Load all system data at program startup: Set the loading behavior for
system data.
If this option is not enable, only the tables that are absolutely necessary are loaded
when the Designer starts. The rest of the table are loaded in background and the user
can already start using the program. The progress of the filling procedure is shown in
the program’s status bar.
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If this option is enabled, all tables are loaded when the program starts. The user
cannot start using the program until all the tables have been loaded. The changes
take effect once the Designer has restarted.
l

Load BLOB fields from database on program start: If this option is not
enabled, the contents of binary fields are only loaded when they are required.
If the option is enable, this data is already loaded at program startup. The means
that program startup takes longer.
The changes take effect once the Designer has restarted.

l

Save databases locally: If this option is enabled, the internal database is not
deleted when the program ends. This accelerates restarting the program the next
time since only the changes connected with the One Identity Manager database need
to be reloaded.
If the option is not enabled the internal database is deleted from the hard disk when
the program ends. This means that all the data has to be loaded from the One
Identity Manager database when the program is restarted.

l

Use RAM to store the system data (no crash recovery): If this option is not
enabled, the internal database is saved on the workstation hard disk.
If the option is enabled, the internal database is loaded into the workstation’s RAM.
In this case the database cannot be restore if the program crashes.
The changes take effect once the Designer has restarted.

l

l

Database directory: If the Save database locally option is enabled, the internal
database is stored in the %LocalAppData%\One Identity\One Identity
Manager\Designer\Cache directory. You save the database somewhere else by
selecting another database directory.
Clear local cache: Click the button to empty the local cache directory
%LocalAppData%\One Identity\One Identity Manager\Cache.

Related topics
l

General tips for the Designer on page 80

l

Designer program settings on page 84

Logging and committing objects in the
Designer
All changed objects in the Designer are created in the internal database. Permissions,
formatting rules and side-effects of the Customizer are taken into consideration. Changes
made by the user are also recorded in a change log.

One Identity Manager 8.2.1 User Guide for One Identity Manager
Tools User Interface
Working with the Designer

87

To display change data in the Designer
l

In the Designer, select the Database > Commit to database menu item.

The entries in the change log are grouped by editor. Actions (add, change, and delete) that
have been run and changes to the object’s properties with old and new values are displayed
in the log.
Table 42: Icons in the change log
Icon

Description
Adds the object.
Deletes the object.
The object has been changed.

The following functions are available in the change log:
l

Enable and disable individual changes
You can disable individual changes in the change log. These changes are not
transferred to the One Identity Manager database when the data is saved. You can
however, re-enable changes at a later date. You can enable or disable each change
using the corresponding icon in the change log toolbar.

l

Define change label
It is also possible to create a group of all the changes in the change log,
under one label.
l

l

Before saving the recorded changes in the change log, select the required
change label in the Change label menu.
To assign individual changes to different change labels, use the Special
change label context menu entry in the change log.

When the changes are transferred to the One Identity Manager database, the change
label is applied to the relevant changes. For more information about working with
change labels, see the One Identity Manager Operational Guide.
l

Saves changes
All changes are saved to the One Identity Manager database as specified. This is
done at object level so that, for example, processes are generated and formatting
rules are observed. The principle "last writer wins" applies here as opposed to the
previous object processing. That means that changes made by a user to object
properties in the mean time are overwritten.

Table 43: Functions in the change log toolbar
Icon Description
Enables change/section.
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Icon Description
Ignores change/section.
Edit a change label.
Specifies a default change label. This change label is used for all subsequent
changes.

Related topics
l

General tips for the Designer on page 80

Designer-internal full text search
Use full-text search to look for entries within the internal Designer database. You will find
the full text search on its own menu bar in the Designer.
To search for a term
l

Enter your search term in the Search field.
You can enter more than one partial terms. You can use * as a wildcard. Case
sensitivity is not taken into account. Entries are searched for that contain all the
partial terms given.

The objects found are entered in a list as you enter the search term.
Figure 26: Displaying the source

l

l

The icon to the left of the entry shows the entry’s object type (table),e.g. a process,
a table or a menu item.
The source that the object is extracted from is shown to the right of the entry. The
search term is highlighted by an underline.

l

Database tables, object relations and the exact source are also displayed in a tooltip.

l

Double-click an entry to switch to the corresponding object.
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If no entries are found for a search term, the system makes suggestions that you can use
as search terms by double-clicking.
Figure 27: Suggestions for search terms

If you have selected an entry, the search term is added to the search history and is
therefore available for further searches.
l

Open the search history with the arrow in the search field.

l

When you select an entry, all available sources are shown.

The number of entries in the search history depends on your program settings.
Figure 28: Search history

TIP: Update the full text catalog of the Designer database if you need to include objects
in the search that have been edited after the program started, like new processes or
column names. You do this with Update index, in the search history.

User-defined filters in the Designer
It is possible to limit the number of list entries in certain the Designer editors by using a
filter. After creating a filter, the filter conditions are immediately implemented on the set
of result currently displayed. A filter remains in use until you reset it.
The main components of a user filter are:
l

A search in the objects' display values

l

A customized search condition (where clause)

l

A full text search

You have the option to set up ad-hoc filters and permanent filters. Ad hoc filters are used
for a one-off reduction of list entries. These filters are not saved and are applied to the
data immediately.
Create a permanent filter if you want to reuse certain search queries on a frequent
basis. Permanent filters are saved in the user configuration and therefore are always
available for use.
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Detailed information about this topic
l

Using Adhoc filters in the Designer on page 91

l

Creating filter queries using wildcards in the Designer on page 91

l

Creating filter queries in the Designer using SQL conditions on page 92

l

Creating filter queries using full-text search in the Designer on page 93

l

Applying filters in the Designer on page 94

l

Publishing filters in the Designer on page 94

Using Adhoc filters in the Designer
Ad hoc filters are used for a one-off reduction of list entries. These filters are not saved and
are applied to the data immediately. The WHERE clause wizard helps you formulate a
condition for database queries. The complete database query is composed internally.
To use an ad-hoc filter in the Designer
1. In the Designer, select the Filter > Define filter menu item.
2. In the Where Clause Wizard, create the filter condition.
IMPORTANT: Enter the condition for limiting the result set in SQLite notation. The
condition is defined as a valid where clause for database queries. The condition relates to
the selected database table found that is determined when the editor starts.

Related topics
l

Wizard for entering database queries on page 44

Creating filter queries using wildcards in
the Designer
The system searches for the search term in the display values of the selected object
definition, using the wildcards.
To create a filter query using placeholders in the Designer
1. In the Designer, select the Filter > Manage filters menu.
2. Click New filter.
3. In the Define a filter dialog, select the Wildcard filter method.
4. In the Filter parameter pane, enter the following information.
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l

l

Filter objects of: The object definition for the list is already selected.
Search pattern: Enter the search pattern. You can use * as a wildcard in the
search pattern.
Examples:
Pattern* - searches for all entries whose display value starts with the
Pattern string
*Pattern - searches for all entries whose display value ends with the
Pattern string
*Pattern* - searches for all entries whose display value contains the
Pattern string
Pattern - searches for all entries whose display value matches the
Pattern string

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.
6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.
8. Select the Database > Save to database and click Save.

Related topics
l

Creating filter queries in the Designer using SQL conditions on page 92

l

Creating filter queries using full-text search in the Designer on page 93

l

Applying filters in the Designer on page 94

l

Publishing filters in the Designer on page 94

Creating filter queries in the Designer using
SQL conditions
A condition is used to filter all entries that match the specified condition according to the
selected object definition.
To create a filter query using a SQL condition in the Designer
1. In the Designer, select the Filter > Manage filters menu.
2. Click New filter.
3. In the Define a filter dialog, select the SQL filter method.
4. In the Filter parameter pane, enter the following information.
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l

l

Filter objects of: The object definition for the list is already selected.
Search pattern: Enter the condition. Enter the condition as a valid database
query WHERE clause. You can enter the database queries as a SQL query
directly or compile the database queries with a wizard. Use the Expert view
and Simple view button to switch to the appropriate view.

5. To save the filter, enter a name and a description for the search filter in the Save
filter pane and click Save.
6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.
8. Select the Database > Save to database and click Save.

Related topics
l

Creating filter queries using wildcards in the Designer on page 91

l

Creating filter queries using full-text search in the Designer on page 93

l

Applying filters in the Designer on page 94

l

Publishing filters in the Designer on page 94

Creating filter queries using full-text search
in the Designer
NOTE: To use the full-text search, you must run the program over an application server
with an installed search service. For detailed information about installing an application
server for full text search, see the One Identity Manager Installation Guide.
A search query using full-text search, searches for the specified search term in all columns
of the selected object definition that are indexed for full-text search. For detailed
information about configuring columns for the full text search, see the One Identity
Manager Configuration Guide.
To create a filter query in the Designer using the full-text search
1. In the Designer, select the Filter > Manage filters menu.
2. Click New filter.
3. In the Define a filter dialog, select the Full text filter method.
4. In the Filter parameter pane, enter the following information.
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l

l

Filter objects of: The object definition for the list is already selected.
Search string: Enter the search term. The use of wild cards is permitted. For
examples, refer to Rules and examples for the full-text search on page 75.

5. In the Save filter pane, enter a name and a description for the search filter and
click Save.
6. (Optional) To make the filer available to all users
a. Click Publish.
b. Confirm the security prompt with Yes.
7. (Optional) To apply the filter immediately, click Filter.
8. Select the Database > Save to database and click Save.

Related topics
l

Creating filter queries using wildcards in the Designer on page 91

l

Creating filter queries in the Designer using SQL conditions on page 92

l

Applying filters in the Designer on page 94

l

Publishing filters in the Designer on page 94

Applying filters in the Designer
To use a saved filter in the Designer
1. In the Designer, select the Filter > Manage filters menu.
2. Double-click the search filter in the Saved filters pane.
3. Click Filter.

Related topics
l

Creating filter queries using wildcards in the Designer on page 91

l

Creating filter queries in the Designer using SQL conditions on page 92

l

Creating filter queries using full-text search in the Designer on page 93

Publishing filters in the Designer
NOTE: To create, edit, and delete public filters, the user requires the Option to define,
modify, and delete public filters. program function. (Common_PublicFilterDefine).
You can make filters available to all users by publishing them. You have the option to
publish a filter when you create it. Afterward, you can also publish a private filter.
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To publish a filter in the Designer
1. In the Designer, select the Filter > Manage filters menu.
2. Double-click the search filter in the Saved filters area.
3. Click Publish.
4. Confirm the security prompt with Yes.
5. Select the Database > Save to database and click Save.

Related topics
l

Creating filter queries using wildcards in the Designer on page 91

l

Creating filter queries in the Designer using SQL conditions on page 92

l

Applying filters in the Designer on page 94

The editors in the Designer
The Designer provides various editors for the One Identity Manager system configuration.
The functionality and the mode of operation of the editors depends on the different
configuration requirements. When you select an object in the navigation view, the available
editors are displayed together with the tasks that can be run.
Table 44: Designer editors
Editor

Description

Object Editor

The Object Editor is provided for editing single objects. All properties of
an object are represented in table form and can be edited depending on
the permissions situation. In addition, properties such as edit permissions
and column definitions are shown. For more information, see Working
with the Object Editor on page 97.

List Editor

The List Editor is used to display result lists and to quickly edit objects and
object relations. Object properties are displayed in tabular form but there
is no additional information about each property as in the Object Editor.
For more information, see Working with the List Editor on page 98.

SQL Editor

You can use the SQL Editor to run database queries against the internal
Designer’s SQLite database. For more information, see Working with the
SQL Editor on page 102.

User &
Permissions
Group Editor

Use the User & Permissions Group Editor to create and edit permissions
groups and the system user. For more information, see the One Identity
Manager Authorization and Authentication Guide.

User
Interface

Use the User Interface Editor to edit the navigation of the One Identity
Manager tools. For more information, see the One Identity Manager
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Editor

Description

Editor

Configuration Guide.

Form Editor

Use the Form Editor to create and edit the interface forms, such as the
main data forms or assignment forms. For more information, see the One
Identity Manager Configuration Guide.

Overview
Form Editor

Use the Overview Form Editor to create overview forms. For more information, see the One Identity Manager Configuration Guide.

Permissions
Editor

Use the Permissions Editor to edit the permissions structure of the permissions groups and system user. For more information, see the One Identity
Manager Authorization and Authentication Guide.

Process
Editor

The Process Editor is the tool that you use to define and change processes
in One Identity Manager. For more information, see the One Identity
Manager Configuration Guide.

Job Server
Editor

You use the Job Server Editor to edit the Job server attributes and the One
Identity Manager Service configuration file. For more information, see the
One Identity Manager Configuration Guide.

Language
Editor

For the translation of captions, use the Language Editor. For more information, see the One Identity Manager Configuration Guide.

Schema
Editor

The Schema Editor displays an overview of the entire One Identity
Manager database model. Schema Editor is used to customize table and
column definitions to suit the customer. For example, you can define
formatting rules or formatting scripts with the Schema Editor. For more
information, see the One Identity Manager Configuration Guide.

Configuration The Configuration Parameter Editor provides an overview of all the configParameter
uration parameters in the One Identity Manager and their current values.
Editor
For more information, see the One Identity Manager Configuration Guide.
Script Editor

Use the Script Editor to create, edit, and test the custom scripts. For more
information, see the One Identity Manager Configuration Guide.

Consistency
Editor

Use the Consistency Editor to analyze database object for data consistency. A number of tests are offered to test the database and if necessary
run a repair. For more information, see the One Identity Manager Operational Guide.

Mail
Template
Editor

Use the Mail Template Editor to create and edit mail templates. For more
information, see the One Identity Manager Operational Guide.
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Working with the Object Editor
The Object Editor is provided for editing single objects. All properties of an object are
represented in table form and can be edited depending on the permissions situation. In
addition, properties such as edit permissions and column definitions are shown.

Detailed information about this topic
l

Object Editor menu items on page 97

l

Multiple object edit in the Object Editor on page 98

Object Editor menu items
When the editor starts, the following menu items are available in the Designer.
Table 45: Menu items added by the editor
Menu

Menu
item

Meaning

Object

New

Creates a new object.

Save

Saves all changes to an object.

Delete

Deletes current object.

Discard

Returns object to previous state.

Reload
object

Updates the object view.

Options Group
view

The object properties are displayed as groups.

Column
names

Column display text is shown. If the option is not enabled, the
technical names according to the One Identity Manager schema are
shown.

Primary
key

Shows or hides the primary key.

Extended Shows or hides the extended column properties.
Help

Object
Editor
help

Opens the editor help.
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Table 46: Meaning of toolbar icons
Icon Meaning
The object properties are displayed as groups.
Displays caption/technical name depending on the One Identity Manager schema.
Shows/Hides primary keys.
Shows/hides the extended column properties.
Creates object.
Saves changes.
Deletes object.
Resets object to previous state (lose changes).
Updates object view.

Multiple object edit in the Object Editor
It is possible to edit more than one object of the same object type at the same time in the
Object Editor.
1. Use Shift + select or Ctrl + select to select the entries in the result list.
2. Open the editor from the task view,
The task name contains the number of selected objects. Input fields that have different
values are marked in color. The values entered and saved in the fields are stored for
all objects.

Working with the List Editor
The List Editor is used to display result lists and to quickly edit objects and object relations.
Object properties are displayed in tabular form but there is no additional information about
each property as in the Object Editor.

Detailed information about this topic
l

List Editor menu items on page 99

l

Functions in the List Editor result list on page 99

l

Configuring columns for List Editor result lists on page 100

l

Multiple editing of list entries in the List Editor on page 101

l

Displaying object relations in the List Editor on page 101
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List Editor menu items
When the editor starts, the following menu items are available in the Designer.
Table 47: Menu items added by the editor
Menu

Menu item

Object New

Filter

View

Help

Meaning
Creates a new object.

Delete

Deletes current object.

Reload object

Updates the object view.

Define filter

Opens a dialog window for creating an ad hoc filter.

Delete filter

Deletes the filter.

Manage filters

Opens a dialog window for creating permanent filters.

Properties

Shows or hides the edit view

Select columns...

Opens a dialog window for selecting columns to be displayed
in the list.

Select table
relations

Opens a dialog box for selecting object relation to view.

List Editor help

Opens the editor help.

Table 48: Meaning of toolbar icons
Icon Meaning
Creates object.
Deletes object.
Copies object to the clipboard.
Paste the object or relation from the clipboard. Next to the icon there is a menu to
select the type from.
Updates object view.
User-defined filter for displaying objects.
Resets custom filter.

Functions in the List Editor result list
The entries in the result list of the List Editor are displayed with a valid name tag. If an
object is selected in the result list, the object properties and object relations are shown in
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the edit view. You can limit the number of entries in the result list by setting a filter. For
this you can use an ad hoc filter or a permanent filter.
Table 49: Entries in the result list context menu
Context Menu
Item

Meaning

New

Inserts a new object.

Delete

Deletes selected object.

Copy

Copies the selected object into the clipboard.

Paste

Inserts the copied object from the clipboard.

Properties

Displays the object properties of the selected entry.

Select columns...

Opens a dialog window for selecting columns to be displayed in the
list.

Navigation

Shows all other editors that can be used with the selected object.

TIP:
l

l

In the table header for the result list, click on a column to sort it by the
selected column.
You can display further object properties in the result list.

Related topics
l

Configuring columns for List Editor result lists on page 100

Configuring columns for List Editor result
lists
To display object properties
1. In the Designer, select the View > Select column menu item.
2. You specify which object properties should be additionally shown in which order in
the result list. You can also enter the column width and alignment of the column
description.
3. Click OK.
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Table 50: Meaning of toolbar icons
Icon Meaning
Inserts column in view.
Removes column from view.
Moves column up.
Moves column down.
Specifies how columns are labeled. If selected the column names are displayed. If
this option is not active, the identifiers from the data model are shown.
The column display is reset to the default settings.

Multiple editing of list entries in the List
Editor
It is possible to edit more than one object of the same object type at the same time in the
List Editor.
l

Use Shift + select or Ctrl + select to select the entries in the result list.

Entries in the list that have different input are specially labeled in the edit view. The values
entered and saved in the fields are stored for all objects.

Displaying object relations in the List Editor
To display object relations
1. Select the View > Select table relations menu item.
2. You can specify which object relations are displayed in the List Editor.
Table 51: Entries in the dialog's context menu
Context
menu item

Meaning

Show relation

The editing window for the object relationship is displayed in the
editing view of the editor.

Hide relation

The editing window for the object relationship is hidden in the
editing view of the editor.

3. Click OK.
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Each relation is shown in its own edit window. To change the assignments, double-click the
icon or choose the required option from the context menu.
Table 52: Meaning of icons in the view
Icon

Meaning
Object is assigned to the selected base object.
Object is not assigned to all selected base objects (multiple entry editing).
Object is not assigned to an object.

Table 53: Items in the view’s context menu
Context Menu Item

Meaning

Assign

Assign object to the selected base object.

Remove

Remove assignment of object to base object.

Properties

Displays the object properties of the selected entry.

Navigation

Shows all other editors that can be used with the selected object.

Working with the SQL Editor
You can use the SQL Editor to run database queries against the internal Designer’s SQLite
database. This internal database contains the schema and the files from the system
components of the connected One Identity Manager database.
NOTE: To use the SQL Editor in the Designer, the user requires the program function
Option to call the SQL editor in Designer to run SQL statements in the SQL
database (Designer_SQLEditor).

Detailed information about this topic
l

SQL Editor menu items on page 102

l

Running database queries in SQL Editor on page 104

SQL Editor menu items
When the editor starts, the following menu items are available in the Designer.
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Table 54: Menu items added by the editor
Menu Menu item

Meaning

Edit

Undo

Restores state before last change.

Redo

Restores state after last change.

Cut

Deletes marked code but save in clipboard.

Copy

Copies selected code to the clipboard.

Paste

Inserts data stored in the clipboard from copy or cut.

Delete

Deletes selected code.

Reduce text indent

Reduces the indent of the selected code in the query
window.

Increase text
indent

Increases the indent of the selected code in the query
window.

Run (F5)

Runs the query.

Show as table

Switches output between text and table.

SQL Editor help

Opens the editor help.

SQL

Help

Table 55: Meaning of toolbar icons
Icon

Meaning
Undoes last change.
Redoes last change.
Cuts selected code.
Copies selected code into clipboard.
Inserts code from clipboard.
Deletes selected code.
Reduces the indent of the selected code in the query window.
Increases the indent of the selected code in the query window.
Switches output between text and table.
Runs the query.
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Running database queries in SQL Editor
To run a database query
l

l

l

Start the SQL Editor in the Designer by selecting the Database > Run SQL
Editor menu item.
Enter your database query in SQLite notation in the query window. The editor
supports highlighting.
Run the database query using F5.
The result are displayed in the results window.
TIP: To sort by a specific column, click on that column in the table header.
TIP: Use Ctrl + C to copy the individual entries or lines to the clipboard. Select
Shift + Select or Ctrl + select to select multiple lines in the table.
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About us

About us

One Identity solutions eliminate the complexities and time-consuming processes often
required to govern identities, manage privileged accounts and control access. Our solutions
enhance business agility while addressing your IAM challenges with on-premises, cloud and
hybrid environments.

Contacting us
For sales and other inquiries, such as licensing, support, and renewals, visit
https://www.oneidentity.com/company/contact-us.aspx.

Technical support resources
Technical support is available to One Identity customers with a valid maintenance contract
and customers who have trial versions. You can access the Support Portal at
https://support.oneidentity.com/.
The Support Portal provides self-help tools you can use to solve problems quickly and
independently, 24 hours a day, 365 days a year. The Support Portal enables you to:
l

Submit and manage a Service Request

l

View Knowledge Base articles

l

Sign up for product notifications

l

Download software and technical documentation

l

View how-to videos at www.YouTube.com/OneIdentity

l

Engage in community discussions

l

Chat with support engineers online

l

View services to assist you with your product
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